Foros

Inicio » Liferay Portal » Português

Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
Ruchi Dubey
Localization liferay6
15 de marzo de 2012 7:15
Respuesta

Ruchi Dubey

Ranking: New Member

Mensajes: 19

Fecha de incorporación: 28 de febrero de 2012

Mensajes recientes

Hi,
I have done localization in my portlet like this:
In portlet.xml :
<supported-locale>en</supported-locale>
<supported-locale>fr</supported-locale>
<resource-bundle>content/Language</resource-bundle>

I have a Language.properties file in in content folder inside my docroot at the correct location. i have tried a lot but localization is not at all happening.I am gettings labels like ???Label1???.

Please help ...
David H Nebinger
RE: Localization liferay6
15 de marzo de 2012 7:18
Respuesta

David H Nebinger

Ranking: Liferay Legend

Mensajes: 7252

Fecha de incorporación: 1 de septiembre de 2006

Mensajes recientes

So do you have the content/Language_fr.properties file w/ the entries for each label?
Hitoshi Ozawa
RE: Localization liferay6
15 de marzo de 2012 7:34
Respuesta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensajes: 7954

Fecha de incorporación: 23 de marzo de 2010

Mensajes recientes

Did you create both Language_en.properties and Language_fr.properties files?
Is "Label1" one of your key?

Did you look at the sample in Liferay svn? (user:guest, no password)
http://svn.liferay.com/repos/public/plugins/trunk/portlets/test-localized-portlet/docroot/
Ruchi Dubey
RE: Localization liferay6
15 de marzo de 2012 22:34
Respuesta

Ruchi Dubey

Ranking: New Member

Mensajes: 19

Fecha de incorporación: 28 de febrero de 2012

Mensajes recientes

Thanks David and Hitoshi for your replies
Yes I have Language_en and Language_fr properties files in my content folder.
Label1 , I had given as an example.Let me give you some exact data:
I have labels like <fmt:message key="ao.portlet.category" /> in my jsp where ao.portlet.category is a key in Language.en and Language.fr properties files and have given resource bundle in portlet.xml as I have said in earlier post. The strange thing is I have done the same in other portlets and things are working fine.Only in this portlet it is not working.
Also to add, I have done only these three things, is there anything else I am missing?