Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
toggle
plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 15 de diciembre de 2012 9:16
RE: plugins not working on 6.1CE or 6.1CE-patched versions Drew Blessing 15 de diciembre de 2012 9:18
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 15 de diciembre de 2012 14:32
RE: plugins not working on 6.1CE or 6.1CE-patched versions Juan Gonzalez 15 de diciembre de 2012 16:29
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 15 de diciembre de 2012 18:45
RE: plugins not working on 6.1CE or 6.1CE-patched versions Hitoshi Ozawa 16 de diciembre de 2012 14:00
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 17 de diciembre de 2012 2:48
RE: plugins not working on 6.1CE or 6.1CE-patched versions Juan Gonzalez 17 de diciembre de 2012 0:44
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 17 de diciembre de 2012 2:56
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 17 de diciembre de 2012 7:18
RE: plugins not working on 6.1CE or 6.1CE-patched versions Hitoshi Ozawa 17 de diciembre de 2012 13:49
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 17 de diciembre de 2012 13:55
RE: plugins not working on 6.1CE or 6.1CE-patched versions Hitoshi Ozawa 18 de diciembre de 2012 5:55
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 18 de diciembre de 2012 11:02
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 19 de diciembre de 2012 15:15
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 17 de diciembre de 2012 20:35
RE: plugins not working on 6.1CE or 6.1CE-patched versions Juan Gonzalez 17 de diciembre de 2012 23:51
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 18 de diciembre de 2012 11:05
RE: plugins not working on 6.1CE or 6.1CE-patched versions Alejandro Espartaco Alvarez 19 de diciembre de 2012 12:09
RE: plugins not working on 6.1CE or 6.1CE-patched versions gordon daniels 19 de diciembre de 2012 15:12
RE: plugins not working on 6.1CE or 6.1CE-patched versions Hitoshi Ozawa 19 de diciembre de 2012 15:16
RE: plugins not working on 6.1CE or 6.1CE-patched versions Julio Camarero 24 de febrero de 2013 3:47
gordon daniels
plugins not working on 6.1CE or 6.1CE-patched versions
15 de diciembre de 2012 9:16
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Hi All,

I cannot get plugins working on the above versions. Has anyone successfully installed and configured plugins on the above versions?

thanks
Drew Blessing
RE: plugins not working on 6.1CE or 6.1CE-patched versions
15 de diciembre de 2012 9:18
Respuesta

Drew Blessing

Ranking: Junior Member

Mensajes: 79

Fecha de incorporación: 27 de enero de 2011

Mensajes recientes

Can you please provide some details as to what you're seeing? I can successfully deploy plugins on 6.1 CE. Error messages and/or stack traces are helpful.
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
15 de diciembre de 2012 14:32
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

thanks for the reply. I have been trying to determine if it was my environment. Nothing in logs at all. The plugins after config show nothing. Your reply helps. Now I know it must be my implementation.

Did you build plugins from source? I have been using war file.

thanks
Juan Gonzalez
RE: plugins not working on 6.1CE or 6.1CE-patched versions
15 de diciembre de 2012 16:29
Respuesta

Juan Gonzalez

LIFERAY STAFF

Ranking: Liferay Legend

Mensajes: 2350

Fecha de incorporación: 28 de octubre de 2008

Mensajes recientes

No problem at all.

Probably a problem in your environment. After this problem and other problem you told about a jsp being removed, I am starting to be sure about that...
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
15 de diciembre de 2012 18:45
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Juan: I came to same conclusion. I am in the process of setting up another VS to install LR and see what happens.

thanks for your time
Hitoshi Ozawa
RE: plugins not working on 6.1CE or 6.1CE-patched versions
16 de diciembre de 2012 14:00
Respuesta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensajes: 7949

Fecha de incorporación: 23 de marzo de 2010

Mensajes recientes

Is this for all plugins or a particular plugin? I haven't had any difficulties deploying portlets in Liferay 6.1.0 GA1 and Liferay 6.1.1 GA2.
Also, how are you trying to deploy your plugins? Are you copying it to the deploy folder? Is the war file deleted after few seconds and nothing appears?
Juan Gonzalez
RE: plugins not working on 6.1CE or 6.1CE-patched versions
17 de diciembre de 2012 0:44
Respuesta

Juan Gonzalez

LIFERAY STAFF

Ranking: Liferay Legend

Mensajes: 2350

Fecha de incorporación: 28 de octubre de 2008

Mensajes recientes

gordon,

Do you have some ext-plugin or hook plugin? Seems very weird...

If you want you can install liferay from scratch in other environment, I will help for any problems you have.
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
17 de diciembre de 2012 2:48
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Hitoshi: this is just the facebook plugins.

thanks
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
17 de diciembre de 2012 2:56
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Juan: You are too kind. No I do not have any hooks or ext plugins. Both installs are basic LR with classic theme. I've easily have installed LR over a hundred times. I play around alot with it in virtual servers. I've never seen the problems I am having but am working on setting up new environment.

I first noticed problems when I switched over to patched version of LR. I don't think it has anything to do with that version. I installed a vanilla LR and am having same problems. This is on my desktop developtment system. I an now setting up a virtual server for development that will have patched version. That way I am off my desktop and will start trying to figure out what is broken there.

Thank you for your offer. I will set up new install and if I run into issues will post them.

thanks again.
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
17 de diciembre de 2012 7:18
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Hi All,

I believe the issues I have been having are due to the way the fb.war file is packaged. I will give you data points on why I think this. Anyone reading this post, is aware I thought it was my environment. I no longer think that is the case.

1. I downloaded and installed fb-integration-portlet-6.1.0.1.2.war. I then configured the portlets as follows:
1.1 Activity Portlet - unchecked 'sdk facebook' and configured url as organization url. It worked .
1.2 Like Box Portlet - unchecked 'sdk facebook' and configured with https://www.facebook.com/XXXX. It worked.
Comment: I believe the reason these two portlets did not work before is because the portlets default to having the 'sdk facebook' ticked. I don't have a facebook sdk anything, not sure what that entails. However, as soon as I un-ticked them, they worked.

2. The following portlets do not work: Like Button, Comments, and Face Pile.

3. I removed all portlets and unregistered the 1.2 war version. I then downloaded and installed fb-integration-portlet-6.1.0.1.war file.
3.1 Activity Portlet worked with the above config.
3. 2 Like Box Porltet worked with the above config.
3.3 Comment Box worked using origination's url.
3.4 Like Button and Face Pile do not.

So, the reason I think its the war file package is based on the above. As one can see three portlets work in version 6.1.0.1. I welcome any comments as Facebook integration is very important to me.

thanks
Hitoshi Ozawa
RE: plugins not working on 6.1CE or 6.1CE-patched versions
17 de diciembre de 2012 13:49
Respuesta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensajes: 7949

Fecha de incorporación: 23 de marzo de 2010

Mensajes recientes

I just use widgets in my portlets. Very clean and very easy to develop and maintain.
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
17 de diciembre de 2012 13:55
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Hitoshi: Hi - what widgets?
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
17 de diciembre de 2012 20:35
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Just set up a new server and did an install of 6.1ga2 and 6.1ga2patched. I still have the same issues with the portlets. Any thoughts?
Juan Gonzalez
RE: plugins not working on 6.1CE or 6.1CE-patched versions
17 de diciembre de 2012 23:51
Respuesta

Juan Gonzalez

LIFERAY STAFF

Ranking: Liferay Legend

Mensajes: 2350

Fecha de incorporación: 28 de octubre de 2008

Mensajes recientes

Did you try installing those Liferay without the facebook portlet or any other custom portlet?

You can tell us what steps do you take, if you do some "custom" configuration, etc.
Hitoshi Ozawa
RE: plugins not working on 6.1CE or 6.1CE-patched versions
18 de diciembre de 2012 5:55
Respuesta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensajes: 7949

Fecha de incorporación: 23 de marzo de 2010

Mensajes recientes

Facebook widget:
http://developers.facebook.com/docs/reference/plugins/like-box/

Google has gadgets too. Just page the <script> tag to the webcontent source code or create a new portlet using Liferay IDE wizard and paste the code to the generated view.jsp page.

http://www.google.com/ig/directory?synd=open
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
18 de diciembre de 2012 11:02
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Hitoshi: thanks for the links. Installed them and they work fine.

thanks again
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
18 de diciembre de 2012 11:05
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Juan: Hi - yes I installed without fb porlets. And there are no custom portlets. I would like to post steps of sever build with 6.1ce-patched, but I don't think this project forum is the right place.

Perhaps you could suggest where I should post.

thanks
Alejandro Espartaco Alvarez
RE: plugins not working on 6.1CE or 6.1CE-patched versions
19 de diciembre de 2012 12:09
Respuesta

Alejandro Espartaco Alvarez

Ranking: New Member

Mensajes: 11

Fecha de incorporación: 10 de septiembre de 2012

Mensajes recientes

Gordon: Hi, how about to send them to be posted here...

https://www.lcepatchers.org/guidelines

BR
Alejandro
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
19 de diciembre de 2012 15:12
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Alejandro: Hi - that's fine by me, but not sure if that is a good place since its about guidelines. What do you think?
Hitoshi Ozawa
RE: plugins not working on 6.1CE or 6.1CE-patched versions
19 de diciembre de 2012 15:16
Respuesta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensajes: 7949

Fecha de incorporación: 23 de marzo de 2010

Mensajes recientes

It's not really a patched version issue but more of a facebook portlet issue. Facebook portlet isn't installed in liferay but default. It's just that some of these portlets are not too well written.
gordon daniels
RE: plugins not working on 6.1CE or 6.1CE-patched versions
19 de diciembre de 2012 15:15
Respuesta

gordon daniels

Ranking: Liferay Master

Mensajes: 704

Fecha de incorporación: 23 de agosto de 2008

Mensajes recientes

Bump: So, I have two portlets that work in 1.2 verison and three portlets in .1.1 version.

Has anyone installed all portlets in 6.1ga2ce without a Facebook sdk account? I don't have one and I think this is the problem. Any thoughts?
Julio Camarero
RE: plugins not working on 6.1CE or 6.1CE-patched versions
24 de febrero de 2013 3:47
Respuesta

Julio Camarero

LIFERAY STAFF

Ranking: Liferay Legend

Mensajes: 1659

Fecha de incorporación: 15 de julio de 2008

Mensajes recientes

Hi guys, there was an issue because facebook changed their API.

The plugins should be working fine now. The new version can be downloaded from here.

thanks!