Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
toggle
Roberto Tellado
Problemas de indexación
25 de mayo de 2010 0:14
Respuesta

Roberto Tellado

Ranking: Regular Member

Mensajes: 244

Fecha de incorporación: 15 de septiembre de 2009

Mensajes recientes

Hola,

Ahora me da también este error:

com.liferay.portal.kernel.search.SearchException: java.io.FileNotFoundException: no segments* file found in org.apache.lucene.store.jdbc.JdbcDirectory@10898e3: files:
DLFE-3947.pdf,

¿Qué es?

La indexación me esta volviendo loco.

Gracias a todos.

Saludos.
Juan Fernández
RE: Problemas de indexación
25 de mayo de 2010 0:39
Respuesta

Juan Fernández

LIFERAY STAFF

Ranking: Liferay Legend

Mensajes: 1227

Fecha de incorporación: 2 de octubre de 2008

Mensajes recientes

Hola Roberto:
parece que se han corrompido los índices de Lucene. Supongo que ya lo habrás hecho, pero ¿has lanzado la reindexación desde el panel de control para volver a empezar de cero?
Un saludo
Roberto Tellado
RE: Problemas de indexación
25 de mayo de 2010 0:41
Respuesta

Roberto Tellado

Ranking: Regular Member

Mensajes: 244

Fecha de incorporación: 15 de septiembre de 2009

Mensajes recientes

Sí, sí. Ya lo hemos hecho. Es que yo creo que ya hemos hecho de todo. Hasta el "pino" emoticon

A ver si me podéis echar una mano. Si necesitais más información contestaré enseguida a todas vuestras preguntas, con tal de solucionar este tema, porque me esta volviendo loco.

Gracias.

Saludos.
Roberto Tellado
RE: Problemas de indexación
25 de mayo de 2010 0:57
Respuesta

Roberto Tellado

Ranking: Regular Member

Mensajes: 244

Fecha de incorporación: 15 de septiembre de 2009

Mensajes recientes

Bueno, Juan, te conteste muy pronto y de hecho es que el error de los segments, no volvio a aparecer, aunque tampoco volvimos a subir ningún fichero. ¿Podría producirse solo a la hora de subir ficheros?

De todas formas, nos aparece mucho una excepcion: Unable to create a new writer. Y la excepción de LockObtainException.

Me he fijado que en las tablas de lucene de la base de datos, nos inserta un registro write.lock.

Hemos creado una issue y reabierto otra que había acerca de este tema.

http://issues.liferay.com/browse/LPS-9454

http://issues.liferay.com/browse/LEP-6078

Además se nos repiten mucho estas excepciones:

[JDBCExceptionReporter:101] Cannot insert duplicate key row in object 'intranet.DLFileRank' with unique index 'IX_CE705D48'

Your document seemed to be mostly unicode, but the section definition was in bytes

Nuestros principales problemas son con la document library y con los indices. El resto del gestor va bastante bien.

A ver si nos podeis echar una mano con esto.

Muchisimas gracias.

Saludos.
Juan Antonio Girón
RE: Problemas de indexación
11 de diciembre de 2012 5:30
Respuesta

Juan Antonio Girón

Ranking: New Member

Mensajes: 15

Fecha de incorporación: 10 de febrero de 2012

Mensajes recientes

Juan Fernández:
Hola Roberto:
parece que se han corrompido los índices de Lucene. Supongo que ya lo habrás hecho, pero ¿has lanzado la reindexación desde el panel de control para volver a empezar de cero?
Un saludo


Hola Juan,
tengo un entorno en cluster con los índices de Lucene configurados en modo jdbc y a menudo presenta problemas debido los índices de Lucene.

En determinadas ocasiones al publicar o guardar un borrador de un contenido tipo blog, se "corrompen" los índices y el portal deja de estar disponible. Para solventar este problema tengo que acceder al panel de control y ejecutar la reindexación. Una vez finalizado el proceso todo el contenido puede visualizarse correctamente incluido el nuevo contenido de tipo blog creado.
He tratado de localizar el problema, pero no encuentro el origen del problema. Me he planteado la posibilidad de desactivar Lucene para este tipo de contenido, aunque no sé si es posible.
También he visto algún hilo del foro que hace referencia a bugs relacionados con el almacenamiento de índices en base de datos, como por ejemplo la aparición del registro write.lock, que debe ser eliminado manualmente , no es así?

Puedes , por favor, ofrecerme alguna sugerencia para tratar de solventar este problema, muy grave para mi entorno.

Gracias.
Gustavo Fernández Gómez
RE: Problemas de indexación
11 de diciembre de 2012 5:43
Respuesta

Gustavo Fernández Gómez

Ranking: Regular Member

Mensajes: 190

Fecha de incorporación: 26 de octubre de 2007

Mensajes recientes

Buenas:

Sin ser especialmente catastrofista yo juraría que el modelo de persistencia de índices en base de datos, las veces que lo he probado, no funcionaba fino. Te recomendaría cambiar a otro de los modelos soportados por el producto.

* SOLR
* Indices en local en cada nodo replicados por el producto.

Ambos los he usado en instancias productivas y funcionan correctamente, el plugin web de solr para algunas versiones hace alguna cosa rara pero una vez puesto en marcha funciona bien y el de índices en local + replica es el que más veces he visto funcionando en entornos productivos con cluster.

un saludo
--gustavo
Roberto Tellado
RE: Problemas de indexación
11 de diciembre de 2012 6:55
Respuesta

Roberto Tellado

Ranking: Regular Member

Mensajes: 244

Fecha de incorporación: 15 de septiembre de 2009

Mensajes recientes

Hola,

Tengo una pregunta en referencia a tener los índices en local. ¿Cómo se configura eso de que haga la replica entre nodos? ¿O es algo automático?

Gracias.
Saludos.
Juan Gonzalez
RE: Problemas de indexación
11 de diciembre de 2012 10:19
Respuesta

Juan Gonzalez

LIFERAY STAFF

Ranking: Liferay Legend

Mensajes: 1846

Fecha de incorporación: 28 de octubre de 2008

Mensajes recientes

Aqui tienes una buena guia (no es tan automatico, aunque es facil):

http://www.liferay.com/documentation/liferay-portal/6.1/user-guide/-/ai/liferay-clusteri-3
Roberto Tellado
RE: Problemas de indexación
11 de diciembre de 2012 10:28
Respuesta

Roberto Tellado

Ranking: Regular Member

Mensajes: 244

Fecha de incorporación: 15 de septiembre de 2009

Mensajes recientes

Hola,

Estas propiedades, a partir de que versión están disponibles ¿?

Gracias.
Saludos.
Gustavo Fernández Gómez
RE: Problemas de indexación
11 de diciembre de 2012 11:13
Respuesta

Gustavo Fernández Gómez

Ranking: Regular Member

Mensajes: 190

Fecha de incorporación: 26 de octubre de 2007

Mensajes recientes

para la versión 5.2.3 ya había un plugin-web para solr, pero la replica de índices por cluster link no estaba disponible para la CE, en la EE sp3 o sp4 ya estaban accesibles las replicas sin problemas. En la 6.0 yo creo que ya funcionaba todo tanto en la CE como en la EE

Resumiendo creo que era algo como
Cluster link esta accesible para
* 6.0+ CE
* 5.2+ EE sp3
* 5.1+ EE sp4

plugin-web de solr
* 5.2+ CE
* 5.2+ EE