Foros

Inicio » Liferay IDE » English

Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
toggle
Gregory Amerson
Problem while installing Dynamic Web Module 2.5
22 de junio de 2010 13:42
Respuesta

Gregory Amerson

LIFERAY STAFF

Ranking: Liferay Master

Mensajes: 968

Fecha de incorporación: 16 de febrero de 2010

Mensajes recientes

Dave Weitzel:

I can create new hook project fine but when trying to create a new portlet project I get "Failed while installing Dynamic Web Module 2.5" error message (null pointer). I can see docroot/WEB-INF/src folder, JRE and docroot but no liferay jars or Portlet plugin APi files.


Could you do the following steps to try to help determine the reason for the error?

1. Open error log (Ctrl+3, type "Error Log")
2. Delete error log (red X)
3. Restart and try to replicate the problem
4. Capture the contents of the log (copy any errors logged) and paste them here.

That should help us figure out what is going wrong. Thanks!
Dave Weitzel
RE: Problem while installing Dynamic Web Module 2.5
23 de junio de 2010 11:28
Respuesta

Dave Weitzel

Ranking: Regular Member

Mensajes: 193

Fecha de incorporación: 18 de noviembre de 2009

Mensajes recientes

Here is content of the error log:

!ENTRY org.eclipse.jst.j2ee 4 0 2010-06-23 14:25:12.295
!MESSAGE Exception thrown.
!STACK 0
java.lang.NullPointerException: No IModelProvider exists for project P/newportlet-portlet of version: Dynamic Web Module 2.5
at org.eclipse.jst.j2ee.model.ModelProviderManager.getModelProvider(ModelProviderManager.java:99)
at org.eclipse.jst.j2ee.web.project.facet.WebFacetInstallDelegate.createWeb25DeploymentDescriptor(WebFacetInstallDelegate.java:220)
at org.eclipse.jst.j2ee.web.project.facet.WebFacetInstallDelegate.execute(WebFacetInstallDelegate.java:117)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.callDelegate(FacetedProject.java:1467)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.modifyInternal(FacetedProject.java:438)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.mergeChangesInternal(FacetedProject.java:1171)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.access$2(FacetedProject.java:1107)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject$5.run(FacetedProject.java:1089)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1800)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.mergeChanges(FacetedProject.java:1099)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProjectWorkingCopy.commitChanges(FacetedProjectWorkingCopy.java:1958)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProjectWizard.performFinish(ModifyFacetedProjectWizard.java:400)
at org.eclipse.wst.web.ui.internal.wizards.NewProjectDataModelFacetWizard.performFinish(NewProjectDataModelFacetWizard.java:279)
at com.liferay.ide.eclipse.project.ui.wizard.NewPluginProjectWizard.performFinish(NewPluginProjectWizard.java:180)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProjectWizard$3.run(ModifyFacetedProjectWizard.java:331)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1800)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProjectWizard$4.run(ModifyFacetedProjectWizard.java:345)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

!ENTRY org.eclipse.wst.common.project.facet.core 4 0 2010-06-23 14:25:12.368
!MESSAGE Failed while installing Dynamic Web Module 2.5.
!STACK 0
java.lang.NullPointerException
at org.eclipse.jst.j2ee.web.project.facet.WebFacetInstallDelegate.createWeb25DeploymentDescriptor(WebFacetInstallDelegate.java:247)
at org.eclipse.jst.j2ee.web.project.facet.WebFacetInstallDelegate.execute(WebFacetInstallDelegate.java:117)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.callDelegate(FacetedProject.java:1467)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.modifyInternal(FacetedProject.java:438)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.mergeChangesInternal(FacetedProject.java:1171)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.access$2(FacetedProject.java:1107)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject$5.run(FacetedProject.java:1089)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1800)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProject.mergeChanges(FacetedProject.java:1099)
at org.eclipse.wst.common.project.facet.core.internal.FacetedProjectWorkingCopy.commitChanges(FacetedProjectWorkingCopy.java:1958)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProjectWizard.performFinish(ModifyFacetedProjectWizard.java:400)
at org.eclipse.wst.web.ui.internal.wizards.NewProjectDataModelFacetWizard.performFinish(NewProjectDataModelFacetWizard.java:279)
at com.liferay.ide.eclipse.project.ui.wizard.NewPluginProjectWizard.performFinish(NewPluginProjectWizard.java:180)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProjectWizard$3.run(ModifyFacetedProjectWizard.java:331)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1800)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProjectWizard$4.run(ModifyFacetedProjectWizard.java:345)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Gregory Amerson
RE: Problem while installing Dynamic Web Module 2.5
23 de junio de 2010 11:33
Respuesta

Gregory Amerson

LIFERAY STAFF

Ranking: Liferay Master

Mensajes: 968

Fecha de incorporación: 16 de febrero de 2010

Mensajes recientes

Try this:

  1. Open new portlet plugin project wizard
  2. On 2nd page, change dynamic web module version to 2.4


See if that allows the wizard to continue.
Dave Weitzel
RE: Problem while installing Dynamic Web Module 2.5
24 de junio de 2010 7:08
Respuesta

Dave Weitzel

Ranking: Regular Member

Mensajes: 193

Fecha de incorporación: 18 de noviembre de 2009

Mensajes recientes

That seems to work
Thanks

starting to get to grips with both the IDE and how to extend Liferay
Gregory Amerson
RE: Problem while installing Dynamic Web Module 2.5
24 de junio de 2010 7:12
Respuesta

Gregory Amerson

LIFERAY STAFF

Ranking: Liferay Master

Mensajes: 968

Fecha de incorporación: 16 de febrero de 2010

Mensajes recientes

Glad you got up and running.
Robin Keith
RE: Problem while installing Dynamic Web Module 2.5
15 de diciembre de 2010 7:05
Respuesta

Robin Keith

Ranking: New Member

Mensajes: 7

Fecha de incorporación: 26 de octubre de 2010

Mensajes recientes

I also had this problem. I solved it by upgrading my Eclipse install from the plain java version to the java EE version (same version no. i.e. 3.6 32bit Windows). The java version doesn't have web tools - might be related to that.
Gregory Amerson
RE: Problem while installing Dynamic Web Module 2.5
15 de diciembre de 2010 8:26
Respuesta

Gregory Amerson

LIFERAY STAFF

Ranking: Liferay Master

Mensajes: 968

Fecha de incorporación: 16 de febrero de 2010

Mensajes recientes

Correct Keith, Liferay IDE requires the Web version of the Eclipse developer package. Theoretically it is possible to install Liferay IDE into a java only package and all the necessary dependencies should get downloaded but as you saw that doesn't exactly work. Using the Java for EE developers (web includes version) should always work.
Mohan Tyagi
RE: Problem while installing Dynamic Web Module 2.5
28 de septiembre de 2011 11:06
Respuesta

Mohan Tyagi

Ranking: New Member

Mensajes: 2

Fecha de incorporación: 28 de septiembre de 2011

Mensajes recientes

Hi Amerson,
after changing to dynamic web module version to 2.4,
will it work on other IDE which support dynamic web module version to 2.5

Thanks In advaced
Mohan
Gregory Amerson
RE: Problem while installing Dynamic Web Module 2.5
28 de septiembre de 2011 17:56
Respuesta

Gregory Amerson

LIFERAY STAFF

Ranking: Liferay Master

Mensajes: 968

Fecha de incorporación: 16 de febrero de 2010

Mensajes recientes

Hi Mohan,

The default Liferay Project is web facet version 2.5 but there is no reason it can't work with 2.4. However, the facet preference UI may not let you move it backwards, but there is no reason you can't edit the file manually if you run into problems
1<project>/.settings/org.eclipse.wst.common.project.facet.core.xml
and switch the jst.web facet to version 2.4
Joaquin Cabal
RE: Problem while installing Dynamic Web Module 2.5
16 de julio de 2012 14:59
Respuesta

Joaquin Cabal

Ranking: Junior Member

Mensajes: 51

Fecha de incorporación: 7 de septiembre de 2009

Mensajes recientes

You can see this Url where there is a solution:
http://www.liferay.com/community/forums/-/message_boards/message/14882483