Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
toggle
Aparna Ravidas
Lifaray displayed in strange way
12 de diciembre de 2011 13:21
Respuesta

Aparna Ravidas

Ranking: New Member

Mensajes: 9

Fecha de incorporación: 1 de diciembre de 2011

Mensajes recientes

Hi All..
I'm trying to install liferay community edition bundled with tomcat in windows 7 64 bit. with 64 bit jdk.when i ran the startup file from tomcat-6-0-29/bin with default configuration, it gives http :404 error( requested resource not found). but when i pointed to mysql database using portal-ext.properties , the http://localhost:8080 shows the liferay page but its looks very odd without any theme or css. i'm attaching the screenshot. its just showing some lines of text, text boxes for sign in..I'm able to sign in though. please help me to figure out what went wrong . thanks in advance
Adjunto

archivos adjuntos: screenshot.png (142,5k)
Ken Dong
RE: Lifaray displayed in strange way
12 de diciembre de 2011 13:52
Respuesta

Ken Dong

LIFERAY STAFF

Ranking: New Member

Mensajes: 6

Fecha de incorporación: 31 de agosto de 2010

Mensajes recientes

Sometimes you'll need to refresh the browser cache. Do you get the same thing when you open localhost:8080 in a different browser?
Aparna Ravidas
RE: Lifaray displayed in strange way
12 de diciembre de 2011 14:10
Respuesta

Aparna Ravidas

Ranking: New Member

Mensajes: 9

Fecha de incorporación: 1 de diciembre de 2011

Mensajes recientes

i tried different browsers and cleared the cache also... does it hasanythin to do with the 64 bit or jdk. because it was working fine with 32 bit windows 7
Ken Dong
RE: Lifaray displayed in strange way
13 de diciembre de 2011 10:36
Respuesta

Ken Dong

LIFERAY STAFF

Ranking: New Member

Mensajes: 6

Fecha de incorporación: 31 de agosto de 2010

Mensajes recientes

Is this clean bundle with a clean database?
Aparna Ravidas
RE: Lifaray displayed in strange way
15 de diciembre de 2011 14:05
Respuesta

Aparna Ravidas

Ranking: New Member

Mensajes: 9

Fecha de incorporación: 1 de diciembre de 2011

Mensajes recientes

yes...i downloaded the bundle and followed the steps as in "liferay in action"
Hitoshi Ozawa
RE: Lifaray displayed in strange way
15 de diciembre de 2011 15:27
Respuesta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensajes: 7990

Fecha de incorporación: 23 de marzo de 2010

Mensajes recientes

Have you looked at these thread? Liferay should work on Windows7 64bit too.

http://www.liferay.com/community/forums/-/message_boards/message/4409489

http://www.liferay.com/community/forums/-/message_boards/message/4999904
David H Nebinger
RE: Lifaray displayed in strange way
15 de diciembre de 2011 15:55
Respuesta

David H Nebinger

Ranking: Liferay Legend

Mensajes: 7153

Fecha de incorporación: 1 de septiembre de 2006

Mensajes recientes

Aparna Ravidas:
http://localhost:8080 shows the liferay page but its looks very odd without any theme or css.


Your page is using either the styled (or unstyled) theme or a newly created theme that inherits from styled but has not yet been populated.

Change back to the classic theme and it will look the way you expect.
Gnaniyar Zubair
RE: Lifaray displayed in strange way
15 de diciembre de 2011 16:07
Respuesta

Gnaniyar Zubair

Ranking: Liferay Master

Mensajes: 603

Fecha de incorporación: 19 de diciembre de 2007

Mensajes recientes

Aparna Ravidas:
Hi All..
I'm trying to install liferay community edition bundled with tomcat in windows 7 64 bit. with 64 bit jdk.when i ran the startup file from tomcat-6-0-29/bin with default configuration, it gives http :404 error( requested resource not found). but when i pointed to mysql database using portal-ext.properties , the http://localhost:8080 shows the liferay page but its looks very odd without any theme or css. i'm attaching the screenshot. its just showing some lines of text, text boxes for sign in..I'm able to sign in though. please help me to figure out what went wrong . thanks in advance



Hi Aparna,


1. have you downloaded the Liferay bundle properly?
2. Have you created any theme and applied?
3. If so, UnStyled Theme is applied . Login into portal and change the theme
3. deploy any other theme war file and check it.
Ken Dong
RE: Lifaray displayed in strange way
19 de diciembre de 2011 8:18
Respuesta

Ken Dong

LIFERAY STAFF

Ranking: New Member

Mensajes: 6

Fecha de incorporación: 31 de agosto de 2010

Mensajes recientes

You can also try clearing your temp/work folder
Aparna Ravidas
RE: Lifaray displayed in strange way
3 de enero de 2012 9:06
Respuesta

Aparna Ravidas

Ranking: New Member

Mensajes: 9

Fecha de incorporación: 1 de diciembre de 2011

Mensajes recientes

Hi All... Thank You for your suggestions.. But the issue is still not solved.. As suggested i tried logging in and change the theme to 'default'. but its already set to 'default' theme. But i notice some warning when i started tom cat which says that 'no theme found for specified theme id control panel. Returning the default theme'. Any clue on how i could resolve it. Thanks in advance
Drew Blessing
RE: Lifaray displayed in strange way
3 de enero de 2012 9:17
Respuesta

Drew Blessing

Ranking: Junior Member

Mensajes: 79

Fecha de incorporación: 27 de enero de 2011

Mensajes recientes

I believe the fix for that message is to put a default theme definition in the portal-ext.properties file. This is noted in the wiki article here: http://www.liferay.com/community/wiki/-/wiki/Main/How+To+Change+Liferay+Default+Theme

The property is
1default.theme.id=classic
(If you want the default theme to be the default or classic Liferay theme. If you want a custom theme you will need to change that to the short id of the custom theme, found in the theme's look-and-feel.xml file.
Aparna Ravidas
RE: Lifaray displayed in strange way
3 de enero de 2012 9:31
Respuesta

Aparna Ravidas

Ranking: New Member

Mensajes: 9

Fecha de incorporación: 1 de diciembre de 2011

Mensajes recientes

hi..
I got the warning message when i tried to change the default theme which was set to 'classic'. actually i dont want to change the default theme. what i really want is to bring the appearance of the liferay. it does not show any style though the theme is set as 'default' . thanks in advance...
David H Nebinger
RE: Lifaray displayed in strange way
3 de enero de 2012 14:00
Respuesta

David H Nebinger

Ranking: Liferay Legend

Mensajes: 7153

Fecha de incorporación: 1 de septiembre de 2006

Mensajes recientes

Liferay has two unstyled themes which are supposed to be used as the foundation for theme development. These two themes, named styled and unstyled, have no real CSS behind them but provide the basic foundation for creating a new theme (they provide many of the placeholders that a theme developer would populate to affect the whole look and feel of the portal).

I'm not sure what your default theme is, but if you changed off of 'classic' (or any other fully populated theme) or you created a brand new theme based upon either the styled or unstyled themes, you end up w/ the page as presented in your screen capture.

To change the appearance of Liferay, you need the SDK and create a theme project. The new project would use styled as the default parent theme, but I usually use classic as my parent theme. After you have the theme project, you can start overriding the appropriate CSS files to change the look and feel.