Vue combinée Vue Plate Arborescence
Sujets [ Précédent | Suivant ]
toggle
Ben Brown
Active Directory Setup - can't log in.
16 septembre 2011 03:04
Réponse

Ben Brown

Rang: Junior Member

Publications: 75

Date d'inscription: 7 juillet 2010

Publications Récentes

Hi,

I'm using Liferay EE 6.0 sp2/Tomcat on Ubuntu Server 11.04/64bit.

I have Active Directory users importing correctly into Liferay, but I am unable to log in using the AD user details...

I also use the Liberal Screen Name Validator because our usernames (mailNickname) have underscores in - e.g. mine is ben_b

In the database, the user_ table is showing the correct fields being populated too.

I have the set up as below:



When I try and log in as a user I can see in the database I get the following:

 109:48:08,829 DEBUG [LDAPAuth:362] Authenticator is enabled
 209:48:08,830 DEBUG [PortalLDAPUtil:44] -- listing properties --
 3java.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory
 4java.naming.provider.url=ldap://mhdc-dcser1:389
 5com.sun.jndi.ldap.connect.pool.timeout=10000
 6java.naming.security.principal=xxxxxxxx
 7com.sun.jndi.ldap.connect.pool=true
 8com.sun.jndi.ldap.connect.pool.maxsize=50
 9java.naming.security.credentials=xxxxxxxxx
10java.naming.referral=follow
11
1209:48:08,831 DEBUG [LDAPSettingsUtil:51] Search filter before transformation (&(objectCategory=person)(mailNickname=@user_id@))
1309:48:08,831 DEBUG [LDAPSettingsUtil:65] Search filter after transformation (&(objectCategory=person)(mailNickname=0))
1409:48:08,832 DEBUG [LDAPSettingsUtil:44] -- listing properties --
15password=userPassword
16lastName=sn
17screenName=sAMAccountName
18firstName=givenName
19jobTitle=title
20emailAddress=mail
21group=memberOf
22fullName=cn
23
2409:48:08,833 DEBUG [LDAPAuth:320] Search filter did not return any results


Thanks for any help or advice, I assume I must have a filter set wrongly or something similar.

Ben
Sreeraj AV
RE: Active Directory Setup - can't log in.
17 septembre 2011 21:03
Réponse

Sreeraj AV

Rang: Regular Member

Publications: 233

Date d'inscription: 26 avril 2010

Publications Récentes

just try sAMAccountName=@screen_name@ instead of mailNickname=@user_id@
Ben Brown
RE: Active Directory Setup - can't log in.
19 septembre 2011 00:41
Réponse

Ben Brown

Rang: Junior Member

Publications: 75

Date d'inscription: 7 juillet 2010

Publications Récentes

That worked!

Thanks very much for your help!

Ben
Hannes C.
RE: Active Directory Setup - can't log in.
10 septembre 2012 04:32
Réponse

Hannes C.

Rang: New Member

Publications: 1

Date d'inscription: 4 septembre 2012

Publications Récentes

Sreeraj AV:
just try sAMAccountName=@screen_name@ instead of mailNickname=@user_id@


Do you know how to handle the problem with ,, Liferay 6.1 [tomcat bundle]" ? i ve got the same problem just with liferay 6.1 and cant find the ext.properties file but already read that this file doesn't exist for liferay 6.1 hmmmm... really thx for help cuz first time working with liferay and i cant find a solution for this problem emoticon
Attachement

Pièces jointes: anmelden_fehlgeschlagen.png (22,3k)
Linus Sphinx
RE: Active Directory Setup - can't log in.
10 septembre 2012 14:33
Réponse

Linus Sphinx

Rang: Junior Member

Publications: 84

Date d'inscription: 12 août 2010

Publications Récentes

Won't find it in any version unless you create it and fill it with the variables and values you want to over-ride.