Forum

Accueil » Liferay IDE » English

Vue combinée Vue Plate Arborescence
Sujets [ Précédent | Suivant ]
toggle
l ll
Portal version not supported. Need at least 6.0.2
18 juillet 2012 09:34
Réponse

l ll

Rang: Junior Member

Publications: 74

Date d'inscription: 12 décembre 2011

Publications Récentes

need to run liferay-portal-5.2.3 ...

I tried the following IDE:

eclipse_Liferay_IDE_1.4.0_v201110020220-win32-x86_64.zip
eclipse_Liferay_IDE_1.5.0_v201201102224-win32-x86_64.zip
eclipse_Liferay_IDE_1.5.1_v201202280246-win32-x86_64.zip
eclipse_Liferay_IDE_1.5.2_v201203040240-win32-x86_64.zip
eclipse_Liferay_IDE_1.5.3.v201205280937-win32-x86_64.zip

Portal version not supported. Need at least 6.0.2

Please help
David H Nebinger
RE: Portal version not supported. Need at least 6.0.2
18 juillet 2012 09:53
Réponse

David H Nebinger

Community Moderator

Rang: Liferay Legend

Publications: 8603

Date d'inscription: 1 septembre 2006

Publications Récentes

You'll have to go to sourceforge and download an older version of the Liferay IDE that is compatible w/ 5.2.3.

Note that Liferay IDE is not absolutely necessary to develop plugins, although it does help. You can create plugins using the command line in the SDK, and those new plugins will have .project files so you can import them into a vanilla Eclipse install. You're just left on your own for editing the various xml files...
l ll
RE: Portal version not supported. Need at least 6.0.2
18 juillet 2012 10:09
Réponse

l ll

Rang: Junior Member

Publications: 74

Date d'inscription: 12 décembre 2011

Publications Récentes

Thank you.
But I can not run a binary file. So I want a IDE

 1
 2Microsoft Windows [Version 6.1.7601]
 3
 4C:\>g:
 5
 6G:\>cd atime\liferay-portal-5.2.3\tomcat-6.0.18\bin
 7
 8G:\atime\liferay-portal-5.2.3\tomcat-6.0.18\bin>startup.bat
 9Using CATALINA_BASE:   G:\atime\liferay-portal-5.2.3\tomcat-6.0.18
10Using CATALINA_HOME:   G:\atime\liferay-portal-5.2.3\tomcat-6.0.18
11Using CATALINA_TMPDIR: G:\atime\liferay-portal-5.2.3\tomcat-6.0.18\temp
12Using JRE_HOME:        G:\atime\liferay-portal-5.2.3\tomcat-6.0.18/jre1.5.0_17/win
13
14G:\atime\liferay-portal-5.2.3\tomcat-6.0.18\bin>startup.bat
15Using CATALINA_BASE:   G:\atime\liferay-portal-5.2.3\tomcat-6.0.18
16Using CATALINA_HOME:   G:\atime\liferay-portal-5.2.3\tomcat-6.0.18
17Using CATALINA_TMPDIR: G:\atime\liferay-portal-5.2.3\tomcat-6.0.18\temp
18Using JRE_HOME:        G:\atime\liferay-portal-5.2.3\tomcat-6.0.18\jre1.5.0_17\win
19G:\atime\liferay-portal-5.2.3\tomcat-6.0.18\bin>


The first version of the original setenv.bat
The second after editing

logs do not
David H Nebinger
RE: Portal version not supported. Need at least 6.0.2
18 juillet 2012 11:04
Réponse

David H Nebinger

Community Moderator

Rang: Liferay Legend

Publications: 8603

Date d'inscription: 1 septembre 2006

Publications Récentes

What?

This makes no sense. Cannot run a binary file? What binary file?

Are you saying you cannot start Liferay? That's a completely different thing than whether or not you should be using the IDE.
Jack Bakker
RE: Portal version not supported. Need at least 6.0.2
18 juillet 2012 16:06
Réponse

Jack Bakker

Rang: Liferay Master

Publications: 761

Date d'inscription: 3 janvier 2010

Publications Récentes

there's a Liferay IDE compatible with v5.2.3 ?
Jack Bakker
RE: Portal version not supported. Need at least 6.0.2
18 juillet 2012 16:13
Réponse

Jack Bakker

Rang: Liferay Master

Publications: 761

Date d'inscription: 3 janvier 2010

Publications Récentes

ild, your thread is not making sense to me

the Liferay SDK for v5.2.3 using ant works well ; there are many posts describing how ; the Liferay IDE for later versions is fantastic for speeding up dev work

your setenv.bat post makes no sense to me, sorry
Gregory Amerson
RE: Portal version not supported. Need at least 6.0.2
18 juillet 2012 17:46
Réponse

Gregory Amerson

LIFERAY STAFF

Rang: Liferay Master

Publications: 974

Date d'inscription: 16 février 2010

Publications Récentes

ild i:
need to run liferay-portal-5.2.3 ...

I tried the following IDE:

eclipse_Liferay_IDE_1.4.0_v201110020220-win32-x86_64.zip
eclipse_Liferay_IDE_1.5.0_v201201102224-win32-x86_64.zip
eclipse_Liferay_IDE_1.5.1_v201202280246-win32-x86_64.zip
eclipse_Liferay_IDE_1.5.2_v201203040240-win32-x86_64.zip
eclipse_Liferay_IDE_1.5.3.v201205280937-win32-x86_64.zip

Portal version not supported. Need at least 6.0.2

Please help



Sorry for confusion but Liferay IDE only supports version 6.0.2 or greater of Liferay Portal. As David mentions you will need to just use the Plugins SDK and java projects manually for portal versions prior to 6.0.2.