Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Naveen Sharma
Liferay not accepting LDAP user password
August 17, 2011 11:50 PM
Answer

Naveen Sharma

Rank: New Member

Posts: 2

Join Date: August 17, 2011

Recent Posts

Hi All,

I recently installed liferay 6.0.6. I had the requirement for using LDAP authentication which I did in Portal Settings.
All went off well and users/groups were imported from LDAP server successfully.
However, they cannot login using their passwords with LDAP server. I tried using the LDAP password policy in liferay but that did not work out.

Any idea of how to make liferay talk to ldap server for password verification ?

Do I need the patch mentioned here:
http://www.liferay.com/community/forums/-/message_boards/message/10090229

Regards,
Naveen Sharma.
Ravi Kumar Gupta
RE: Liferay not accepting LDAP user password
August 17, 2011 11:56 PM
Answer

Ravi Kumar Gupta

Rank: Liferay Legend

Posts: 1145

Join Date: June 23, 2009

Recent Posts

I did use LDAP with LR 6.0.6 some time back and it works fine. Can you please share the logs to analyze any error thats coming.

Thanks and Regards
Ravi
Naveen Sharma
RE: Liferay not accepting LDAP user password
August 18, 2011 1:25 AM
Answer

Naveen Sharma

Rank: New Member

Posts: 2

Join Date: August 17, 2011

Recent Posts

Dear Ravi,

> I did use LDAP with LR 6.0.6 some time back and it works fine

I can see all users imported from LDAP.
However, ldap passwords don't work. I have no clues.

Which log file to look for authentication failures. server/log doesn't show any errors.

Regards,
Naveen Sharma.
Ravi Kumar Gupta
RE: Liferay not accepting LDAP user password
August 18, 2011 2:11 AM
Answer

Ravi Kumar Gupta

Rank: Liferay Legend

Posts: 1145

Join Date: June 23, 2009

Recent Posts

okay.. and what LDAP access logs. Which LDAP you are using.. there should be some logs folder or so..

My approach to this problem is to check whether at login time LR is using LDAP or not.. if not then there is some problem in LR settings. If yes then check proper ldap credentials.
Sreeraj AV
RE: Liferay not accepting LDAP user password
August 24, 2011 11:46 PM
Answer

Sreeraj AV

Rank: Regular Member

Posts: 223

Join Date: April 26, 2010

Recent Posts

Naveen Sharma:
Dear Ravi,

> I did use LDAP with LR 6.0.6 some time back and it works fine

I can see all users imported from LDAP.
However, ldap passwords don't work. I have no clues.

Which log file to look for authentication failures. server/log doesn't show any errors.

Regards,
Naveen Sharma.


I think the problem is in your Authentication Search Filter filed. I've integrated Active Directory with LR 6.0.5, 6.0.6 and LR 6 EE SP2.
i gave (&(objectCategory=Person)(sAMAccountName=@screen_name@)) in my Authentication Search Filter filed. and configured authentication using screen name
Attachment

Attachment

Attachments: Screenshot_1.png (4.1k), Screenshot_2.png (19.2k)
Brian Scott Schupbach
RE: Liferay not accepting LDAP user password
October 5, 2011 2:13 PM
Answer

Brian Scott Schupbach

Rank: Expert

Posts: 331

Join Date: October 23, 2008

Recent Posts

Hello,

Thanks for posting those screen shots. I had an issue where users could use ANY password to authenticate into the portal. That issue has been fixed.

However, I have run into a new problem... If a user has the role of the portal Administrator (omniadmin) any password can be entered with the username and they are allowed to enter the portal.

Any suggestions? are you experiencing something similar?

Thanks in advance.

Brian
Drew Blessing
RE: Liferay not accepting LDAP user password
October 16, 2011 8:09 PM
Answer

Drew Blessing

Rank: Junior Member

Posts: 79

Join Date: January 27, 2011

Recent Posts

Out of curiosity, you're not using Chrome browser are you? I haven't ever seen this in Liferay 6.0.6 except with Chrome. The browser holds into the Session objects and makes Liferay, and other apps, appear to accept invalid passwords. It's worth a shot anyway.

By the way, I can't help but notice the giant red N you have as your pic. Do you work in NE? I know this is outside the scope of this forum. I work in K12 education in NE and we're doing a huge deployment of LR. If you're interested in collaborating or just chatting about LR, send me a dm on Twitter @drewblessing.
Brian Scott Schupbach
RE: Liferay not accepting LDAP user password
October 17, 2011 9:48 AM
Answer

Brian Scott Schupbach

Rank: Expert

Posts: 331

Join Date: October 23, 2008

Recent Posts

Oops, I should have updated this post...

The issue has been corrected. I received a patch to get the LDAP import feature working the way I needed and somewhere in that patch it allowed users to authenticate with any password. I removed the patch and everything is working correctly now.

Yes, I do work in Nebraska! I'll send you a dm on twitter. It would be nice to see if we can collaborate on something.

Brian
Brandon Wagner
RE: Liferay not accepting LDAP user password
October 26, 2011 3:25 PM
Answer

Brandon Wagner

Rank: Junior Member

Posts: 67

Join Date: May 14, 2008

Recent Posts

Ravi -- cheers, you helped me greatly with these screenshots. The General tab was the key, for me.
Born Telefrag
RE: Liferay not accepting LDAP user password
June 20, 2013 5:34 AM
Answer

Born Telefrag

Rank: New Member

Posts: 1

Join Date: June 7, 2013

Recent Posts

thx a lot, you saved a bunch of my time