Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
henk huisman
Page layout in custom theme stuck to 1 column
June 18, 2012 5:25 AM
Answer

henk huisman

Rank: New Member

Posts: 11

Join Date: November 21, 2010

Recent Posts

I created a custom theme using Eclipse. On my home machine (PC Wind7) all works fine and I can choose any page layout I want.
On the production machine I deployed the WAR-file I created locally.
In production I can change the page layout to any setting (30/70), but the result is always a page layout of 1 column.
Anyone an idea where to look for?

Thanks in advance
Henk Huisman
Maarten van Heiningen
RE: Page layout in custom theme stuck to 1 column
June 18, 2012 1:17 PM
Answer

Maarten van Heiningen

Rank: Regular Member

Posts: 172

Join Date: February 5, 2009

Recent Posts

Hello Henk,

This should not be the case. It should be the case that if you select a layout for a given page this should them be set.

Can you provide more details?

My first suggestion is that on your production machine you have the settings that cache your page layouts and themes.

See your portal-ext.properties settings for
1layout.template.cache.enabled=false


Best Maarten
henk huisman
RE: Page layout in custom theme stuck to 1 column
June 19, 2012 1:41 AM
Answer

henk huisman

Rank: New Member

Posts: 11

Join Date: November 21, 2010

Recent Posts

Maarten thanks for your suggestion. Much appreciated.

Some more detail.
If I look at the source of the page that is generated by Liferay it definitely shows the divs with column_1 and column_2.
But in the GUI I just can not drop a portlet (eg web content) in the second column. It always drops it in column 1.

If I switch to the classic theme everything works fine; but if I use my custom theme the problem occurs.

Henk
Maarten van Heiningen
RE: Page layout in custom theme stuck to 1 column
June 19, 2012 2:14 AM
Answer

Maarten van Heiningen

Rank: Regular Member

Posts: 172

Join Date: February 5, 2009

Recent Posts

Hi Henk,

Okay there are two things.

1) The portlets that are placed on your page using the quick link (items directly under the Add section) are always placed in the first column first position.

2) please check your css for the second column when using your theme. You can use firebug etc. Please check if the css code for this column is set to display none or display hidden because the extra column css class is set on this set to 'empty'

Best,
Maarten
henk huisman
RE: Page layout in custom theme stuck to 1 column
June 19, 2012 5:27 AM
Answer

henk huisman

Rank: New Member

Posts: 11

Join Date: November 21, 2010

Recent Posts

Indeed, probably has to do something with the css

In internet explorer 9 things seem to work fine!!

There are some ie specific references (mostly ie6 and ie7) in my custom.css like

.ie .lfr-portlet-title-editable-content {
margin-top: 4px;
}


I am completely lost

Henk
Maarten van Heiningen
RE: Page layout in custom theme stuck to 1 column
June 19, 2012 11:57 PM
Answer

Maarten van Heiningen

Rank: Regular Member

Posts: 172

Join Date: February 5, 2009

Recent Posts

Hi Henk,

This part of the css has nothing to do with not being able to place a portlet into your second column.

henk huisman:

There are some ie specific references (mostly ie6 and ie7) in my custom.css like
.ie .lfr-portlet-title-editable-content {
margin-top: 4px;
}


Is it possible to copy (printscreen of just firebug) just the section of rendered html from firebug into the post so I can see the generated code and hopefully part of your css?
So you can leave out project specific stuff...

Best Maarten
henk huisman
RE: Page layout in custom theme stuck to 1 column
June 20, 2012 3:22 AM
Answer

henk huisman

Rank: New Member

Posts: 11

Join Date: November 21, 2010

Recent Posts

Hi Maarten,
would it be an idea if I gave you temporary access to the portal I am building?
Henk
Maarten van Heiningen
RE: Page layout in custom theme stuck to 1 column
June 20, 2012 5:52 AM
Answer

Maarten van Heiningen

Rank: Regular Member

Posts: 172

Join Date: February 5, 2009

Recent Posts

Hello Henk,

I send you a friend request on your Liferay profile so we can chat.

Best,
Maarten
henk huisman
RE: Page layout in custom theme stuck to 1 column
June 21, 2012 1:08 PM
Answer

henk huisman

Rank: New Member

Posts: 11

Join Date: November 21, 2010

Recent Posts

I found an old thread

Drag-n-drop loss in custom theme?

seems to be the same problem.

Anyone solved that issue?
henk huisman
RE: Page layout in custom theme stuck to 1 column
June 23, 2012 5:31 AM
Answer

henk huisman

Rank: New Member

Posts: 11

Join Date: November 21, 2010

Recent Posts

I think I solved the problem.

It had to do with permissions on the production server.
As I deployed my war file of the custom theme by uploading it to de deploy directory, the owner of the custom theme file became root.
Also in the temp directories some of the temp css files were owned by root. I do not know what they are for, but they actually matter.

What did help was activating the portal-developer.properties in the setenv script
Installing and intensively using the web developer plugin of Chrome
Not giving up
Hitoshi Ozawa
RE: Page layout in custom theme stuck to 1 column
June 23, 2012 5:53 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7952

Join Date: March 23, 2010

Recent Posts

I was having similar problems with OS permissions. I'm now uploading my portlets from Liferay's Control Panel -> Server Administration -> Plugin installation
This way, I'll be installing plugin using liferay's account.
Yan Naing Oo
RE: Page layout in custom theme stuck to 1 column
June 28, 2012 7:00 PM
Answer

Yan Naing Oo

Rank: Regular Member

Posts: 180

Join Date: February 17, 2011

Recent Posts

Hi henk,

how did you solved this portlet stuck in the custom layout creation on liferay. I used CE v6.0.6 enviroment.
please let me know emoticon

thanks