Forums

Home » Liferay IDE » English

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Samita Bhujbal
BeanLocator is null
October 11, 2012 6:32 AM
Answer

Samita Bhujbal

Rank: Regular Member

Posts: 120

Join Date: July 5, 2011

Recent Posts

I am using Liferay 6.0.6. I have developed one portlet using service builder. It is working fine on localhost. I have uploaded portlet on UAT site from Control Panel. It is deployed successfully. On one jsp I am accessing entry from one table using service builder. For that page I am getting "BeanLocator is null" exception. I am working on service builder from last 6 months but I have came across such error for the first time.
What is the reason behind this?? How to resolve it??
Is it due to uploading portlet on UAT through control panel instead of uploading .war file in deploy folder on server ???emoticon
emoticon
Apoorva Prakash
RE: BeanLocator is null
October 11, 2012 10:43 AM
Answer

Apoorva Prakash

Rank: Liferay Master

Posts: 659

Join Date: June 15, 2010

Recent Posts

Samita Bhujbal:

Is it due to uploading portlet on UAT through control panel instead of uploading .war file in deploy folder on server ???


No its not. I've seen table is not updated sometimes, but works well after server restart. Cant say why!!! Try it.

Hope this will help...

Thanks and Regards,
Apoorva Prakash
Samita Bhujbal
RE: BeanLocator is null
October 11, 2012 11:08 PM
Answer

Samita Bhujbal

Rank: Regular Member

Posts: 120

Join Date: July 5, 2011

Recent Posts

Thanks for reply Apoorva......................I have restarted server many times but still that issue is there.