Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Ranen Das
Whats wrong with Liferay
November 9, 2012 7:13 AM
Answer

Ranen Das

Rank: Regular Member

Posts: 137

Join Date: April 6, 2011

Recent Posts

This is becoming a regular feature - mixing english with other languages???
Attachments: watsWrongWithLiferay.bmp (1,317.8k)
Florencia Gadea
RE: Whats wrong with Liferay
November 9, 2012 7:27 AM
Answer

Florencia Gadea

Rank: Regular Member

Posts: 159

Join Date: March 27, 2012

Recent Posts

Yes, it happens to me all the time...
David H Nebinger
RE: Whats wrong with Liferay
November 9, 2012 7:30 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 6270

Join Date: September 1, 2006

Recent Posts

I don't know that there is anything wrong here...

Looks like your default locale is set so you see the surrounding content in the locale of your selection.

But forum posts, like mine for example, are done in my locale only. I'm not writing the forum post in all other languages that Liferay supports. So I think you're stuck seeing the original english post...

Other things in the portal itself can and are localized. You can localize your web content, your labels, etc. When the content supports localization, you get the localization.

But if the content does not support localization (i.e. my forum response), the content cannot be localized.

I'll typically use chrome's ability to translate pages when I get to a forum post that is in another language that I'm concerned about. Doesn't do an awesome job (it sucks at translating source code), but typically does enough that I can get the gist of what is being said...
Juan Gonzalez
RE: Whats wrong with Liferay
November 9, 2012 11:48 AM
Answer

Juan Gonzalez

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1855

Join Date: October 28, 2008

Recent Posts

Happens the same to a mate in office.

I didn't see anything wrong. Probably is a browser language setting misconfiguration, and you can see now because of an upgrade in Liferay.com.
Jack Bakker
RE: Whats wrong with Liferay
November 9, 2012 1:49 PM
Answer

Jack Bakker

Rank: Liferay Master

Posts: 515

Join Date: January 3, 2010

Recent Posts

I get same thing once in a while but then clear my cache/cookies and all seems fine again

no idea why except that it seems to happen after I google then go to liferay page in other language then find myself in other language by default
Milan Kostoláni
RE: Whats wrong with Liferay
November 12, 2012 12:55 AM
Answer

Milan Kostoláni

Rank: Junior Member

Posts: 92

Join Date: July 26, 2012

Recent Posts

The thing is that when you someone posts a link to wiki/forum/blog with his personal language option and you click on it, it changes your default language in liferay to language that has that someone as default.

So basically that was you see is not problem with liferay, just your default language changed to Magyar, probably after you clicked on some link to content posted by someone with default language - Magyar. (but I think it can be classified as bug, because it should not change your default language)