Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Naveen Sharma
Liferay not accepting LDAP user password
17 agosto 2011 23.50
Risposta

Naveen Sharma

Punteggio: New Member

Messaggi: 2

Data di Iscrizione: 17 agosto 2011

Messaggi recenti

Hi All,

I recently installed liferay 6.0.6. I had the requirement for using LDAP authentication which I did in Portal Settings.
All went off well and users/groups were imported from LDAP server successfully.
However, they cannot login using their passwords with LDAP server. I tried using the LDAP password policy in liferay but that did not work out.

Any idea of how to make liferay talk to ldap server for password verification ?

Do I need the patch mentioned here:
http://www.liferay.com/community/forums/-/message_boards/message/10090229

Regards,
Naveen Sharma.
Ravi Kumar Gupta
RE: Liferay not accepting LDAP user password
17 agosto 2011 23.56
Risposta

Ravi Kumar Gupta

Punteggio: Liferay Legend

Messaggi: 1216

Data di Iscrizione: 23 giugno 2009

Messaggi recenti

I did use LDAP with LR 6.0.6 some time back and it works fine. Can you please share the logs to analyze any error thats coming.

Thanks and Regards
Ravi
Naveen Sharma
RE: Liferay not accepting LDAP user password
18 agosto 2011 1.25
Risposta

Naveen Sharma

Punteggio: New Member

Messaggi: 2

Data di Iscrizione: 17 agosto 2011

Messaggi recenti

Dear Ravi,

> I did use LDAP with LR 6.0.6 some time back and it works fine

I can see all users imported from LDAP.
However, ldap passwords don't work. I have no clues.

Which log file to look for authentication failures. server/log doesn't show any errors.

Regards,
Naveen Sharma.
Ravi Kumar Gupta
RE: Liferay not accepting LDAP user password
18 agosto 2011 2.11
Risposta

Ravi Kumar Gupta

Punteggio: Liferay Legend

Messaggi: 1216

Data di Iscrizione: 23 giugno 2009

Messaggi recenti

okay.. and what LDAP access logs. Which LDAP you are using.. there should be some logs folder or so..

My approach to this problem is to check whether at login time LR is using LDAP or not.. if not then there is some problem in LR settings. If yes then check proper ldap credentials.
Sreeraj AV
RE: Liferay not accepting LDAP user password
24 agosto 2011 23.46
Risposta

Sreeraj AV

Punteggio: Regular Member

Messaggi: 233

Data di Iscrizione: 26 aprile 2010

Messaggi recenti

Naveen Sharma:
Dear Ravi,

> I did use LDAP with LR 6.0.6 some time back and it works fine

I can see all users imported from LDAP.
However, ldap passwords don't work. I have no clues.

Which log file to look for authentication failures. server/log doesn't show any errors.

Regards,
Naveen Sharma.


I think the problem is in your Authentication Search Filter filed. I've integrated Active Directory with LR 6.0.5, 6.0.6 and LR 6 EE SP2.
i gave (&(objectCategory=Person)(sAMAccountName=@screen_name@)) in my Authentication Search Filter filed. and configured authentication using screen name
Allegato

Allegato

Allegati: Screenshot_1.png (4,1k), Screenshot_2.png (19,2k)
Brian Scott Schupbach
RE: Liferay not accepting LDAP user password
5 ottobre 2011 14.13
Risposta

Brian Scott Schupbach

Punteggio: Expert

Messaggi: 329

Data di Iscrizione: 23 ottobre 2008

Messaggi recenti

Hello,

Thanks for posting those screen shots. I had an issue where users could use ANY password to authenticate into the portal. That issue has been fixed.

However, I have run into a new problem... If a user has the role of the portal Administrator (omniadmin) any password can be entered with the username and they are allowed to enter the portal.

Any suggestions? are you experiencing something similar?

Thanks in advance.

Brian
Drew Blessing
RE: Liferay not accepting LDAP user password
16 ottobre 2011 20.09
Risposta

Drew Blessing

Punteggio: Junior Member

Messaggi: 79

Data di Iscrizione: 27 gennaio 2011

Messaggi recenti

Out of curiosity, you're not using Chrome browser are you? I haven't ever seen this in Liferay 6.0.6 except with Chrome. The browser holds into the Session objects and makes Liferay, and other apps, appear to accept invalid passwords. It's worth a shot anyway.

By the way, I can't help but notice the giant red N you have as your pic. Do you work in NE? I know this is outside the scope of this forum. I work in K12 education in NE and we're doing a huge deployment of LR. If you're interested in collaborating or just chatting about LR, send me a dm on Twitter @drewblessing.
Brian Scott Schupbach
RE: Liferay not accepting LDAP user password
17 ottobre 2011 9.48
Risposta

Brian Scott Schupbach

Punteggio: Expert

Messaggi: 329

Data di Iscrizione: 23 ottobre 2008

Messaggi recenti

Oops, I should have updated this post...

The issue has been corrected. I received a patch to get the LDAP import feature working the way I needed and somewhere in that patch it allowed users to authenticate with any password. I removed the patch and everything is working correctly now.

Yes, I do work in Nebraska! I'll send you a dm on twitter. It would be nice to see if we can collaborate on something.

Brian
Brandon Wagner
RE: Liferay not accepting LDAP user password
26 ottobre 2011 15.25
Risposta

Brandon Wagner

Punteggio: Junior Member

Messaggi: 67

Data di Iscrizione: 14 maggio 2008

Messaggi recenti

Ravi -- cheers, you helped me greatly with these screenshots. The General tab was the key, for me.
Born Telefrag
RE: Liferay not accepting LDAP user password
20 giugno 2013 5.34
Risposta

Born Telefrag

Punteggio: New Member

Messaggi: 1

Data di Iscrizione: 7 giugno 2013

Messaggi recenti

thx a lot, you saved a bunch of my time