Tribune

Home » Liferay Sync

Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Rex Petersen
Failed to connect to server
1 febbraio 2012 21.05
Risposta

Rex Petersen

Punteggio: New Member

Messaggi: 11

Data di Iscrizione: 10 marzo 2011

Messaggi recenti

After installing Sync, when entering Account Settings in the "Enter new account information" dialog, I get the message "Failed to connect to server" when attempting to connect to a local instance of LR6.1GA.

What are the requirements for the server to which Liferay Sync is attempting to connect?

So far I haven't seen a "Getting Started" doc which might cover this. Am I missing something?
Michael Young
RE: Failed to connect to server
1 febbraio 2012 21.46
Risposta

Michael Young

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 842

Data di Iscrizione: 4 agosto 2004

Messaggi recenti

Hey Rex,

We'll have a look at this. In the meantime, can you attach your log file?

They should be in user.home/.liferay-sync/logs

Thanks.
Rex Petersen
RE: Failed to connect to server
1 febbraio 2012 21.54
Risposta

Rex Petersen

Punteggio: New Member

Messaggi: 11

Data di Iscrizione: 10 marzo 2011

Messaggi recenti

Hi Michael,

Here is the log file.

I just downloaded and installed this instance of LR6.1GA1 tonight.
Allegati: liferay-sync.log (4,0k)
Michael Young
RE: Failed to connect to server
1 febbraio 2012 22.07
Risposta

Michael Young

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 842

Data di Iscrizione: 4 agosto 2004

Messaggi recenti

It seems that Sync is not recognizing your server as a valid Liferay portal. Have you already started GA1 and completed the setup, logged in, etc? We'll have a better look at this tomorrow and try to reproduce this.
Rex Petersen
RE: Failed to connect to server
1 febbraio 2012 22.12
Risposta

Rex Petersen

Punteggio: New Member

Messaggi: 11

Data di Iscrizione: 10 marzo 2011

Messaggi recenti

yes, in fact was logged while attempting to make the Sync connection.

Also, if I change the username or password it gives me a "username or password is incorrect" so it looks like it is communicating.

Anything in particular to look at on the server? Where would I find source for the ServerReleaseInfo class?
Dennis Ju
RE: Failed to connect to server
2 febbraio 2012 15.22
Risposta

Dennis Ju

LIFERAY STAFF

Punteggio: Regular Member

Messaggi: 103

Data di Iscrizione: 30 settembre 2010

Messaggi recenti

It looks like we're not getting back the expected http headers when communicating to the portal.

Can you try installing the Firefox add-on "Live HTTP Headers" link and see what you're getting when you go to your portal? You may want to attach it as a file as there might be quite a bit of text.
Valentine KH
RE: Failed to connect to server
4 luglio 2012 1.24
Risposta

Valentine KH

Punteggio: New Member

Messaggi: 3

Data di Iscrizione: 28 giugno 2011

Messaggi recenti

Hi, Dennis

I've got the same problem. Runnning Sync with liferay-portal-6.1.0-ce-ga1. Any clue to resolve the problem?

Although tell me please what url Sync is connecting while identifying Liferay portal version and so on? I could check headers returning from that URL to help you.

Thx
Valentine KH
RE: Failed to connect to server
4 luglio 2012 1.52
Risposta

Valentine KH

Punteggio: New Member

Messaggi: 3

Data di Iscrizione: 28 giugno 2011

Messaggi recenti

From quick overview: start page returns me 'Liferay-Portal: Liferay Portal Community Edition 6.1.0 CE (Paton / Build 6100 / January 6, 2012)' header. I can see it from Firebug. Other headers are common and not liferay-oriented.

Moreover I managed to connect to localhost Liferay portal with Sync. Exactly the same version of portal (the same archive) is installed on remote server, which I cannot connect with Sync. Starpage headers are the same. Could you please tell me the URL that Sync connects to to prove Liferay version. Strange thing is I cannot see Sync network traffic while tryinf to log in with Fiddler....
Valentine KH
RE: Failed to connect to server
4 luglio 2012 3.22
Risposta

Valentine KH

Punteggio: New Member

Messaggi: 3

Data di Iscrizione: 28 giugno 2011

Messaggi recenti

Problem solved.

I monitored requests made by Sync with Fiddler and MS Network Monitor. There are 3 requests. The second is '/'. By default this returns main page. In my config home page was set to /home in Control Panel and start page was set to /home too. This caused http://serverurl/ path return 404. Switching to defults (or /) resolved problem.
Dennis Ju
RE: Failed to connect to server
6 luglio 2012 12.23
Risposta

Dennis Ju

LIFERAY STAFF

Punteggio: Regular Member

Messaggi: 103

Data di Iscrizione: 30 settembre 2010

Messaggi recenti

Hi Valentine,

Can you help me understand exactly what your configuration is? If this is a configuration bug, we should fix it.

So I understand your main page's "Friendly URL" was set to /home. But which setting are you referring to when you said "start page was set to /home too"?
Brett Lewinski
RE: Failed to connect to server
13 luglio 2012 11.15
Risposta

Brett Lewinski

Punteggio: Junior Member

Messaggi: 46

Data di Iscrizione: 3 maggio 2011

Messaggi recenti

Hi -

I have been experimenting with Liferay Sync. I have it connecting to my local Liferay 6.1 instance no problem. When I try to connect Liferay Sync to my remote 6.1 server I am getting a "peer not authenticated" message returned. Anybody have any idea whats going on or how I can fix this. Any help would be much appreciated.

Thanks in advance!
Brett
Dennis Ju
RE: Failed to connect to server
13 luglio 2012 15.38
Risposta

Dennis Ju

LIFERAY STAFF

Punteggio: Regular Member

Messaggi: 103

Data di Iscrizione: 30 settembre 2010

Messaggi recenti

Hi Brett,

Does your portal default to https? (does your portal URL always default to https://myportal.com)?
Brett Lewinski
RE: Failed to connect to server
16 luglio 2012 6.32
Risposta

Brett Lewinski

Punteggio: Junior Member

Messaggi: 46

Data di Iscrizione: 3 maggio 2011

Messaggi recenti

Dennis -

Thanks for the reply. Yes all of our servers are using https.

Thanks
Brett
Anonimo
RE: Failed to connect to server
16 luglio 2012 8.12
Risposta

Anonimo

This is a known issue.

http://issues.liferay.com/browse/SYNC-364
SYNC-364 Sync cannot connect to portal through https

It should be fixed in an upcoming release.
Brett Lewinski
RE: Failed to connect to server
16 luglio 2012 11.09
Risposta

Brett Lewinski

Punteggio: Junior Member

Messaggi: 46

Data di Iscrizione: 3 maggio 2011

Messaggi recenti

Gail -

Thanks for the info, it is much appreciated! Any ideas on when this may be resolved?

Thanks Again!
Brett