Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Johan de jong
Strange errors? Look here ( An unexpected error occurred while )
19 giugno 2012 1.42
Risposta

Johan de jong

Punteggio: Junior Member

Messaggi: 35

Data di Iscrizione: 6 febbraio 2012

Messaggi recenti

Since i'm a frequent Liferay user and administrator of several sites i just want to help anybody by writing this post.

Liferay can sometimes throw very strange errors when you want to use a certain part of the website.
Today for example, i wanted to upload a file to a document library and Liferay kept throwing the error "An unexpected error occurred while saving your document.".

When iwanted to upload the file by the WEBDAV url / "Access from my Desktop" it threw a "file to large" error.
I tried and changed every setting and increased the file limit to 100 TB but still no way i could upload the file.

Then at one point Liferay finaly wrote a descent error into my glassfish errorlog
1Caused by: java.io.FileNotFoundException: /export/home/me/liferay/data/document_library/14458/15041/319/1.0 (No such file or directory)

As a last resort i went to my server and checked the filestructure.

and there i found what happens a lot to me. I have a dedicated user that SHOULD run Liferay on Glassfish, but during tests and so i sometimes forget this and start Liferay with my root-account. This renders a lot of directories unusable for the standard-user and results in an enormous list of strange errors.

So if you use a special user-account on your server to run Liferay on Glassfish (most Linux OS's have a dedicated Tomcat user) make sure it has all permissions (at least RW) to:
1
2/var/tmp/liferay
3$glassfishinstalldir/data
4$glassfishinstalldir/domains/domain1/generated
5$glassfishinstalldir/domains/domain1/logs


If it hasn't, make sure it gets it.
Hitoshi Ozawa
RE: Strange errors? Look here ( An unexpected error occurred while )
23 giugno 2012 5.06
Risposta

Hitoshi Ozawa

Punteggio: Liferay Legend

Messaggi: 7990

Data di Iscrizione: 23 marzo 2010

Messaggi recenti

I did the same thing in my JBoss installation once. Took me few hours to find the problem. :-)

I'm amazed that liferay even startup up in your environment. Mine didn't.