Tribune

Home » Liferay Portal » English » 3. Development

Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Florencia Gadea
Custom query: org.hibernate.MappingException: Unknown entity
23 novembre 2012 3.55
Risposta

Florencia Gadea

Punteggio: Regular Member

Messaggi: 146

Data di Iscrizione: 27 marzo 2012

Messaggi recenti

Hi Everyone!

When I try to execute a custom query I get this exception:

1com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.MappingException: Unknown entity: com.rcs.service.model.impl.MessageSourceImpl

Here is the code:

1
2String sql = "SELECT DISTINCT resourcekey, resourcelocale, resourcevalue, resourcebundle from resourceEditor_MessageSource";       
3setSessionFactory((SessionFactory)PortalBeanLocatorUtil.getBeanLocator().locate(MessageSourceModelImpl.SESSION_FACTORY));
4Session session = openSession();
5SQLQuery q = session.createSQLQuery(sql);
6q.setCacheable(false);
7q.addEntity(MessageSourceModelImpl.TABLE_NAME, MessageSourceImpl.class);
8List<MessageSource> result = ( List<MessageSource> ) QueryUtil.list(q, getDialect(), start, end);


Can you tell me what is wrong here?

TIA,

Flor.
Florencia Gadea
RE: Custom query: org.hibernate.MappingException: Unknown entity
23 novembre 2012 3.56
Risposta

Florencia Gadea

Punteggio: Regular Member

Messaggi: 146

Data di Iscrizione: 27 marzo 2012

Messaggi recenti

Anyone?

I've been trying to make this work for days, and I can't get any help.
Juan Gonzalez
RE: Custom query: org.hibernate.MappingException: Unknown entity
23 novembre 2012 10.45
Risposta

Juan Gonzalez

LIFERAY STAFF

Punteggio: Liferay Legend

Messaggi: 2141

Data di Iscrizione: 28 ottobre 2008

Messaggi recenti

Try changing all your

MessageSourceModelImpl

to

MessageSourceModel
Florencia Gadea
RE: Custom query: org.hibernate.MappingException: Unknown entity
4 dicembre 2012 5.47
Risposta

Florencia Gadea

Punteggio: Regular Member

Messaggi: 146

Data di Iscrizione: 27 marzo 2012

Messaggi recenti

I tested it and it never worked.

I ended up getting the same results using a dynamic query.

Thanks anyway.