Tribune

Home » Liferay IDE » English

Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Laurent Saboret 26 novembre 2012 1.29
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Gregory Amerson 26 novembre 2012 1.41
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Laurent Saboret 4 dicembre 2012 8.15
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Gregory Amerson 5 dicembre 2012 0.26
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Laurent Saboret 5 dicembre 2012 1.36
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Dave Weitzel 5 dicembre 2012 6.43
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Laurent Saboret 5 dicembre 2012 6.57
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Laurent Saboret 5 dicembre 2012 7.09
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Dave Weitzel 5 dicembre 2012 14.53
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Gregory Amerson 20 dicembre 2012 0.26
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Laurent Saboret 21 dicembre 2012 1.48
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Gregory Amerson 21 dicembre 2012 1.56
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Laurent Saboret 21 dicembre 2012 6.19
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Gregory Amerson 23 dicembre 2012 23.39
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Laurent Saboret 24 dicembre 2012 2.44
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Gregory Amerson 26 dicembre 2012 23.27
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Laurent Saboret 27 dicembre 2012 11.21
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Gregory Amerson 27 dicembre 2012 17.52
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Dave Weitzel 28 dicembre 2012 13.22
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Laurent Saboret 7 gennaio 2013 0.54
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Gregory Amerson 18 gennaio 2013 6.13
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Brandt Solovij 30 gennaio 2013 11.00
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Brandt Solovij 6 febbraio 2013 13.49
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css Adeel Aslam 3 luglio 2013 16.35
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css sujeesh sujeesh 17 marzo 2014 21.58
Laurent Saboret
Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
26 novembre 2012 1.29
Risposta

Laurent Saboret

Punteggio: New Member

Messaggi: 17

Data di Iscrizione: 22 novembre 2012

Messaggi recenti

Hi,

I created a new theme in Eclipse Indigo 3.7.2 + Liferay IDE 1.6.1 using Liferay Plugin SDK 6.1.1.
I initialized the _diffs/ folder by copying Zoe Resort diffs/ folder (from http://svn.liferay.com/repos/public/plugins/branches/6.1.x/themes/zoe-resort-theme)
I started Liferay 6.1/Tomcat server
I compiled and deployed the theme via "Liferay >> sdk >> deploy" menu item
I chose the theme in Liferay Control Panels
=> the theme worked perfectly in Firefox :-)

Then I added the theme to Liferay 6.1/Tomcat server
I modified docroot/_diffs/css/custom.css and saved it.
Eclipse compiled automatically the theme and synchronized Tomcat
=> unfortunately, refreshing the page in Firefox failed with a message indicating that Firefox cannot load custom.css

After checking the differences between "Liferay >> sdk >> deploy" menu item and automatic build and synchronization, I found out that automatic build did not update docroot/css/.sass-cache/custom.css and removed docroot/css/custom.css! After automatic synchronization, custom.css is also deleted in Tomcat, hence the error in Firefox.

Any help would be appreciated.

Best regards,
Laurent

My configuration:

Red Hat Linux
Java 1.6
Eclipse Indigo 3.7.2 + Liferay IDE 1.6.1
Liferay 6.1.1 + Tomcat 7 bundle
Liferay Plugin SDK 6.1.1
Firefox 16
Gregory Amerson
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
26 novembre 2012 1.41
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 911

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

Thanks Laurent for the detailed problem report. My team will take a look at it soon and try to get back with you with a response.
Laurent Saboret
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
4 dicembre 2012 8.15
Risposta

Laurent Saboret

Punteggio: New Member

Messaggi: 17

Data di Iscrizione: 22 novembre 2012

Messaggi recenti

Hi Gregory,

Have you been able to reproduce my problem with automatic build and automatic synchronization of a theme? Do you have any idea to workaround the problem?

Best regards,
Laurent
Gregory Amerson
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
5 dicembre 2012 0.26
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 911

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

No, my team has not been able to reproduce. We will try again soon.
Laurent Saboret
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
5 dicembre 2012 1.36
Risposta

Laurent Saboret

Punteggio: New Member

Messaggi: 17

Data di Iscrizione: 22 novembre 2012

Messaggi recenti

Hi Gregory,

A simpler way to reproduce the problem on my machine:

I created a new theme "test" in Eclipse Indigo 3.7.2 + Liferay IDE 1.6.1 using Liferay Plugin SDK 6.1.1.
"Build automatically" is checked by default.
I created a css/ folder inside docroot/_diffs/ folder.
I created an empty file custom.css inside docroot/_diffs/css/.
=> Eclipse compiled automatically the theme (although nothing is printed in Eclipse console). Unfortunately, when checking the files on disk, I saw that automatic build removed docroot/css/custom.css (and did not create docroot/css/.sass-cache/custom.css).

At this point, if I add the new theme to Tomcat 7 server in Eclipse (without deploying), it is copied to Tomcat webapps/ folder and I can select this theme in Site Pages control panel. But, when I go back to my home page, Firefox fails to display it with a message indicating that it cannot load custom.css.


If in Eclipse I "clean" the theme project (and build it immediately), Eclipse prints in its console
Buildfile: xxx/liferay-portal-6.1.1-ce-ga2/liferay-plugins-sdk-6.1.1/themes/test-theme/build.xml
compile:
Copying 690 files to xxx/liferay-portal-6.1.1-ce-ga2/liferay-plugins-sdk-6.1.1/themes/test-theme/docroot
Copying 5 files to xxx/liferay-portal-6.1.1-ce-ga2/liferay-plugins-sdk-6.1.1/themes/test-theme/docroot/templates
Copying 11 files to xxx/liferay-portal-6.1.1-ce-ga2/liferay-plugins-sdk-6.1.1/themes/test-theme/docroot
Copying 1 file to xxx/liferay-portal-6.1.1-ce-ga2/liferay-plugins-sdk-6.1.1/themes/test-theme/docroot
BUILD SUCCESSFUL
and updates docroot/css/custom.css (but not docroot/css/.sass-cache/custom.css).


If in Eclipse, I deploy the theme via "Liferay >> sdk >> deploy" menu item, then both docroot/css/custom.css and docroot/css/.sass-cache/custom.css are updated.
The console output is much longer and lists the steps:
compile
war
build-css
deploy


Any help would be appreciated.

Best regards,
Laurent
Dave Weitzel
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
5 dicembre 2012 6.43
Risposta

Dave Weitzel

Punteggio: Regular Member

Messaggi: 169

Data di Iscrizione: 18 novembre 2009

Messaggi recenti

Hi Laurent
I may be able to add some knowledge here as you seem still to be stuck.

The .sass-cache has nothing to do with eclipse and will not be in the theme plugin in the SDK structure.
It is created when the site is running by the Sass engine I think you can turn this off in developer.properties so the css files are not cached and the web site will reissue them when required to the browsers it may also depend on which CSS add-ons you are declaring in your files. It is always useful to check your portal-developer.properties to have css and js caching turned off (theme.css.fast.load=false javascript.fat.load=false) so you can see more error messages and adjust things accordingly yes it is slower but you expect that in development.

There are three ways that eclipse can update the server when you save files in the /_diffs folder. Deploy will build the war file in the dist folder of the SDK and then copy it to the deploy folder of the site. direct_deploy will build the project (copying from _diffs merging with default theme to build the non _diffs folder and coy those files to the server directly updating the webapps/your theme folder.
The final one is if you have the theme "managed" by eclipse using the add/remove tool when you right click on the server. Then any time you save the file it will be copied to the server (the project isnt being built by ant just the file being copied). Depending on the settings in developer.properties you may or may not see the changes straight away as caching may be taking place.

The file in the the webapps/yourtheme/css folder should never disappear though.

If you them make manual changes to the theme on the server they will be overridden by any change you make in the plugin in Eclipse the next time you do a deploy or save a file if it is synchronized through the server settings. In my experience never modify a theme directly if you are running eclipse it is always easiest to have it synchronized as it takes about 2 seconds to save and be available which is about the time taken to move to your browser and hit refresh (CTRL-F5 to force reloading CSS files).

looking back at your original post... what was the message firefox displayed (was it a a 404 error) and was the file there? Are you sure the css was syntactically correct?
were you changing the files on the webapps folder of the web server directly?

Dave
Laurent Saboret
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
5 dicembre 2012 6.57
Risposta

Laurent Saboret

Punteggio: New Member

Messaggi: 17

Data di Iscrizione: 22 novembre 2012

Messaggi recenti

Dave Weitzel:
Hi Laurent
I may be able to add some knowledge here as you seem still to be stuck.

The .sass-cache has nothing to do with eclipse and will not be in the theme plugin in the SDK structure.
It is created when the site is running by the Sass engine I think you can turn this off in developer.properties so the css files are not cached and the web site will reissue them when required to the browsers it may also depend on which CSS add-ons you are declaring in your files. It is always useful to check your portal-developer.properties to have css and js caching turned off (theme.css.fast.load=false javascript.fat.load=false) so you can see more error messages and adjust things accordingly yes it is slower but you expect that in development.

There are three ways that eclipse can update the server when you save files in the /_diffs folder. Deploy will build the war file in the dist folder of the SDK and then copy it to the deploy folder of the site. direct_deploy will build the project (copying from _diffs merging with default theme to build the non _diffs folder and coy those files to the server directly updating the webapps/your theme folder.
The final one is if you have the theme "managed" by eclipse using the add/remove tool when you right click on the server. Then any time you save the file it will be copied to the server (the project isnt being built by ant just the file being copied). Depending on the settings in developer.properties you may or may not see the changes straight away as caching may be taking place.

The file in the the webapps/yourtheme/css folder should never disappear though.

If you them make manual changes to the theme on the server they will be overridden by any change you make in the plugin in Eclipse the next time you do a deploy or save a file if it is synchronized through the server settings. In my experience never modify a theme directly if you are running eclipse it is always easiest to have it synchronized as it takes about 2 seconds to save and be available which is about the time taken to move to your browser and hit refresh (CTRL-F5 to force reloading CSS files).

looking back at your original post... what was the message firefox displayed (was it a a 404 error) and was the file there? Are you sure the css was syntactically correct?
were you changing the files on the webapps folder of the web server directly?

Dave
Laurent Saboret
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
5 dicembre 2012 7.09
Risposta

Laurent Saboret

Punteggio: New Member

Messaggi: 17

Data di Iscrizione: 22 novembre 2012

Messaggi recenti

Hi Dave,

Dave Weitzel:
The .sass-cache has nothing to do with eclipse and will not be in the theme plugin in the SDK structure.
It is created when the site is running by the Sass engine I think you can turn this off in developer.properties so the css files are not cached and the web site will reissue them when required to the browsers it may also depend on which CSS add-ons you are declaring in your files. It is always useful to check your portal-developer.properties to have css and js caching turned off (theme.css.fast.load=false javascript.fat.load=false) so you can see more error messages and adjust things accordingly yes it is slower but you expect that in development.

Since my first post, I turned off caching in portal-developer.properties, thus the .sass-cache/ folder is ignored by the browser. I am surprised that automatic build does not update .sass-cache/ and I mentioned it, but in practice it does not bother me.

Dave Weitzel:
There are three ways that eclipse can update the server when you save files in the /_diffs folder. Deploy will build the war file in the dist folder of the SDK and then copy it to the deploy folder of the site. direct_deploy will build the project (copying from _diffs merging with default theme to build the non _diffs folder and coy those files to the server directly updating the webapps/your theme folder.
The final one is if you have the theme "managed" by eclipse using the add/remove tool when you right click on the server. Then any time you save the file it will be copied to the server (the project isnt being built by ant just the file being copied). Depending on the settings in developer.properties you may or may not see the changes straight away as caching may be taking place.

The file in the the webapps/yourtheme/css folder should never disappear though.

css/custom.css disappearing is my main concern.

Dave Weitzel:
If you them make manual changes to the theme on the server they will be overridden by any change you make in the plugin in Eclipse the next time you do a deploy or save a file if it is synchronized through the server settings. In my experience never modify a theme directly if you are running eclipse it is always easiest to have it synchronized as it takes about 2 seconds to save and be available which is about the time taken to move to your browser and hit refresh (CTRL-F5 to force reloading CSS files).

looking back at your original post... what was the message firefox displayed (was it a a 404 error) and was the file there? Are you sure the css was syntactically correct?
were you changing the files on the webapps folder of the web server directly?

Dave

Firefox does not display any error message but Firebug indicates that custom.css is missing.
custom.css was correct (the bug even occurs with an empty custom.css).
I only modify the theme in Eclipse, never directly in Tomcat.

Best regards,
Laurent Saboret
Dave Weitzel
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
5 dicembre 2012 14.53
Risposta

Dave Weitzel

Punteggio: Regular Member

Messaggi: 169

Data di Iscrizione: 18 novembre 2009

Messaggi recenti

Hi
I have just seen something similar in my systems and there is a "bug" in the SDK (I suspect the build-common-theme script.)
What I witnessed was that the war file that was being deployed (I was sending to a remote site) was packaging the .sass-cache directory along with the merged files (from _diffs/css and from themes/_unstyled/css

I am not sure where this .sass-cache came from as neither _styled or _unstyled theme on the reference site for the SDK has it but in mine the custom.css file was identical to the custom-common.css file essentially removing my custom.css.

To fix it, at lest temporarily just remove that directory from the war file and deploy manually, and amke sure your SDK doesnt have it in there.

Dave
Gregory Amerson
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
20 dicembre 2012 0.26
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 911

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

Hi Laurent,

Can you try the process over again but never do the "SDK > deploy" step? Just use the Eclipse deployment mechanism (publishing to server) from the start? I know that the .sass_cache will never get created but that should be ok. Liferay themes don't seem to need it if it doesn't exist. I tried this process out and was able to just make small changes to custom.css including using SASS type variables, etc and didn't have any issues. However, I was using Chrome instead of Firefox.
Laurent Saboret
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
21 dicembre 2012 1.48
Risposta

Laurent Saboret

Punteggio: New Member

Messaggi: 17

Data di Iscrizione: 22 novembre 2012

Messaggi recenti

Hi Gregory,

Thanks for looking at my problem.

I created in Liferay IDE a new theme "test2-theme", created a _diffs/css/custom.css file, and added the theme to "Liferay v6.1 CE Server (Tomcat 7)". I did not deploy the theme.
Then, in Firefox, I chose "test2-theme" in "Site Pages" control panel, and went back to my home page.
Unfortunately, the page got displayed with no theme and Firebug printed:
NetworkError: 404 Not Found - http://vhost2.rahan.scep:8080/test2-theme/css/custom.css?browserId=firefox&themeId=test2_WAR_test2theme&languageId=en_US&b=6101&t=1356082318000

I checked the files on disk and, indeed, the file liferay-plugins-sdk-6.1.1/themes/test2-theme/css/custom.css does not exist.

Best regards,
Laurent
Gregory Amerson
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
21 dicembre 2012 1.56
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 911

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

Laurent Saboret:
Hi Gregory,

Thanks for looking at my problem.

I created in Liferay IDE a new theme "test2-theme", created a _diffs/css/custom.css file, and added the theme to "Liferay v6.1 CE Server (Tomcat 7)". I did not deploy the theme.
Then, in Firefox, I chose "test2-theme" in "Site Pages" control panel, and went back to my home page.
Unfortunately, the page got displayed with no theme and Firebug printed:
NetworkError: 404 Not Found - http://vhost2.rahan.scep:8080/test2-theme/css/custom.css?browserId=firefox&themeId=test2_WAR_test2theme&languageId=en_US&b=6101&t=1356082318000

I checked the files on disk and, indeed, the file liferay-plugins-sdk-6.1.1/themes/test2-theme/css/custom.css does not exist.

Best regards,
Laurent



Hi Laurent,

Does your project in Eclipse has the css/custom.css file? It should get automatically created when you create the project. Could you zip up the project source and attach here?
Laurent Saboret
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
21 dicembre 2012 6.19
Risposta

Laurent Saboret

Punteggio: New Member

Messaggi: 17

Data di Iscrizione: 22 novembre 2012

Messaggi recenti

Hi Gregory,

In Eclipse project, docroot/css/custom.css was created during theme creation but deleted when I created the file docroot/_diffs/css/custom.css.
See attached Eclipse project.

Best regards,
Laurent
Allegati: test2-theme.tgz (1.310,0k)
Gregory Amerson
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
23 dicembre 2012 23.39
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 911

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

Hey Laurent,

Quick question. How are you launching the Liferay/Tomcat instance? Are you using the server adapter? or are you using the tomcat/bin/*.bat scripts?
Laurent Saboret
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
24 dicembre 2012 2.44
Risposta

Laurent Saboret

Punteggio: New Member

Messaggi: 17

Data di Iscrizione: 22 novembre 2012

Messaggi recenti

Hi Gregory,

I run tomcat with the "Start" button of "Liferay v6.1 CE Server (Tomcat 7)" server in Eclipse.

Regards,
Laurent
Gregory Amerson
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
26 dicembre 2012 23.27
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 911

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

Laurent Saboret:
Hi Gregory,

I run tomcat with the "Start" button of "Liferay v6.1 CE Server (Tomcat 7)" server in Eclipse.

Regards,
Laurent


Ok, so are you making any other modifications to portal settings? Any other portal-ext.properties?
Laurent Saboret
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
27 dicembre 2012 11.21
Risposta

Laurent Saboret

Punteggio: New Member

Messaggi: 17

Data di Iscrizione: 22 novembre 2012

Messaggi recenti

Gregory Amerson:
Ok, so are you making any other modifications to portal settings? Any other portal-ext.properties?


Hi Gregory,

My understanding is that Liferay reads portal-ext.properties, portal-ide.properties and portal-developer.properties when launched from Eclipse.

portal-ext.properties contains:
permissions.user.check.algorithm=6
image.hook.impl=com.liferay.portal.image.FileSystemHook

portal-ide.properties contains:
json.service.auth.token.enabled=false
include-and-override=portal-developer.properties
auto.deploy.tomcat.conf.dir=/mnt/m4/laurent.saboret/liferay-portal-6.1.1-ce-ga2/tomcat-7.0.27/conf/Catalina/localhost
jsonws.web.service.public.methods=*
com.liferay.portal.servlet.filters.etag.ETagFilter=false
com.liferay.portal.servlet.filters.header.HeaderFilter=false
auto.deploy.interval=1000

portal-developer.properties contains:
theme.css.fast.load=false
theme.images.fast.load=false
javascript.fast.load=false
javascript.log.enabled=false
layout.template.cache.enabled=false
browser.cache.disabled=true
browser.launcher.url=
combo.check.timestamp=true
freemarker.engine.cache.storage=soft:1
freemarker.engine.modification.check.interval=0
invoker.filter.chain.cache.size=0
minifier.inline.content.cache.size=0
openoffice.cache.enabled=false
velocity.engine.resource.manager.cache.enabled=false
com.liferay.portal.servlet.filters.cache.CacheFilter=false
com.liferay.portal.servlet.filters.minifier.MinifierFilter=false
com.liferay.portal.servlet.filters.strip.StripFilter=true
com.liferay.portal.servlet.filters.themepreview.ThemePreviewFilter=true

Regards,
Laurent Saboret
Gregory Amerson
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
27 dicembre 2012 17.52
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 911

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

Yep nothing looks incorrect here, that is all expected and should work just fine.

I really want to be able to reproduce this issue because it is completely blocking you from doing theme development in IDE. So how about this, would you have time for a screencast or a screenshare to demo how to reproduce?
Dave Weitzel
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
28 dicembre 2012 13.22
Risposta

Dave Weitzel

Punteggio: Regular Member

Messaggi: 169

Data di Iscrizione: 18 novembre 2009

Messaggi recenti

Just butting in here as it is close to the end of the week and theme building seems to be a black art sometimes.

I notice in the first post Laurent says in the post on December 21, 2012 4:48 AM that they "did not deploy the theme".

The structure of the project zipped up looks like it has never been "processed" by either manually selecting a task from the Liferay menu or by publishing to the server in Eclipse - Question is automatically build checked for the project? - if not will any change be processed properly if all that has been done is publishing the project to the server without a deploy?

So I would suggest doing a direct deploy or just deploy from the Liferay menu (right click on project name) to ensure the custom.css is copied to the main css folder from the _diffs/css folder, to see if that has any effect. Also check the project is checked to build automatically.

In reference to previous posts in this thread - Do we know when the sdk will be changed to rebuild the sass-cache folder every time the theme is built its a real pain deleting it before building especially as it isnt' visible in eclipse.?
Laurent Saboret
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
7 gennaio 2013 0.54
Risposta

Laurent Saboret

Punteggio: New Member

Messaggi: 17

Data di Iscrizione: 22 novembre 2012

Messaggi recenti

Dave Weitzel:
I notice in the first post Laurent says in the post on December 21, 2012 4:48 AM that they "did not deploy the theme".

The structure of the project zipped up looks like it has never been "processed" by either manually selecting a task from the Liferay menu or by publishing to the server in Eclipse - Question is automatically build checked for the project? - if not will any change be processed properly if all that has been done is publishing the project to the server without a deploy?

So I would suggest doing a direct deploy or just deploy from the Liferay menu (right click on project name) to ensure the custom.css is copied to the main css folder from the _diffs/css folder, to see if that has any effect. Also check the project is checked to build automatically.

Hi Dave,

The "custom.css disappearing problem" described above occurs when I modify _diffs/css/custom.css with "Build automatically" checked. It occurs both if I previously deploy the theme, or if I never deploy it.
Note that "deploy" works fine. The problem occurs only when I use automatic build + automatic publish.

Best regards,
Laurent
Gregory Amerson
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
18 gennaio 2013 6.13
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 911

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

Hello everyone,

Just to give you an update. Thanks to Laurent's efforts in helping me, we have been able to find the source of this issue. The problem is there is a bug in the automatic theme builder code in Liferay IDE that doesn't work if the Eclipse workspace metadata directory and the developer's source project folder are on different file systems (different mount points on Linux, etc). This was causing an underlying call to File.renameTo() to fail.

So unfortunately if you are hit with this bug in 1.6.1 the only work around is to move the plugins SDK root directory to be on the same filesystem as the Eclipse workspace directory or visa-versa. I will have a fix for this in the upcoming IDE 2.0.0 M1 build that will be available next month. If there are any users that are interested in a patched IDE plugin I can post it here if needed. Right now I don't plan on releasing a 1.6.2 just for this fix unless there is enough people impacted by this bug.

Thanks again Laurent for helping me track this one down.
Brandt Solovij
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
30 gennaio 2013 11.00
Risposta

Brandt Solovij

Punteggio: New Member

Messaggi: 14

Data di Iscrizione: 23 marzo 2012

Messaggi recenti

Thanks Greg for the update. I'm on Mac OSx and just getting started with Liferay development. My SDK is in my User directory while my liferay portal + tomcat is in the /usr/local/ and I run it via the command line and it is integrated into Eclipse as a "remote" server.

I face a similar issue insofar that my custom.css is not being applied. The *.vm templating works as intended however....
Brandt Solovij
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
6 febbraio 2013 13.49
Risposta

Brandt Solovij

Punteggio: New Member

Messaggi: 14

Data di Iscrizione: 23 marzo 2012

Messaggi recenti

so this is somewhat still an issue for me.

n out of x times I run clean -> redeploy and only sometimes are the _diffs->css .css files parsed.


I have found a way to watch for the redeploy error :


sometimes the redeploy console log reads :


Loading jar:file:/usr/local/liferay-portal-6.1.10-ee-ga1/tomcat-7.0.25/webapps/ROOT/WEB-INF/lib/portal-impl.jar!/portal.properties
Building zip: ......



That is when it fails.


When it works - it produces something like :


Loading jar:file:/usr/local/liferay-portal-6.1.10-ee-ga1/tomcat-7.0.25/webapps/ROOT/WEB-INF/lib/portal-impl.jar!/portal.properties
Parsed ..... .css in n.ms
Parsed ..... .css in n.ms
Building zip: /


what gives? this is super frustrating and greatly impedes my productivity
Adeel Aslam
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
3 luglio 2013 16.35
Risposta

Adeel Aslam

Punteggio: New Member

Messaggi: 18

Data di Iscrizione: 8 dicembre 2012

Messaggi recenti

Hi,

I was able to reproduce the same problem you have I updated my Liferay Server and Plugins SDK,

I have also upgraded Liferay IDE to Juno latest available I started a theme everything got deployed but not the CSS.

After fighting with the cluttering and the CSS not problem I identified the fix and the cause too

Once you have custom.css deployed reloading it does not get automatically done using Liferay -> SDK -> Deploy

Workaround

Clean the project (Optional)

Liferay -> SDK -> Clean
Liferay -> SDK -> deploy


It always works. I have tested it on three themes.
Gregory Amerson
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
25 ottobre 2013 2.12
Risposta

Gregory Amerson

LIFERAY STAFF

Punteggio: Liferay Master

Messaggi: 911

Data di Iscrizione: 16 febbraio 2010

Messaggi recenti

Justyna Gralinska:
Gregory Amerson:
Hello everyone,

Just to give you an update. Thanks to Laurent's efforts in helping me, we have been able to find the source of this issue. The problem is there is a bug in the automatic theme builder code in Liferay IDE that doesn't work if the Eclipse workspace metadata directory and the developer's source project folder are on different file systems (different mount points on Linux, etc). This was causing an underlying call to File.renameTo() to fail.

So unfortunately if you are hit with this bug in 1.6.1 the only work around is to move the plugins SDK root directory to be on the same filesystem as the Eclipse workspace directory or visa-versa. I will have a fix for this in the upcoming IDE 2.0.0 M1 build that will be available next month. If there are any users that are interested in a patched IDE plugin I can post it here if needed. Right now I don't plan on releasing a 1.6.2 just for this fix unless there is enough people impacted by this bug.

Thanks again Laurent for helping me track this one down.



Hi Gregory! I think I have a similar issue. This is my file structure:

- my 'liferay-plugins-sdk-6.1.1', 'bundles' and 'apache-ant-1.9.2' folders in C:\java\

- and 'eclipse_Liferay_IDE_1.6.2', 'liferay-portal-6.1.2-ce-ga3' and 'workspace' folders all located in C:\liferay

When I create a theme and try to deploy it using Eclipse, the theme is built, a war file is created in C:\java\liferay-plugins-sdk-6.1.1\dist but the theme is not automatically deployed. I need to copy the war file to my deploy folder on the remote server for the theme to be deployed. Is this normal? If I need to change my file structure, what should it be?

Please note that I have Liferay installed both on my local machine and on the remote server and I'm using the Liferay remote server adapter. I'm afraid that my files won't be synchronised if I continue deploying this way.


Hey Justyna,

If you are able to reproduce, can you post a new JIRA ticket to IDE project? https://issues.liferay.com/browse/IDE We can follow up there.
Justyna Gralinska
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
12 febbraio 2014 13.41
Risposta

Justyna Gralinska

Punteggio: New Member

Messaggi: 14

Data di Iscrizione: 13 agosto 2013

Messaggi recenti

Thank you Gregory. I can't remember exactly how we solved it but we did. I think the new upgrade to 6.2 might have fixed it. For anyone else having this issue - you can always export your theme/ plugin / hook as a WAR file and deploy it from Liferay (App Manager > Install..).
sujeesh sujeesh
RE: Liferay IDE 1.6.1 does not compile and deploy automatically custom.css
17 marzo 2014 21.58
Risposta

sujeesh sujeesh

Punteggio: New Member

Messaggi: 1

Data di Iscrizione: 13 febbraio 2014

Messaggi recenti

I am new to liferay , i installed my liferay 6.1.2 but i am not able to install my themes using the plugin installation under controll panel, the screen is showing blank , please help me on this ?
Allegato

Allegati: blank.png (28,8k)