Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Neetu Chopra
Liferay doesn't start still.
30 gennaio 2013 20.51
Risposta

Neetu Chopra

Punteggio: New Member

Messaggi: 3

Data di Iscrizione: 29 gennaio 2013

Messaggi recenti

Hi,

I am working on centos 6.2.
I installed Liferay as per this link:
http://www.bluhm-de.com/installing-liferay-6.1.1-on-centos-6.2

Further I have used all commands mentioned in the thread below but Liferay does not start automatically after boot:
http://www.liferay.com/community/forums/-/message_boards/message/8255964

Please help.

This server will be soon used for production purposes.

Regards,
Neetu Chopra
Hitoshi Ozawa
RE: Liferay doesn't start still.
31 gennaio 2013 14.34
Risposta

Hitoshi Ozawa

Punteggio: Liferay Legend

Messaggi: 7990

Data di Iscrizione: 23 marzo 2010

Messaggi recenti

Liferay 6.1.1 requires Oracle JDK 1.6. JDK1.7 is planned to be supported in the next version but not in Liferay 6.1.1.

Also, the next time you post, please post the error message you are getting.
Neetu Chopra
RE: Liferay doesn't start still.
31 gennaio 2013 21.01
Risposta

Neetu Chopra

Punteggio: New Member

Messaggi: 3

Data di Iscrizione: 29 gennaio 2013

Messaggi recenti

Hii,

Yes that was already realised by me and corrected.JDK 1.6 is currently installed on centos VM.

May be I wasn't clear in describing my query.

The liferay is working perfectly when I start it manually (cd liferay/tomcat/bin/ and then ./startup.sh).
But I want it to start automatically if a reboot is performed.

How to do this?

I created a script name lportal in /etc/init.d as described in the link:
http://www.liferay.com/community/forums/-/message_boards/message/8255964

Also added two comment lines to make it work.

But still no success. emoticon

Any suggestions what could I have done wrong?

Regards,
Neetu Chopra
Neetu Chopra
RE: Liferay doesn't start still.
11 febbraio 2013 23.34
Risposta

Neetu Chopra

Punteggio: New Member

Messaggi: 3

Data di Iscrizione: 29 gennaio 2013

Messaggi recenti

Any suggestions would be highly appreciated. emoticon
Hitoshi Ozawa
RE: Liferay doesn't start still.
12 febbraio 2013 0.54
Risposta

Hitoshi Ozawa

Punteggio: Liferay Legend

Messaggi: 7990

Data di Iscrizione: 23 marzo 2010

Messaggi recenti

You haven't mentioned which application server you're using.
Anyways, this probably really isn't a question on getting liferay to start as a service but rather a question on getting the application server you're using to start as a service.

Check you application server's log to see if you have any directory permission errors. If not, better ask your question at the application server forum on setting up your application server as a service.

Liferay starts/stops OK on my CentOS VM as a service so it's not a problem with liferay.