Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Sarah Tsang
NTLMv2 Authentication
12 luglio 2013 4.27
Risposta

Sarah Tsang

Punteggio: New Member

Messaggi: 16

Data di Iscrizione: 7 maggio 2013

Messaggi recenti

Hi all,

I setup Liferay 6.1 CE GA2 in Windows7 with Tomcat. The server Windows 2008 R2 joined the Microsoft AD.
In LDAP and NTLM setting, anything is work fine. The URL: http://localhost:8080, the Liferay can import user list into DB got from LDAP and SSO is success.

However, the URL: http://127.0.0.1:8080, when clicking "Sign In" hyperlink, the behavior is different, it would be prompted out "Windows Security" Sign-In dialog to auth again.

Any expert would know what problem in it? why Liferay to prompt out the "Windows Security" Sign-In dialog box if using IP address?


Thank you very much.
Péter Borkuti
RE: NTLMv2 Authentication
15 luglio 2013 8.09
Risposta

Péter Borkuti

LIFERAY STAFF

Punteggio: New Member

Messaggi: 18

Data di Iscrizione: 15 giugno 2012

Messaggi recenti

Hi Sarah,

Just a guess:

Probably it could be connected to Liferay's virtual host setting.

If you have time, could you try the following:

1. create a new hostname for localhost-computer in Windows\system32\drivers\etc\hosts which points to 127.0.0.1, example:
127.0.0.1 a1.com

2. check Sign In with this hostname if Windows Security auth. dialog comes up
http://a1.com:8080

3. if yes, try to modify Liferay's Virtual Host settings to "a1.com".
If there is a connection between virtual host settings and your issue, now "http://a1.com:8080" will use NTLM and LDAP and
"http://localhost:8080" will ask auth again.
Sarah Tsang
RE: NTLMv2 Authentication
5 agosto 2013 20.00
Risposta

Sarah Tsang

Punteggio: New Member

Messaggi: 16

Data di Iscrizione: 7 maggio 2013

Messaggi recenti

Péter Borkuti:
Hi Sarah,

Just a guess:

Probably it could be connected to Liferay's virtual host setting.

If you have time, could you try the following:

1. create a new hostname for localhost-computer in Windows\system32\drivers\etc\hosts which points to 127.0.0.1, example:
127.0.0.1 a1.com

2. check Sign In with this hostname if Windows Security auth. dialog comes up
http://a1.com:8080

3. if yes, try to modify Liferay's Virtual Host settings to "a1.com".
If there is a connection between virtual host settings and your issue, now "http://a1.com:8080" will use NTLM and LDAP and
"http://localhost:8080" will ask auth again.


Hi Peter,

Thanks for your suggestion.
Finally, we found the solution which is setup the "a1.com" in local intranet of IE security setting. Then, the Windows Security Auth dialog has not come up again.