Vista Combinata Vista Piatta Vista ad Albero
Discussioni [ Precedente | Successivo ]
toggle
Carlos Muller
Parche a aplicar antes de hacer upgrade de 5.2.3 a 6.0.6
26 giugno 2011 11.13
Risposta

Carlos Muller

Punteggio: New Member

Messaggi: 18

Data di Iscrizione: 1 giugno 2011

Messaggi recenti

Buenas tardes a tod@s,

Estoy haciendo un upgrade de un liferay CE 5.2.3 a la 6.0.6. He encontrado en el siguiente post:

http://www.liferay.com/es/community/forums/-/message_boards/view_message/6777473#_19_message_5603227 (ver al final del hilo)

El siguiente texto:

Like this topic says : http://www.liferay.com/community/forums/-/message_boards/message/6493162
Apply a patch to liferay 6.0.6 source code (you can download it easily through official liferay download site on sourceforge).
This path is available for download to this corresponding solved issue : http://issues.liferay.com/browse/LPS-12109
After application, just remplace the built portal-impl.jar with the one in tomcat/webapps/ROOT/WEB-INF/lib

En él se comenta un problema que existe en la migración con la Document Library, relacionado con el uso del caracter coma en vez del punto, y se habla de la necesidad de sustituir el portal-impl.jar en tomcat/webapps/ROOT/WEB-INF/lib con uno que debe estar disponible "facilmente" en http://issues.liferay.com/browse/LPS-12109.

Pero soy incapaz de bajar de esa url algo parecido a un parche... Alguno de vosotros lo ha tenido que hacer? De donde me puedo bajar ese jar, o algun parche para modificar el que tengo en mi bundle 6.0.6?

Un saludo y gracias por adelantado.
Sergio Sanchez
RE: Parche a aplicar antes de hacer upgrade de 5.2.3 a 6.0.6
1 luglio 2011 4.11
Risposta

Sergio Sanchez

Punteggio: Junior Member

Messaggi: 41

Data di Iscrizione: 3 febbraio 2011

Messaggi recenti

Hola Carlos,

En JIRA te indica el código que corrige ese defecto. Puedes localizarlo en SVN y bajarte esa clase.
Una vez la tengas incluyela en un plugin EXT y dentro de la carpeta de código fuente de ext-impl/src
Tras esto ya puedes desplegarla con ant deploy a tu servidor o generar el war que empaqueta esta clase.

Cuentame si consigues completar el proceso y si el error se corrige

Salu2
Carlos Muller
RE: Parche a aplicar antes de hacer upgrade de 5.2.3 a 6.0.6
17 luglio 2011 10.39
Risposta

Carlos Muller

Punteggio: New Member

Messaggi: 18

Data di Iscrizione: 1 giugno 2011

Messaggi recenti

Por favor, no encuentro un acceso a esa clase. ¿Podrías ponerme un enlace?

Imagino que esa misma clase resuelve el problema al migrar la document-library, que también falla por buscar archivos llamados 1,0 cuando los que existen son los 1.0.

Gracias por adelantado
Carlos Muller
RE: Parche a aplicar antes de hacer upgrade de 5.2.3 a 6.0.6
26 luglio 2011 16.21
Risposta

Carlos Muller

Punteggio: New Member

Messaggi: 18

Data di Iscrizione: 1 giugno 2011

Messaggi recenti

Buenas noches, despues de un tiempo he aplicado la solución comentada por Sergio; desplegar un plugin ext con la clase:

import java.util.Locale;
public class DLFileEntryVersionUpgradeColumnImpl extends BaseUpgradeColumnImpl
{
public DLFileEntryVersionUpgradeColumnImpl(String name) { super(name); }

public Object getNewValue(Object oldValue) throws Exception
{
double version = GetterUtil.getDouble(String.valueOf(oldValue));
//NumberFormat numberFormat = NumberFormat.getInstance();
NumberFormat numberFormat = NumberFormat.getInstance(Locale.US);

numberFormat.setMaximumFractionDigits(1);
numberFormat.setMinimumFractionDigits(1);
return numberFormat.format(version);
}
}

Lamentablemente, en principio me ha echado abajo mi instancia del portal. Ya no arranca bien, no despliega ningun plugin de los que tenia, saltando la excepcion:

23:05:33,187 INFO [CaptchaImpl:127] Initializing com.liferay.portal.captcha.simplecaptcha.SimpleCaptchaImpl
23:06:08,015 ERROR [IncludeTag:231] Current URL / generates exception: javax.servlet.ServletException: com.liferay.portal.NoSuchGroupException: No Group exists with the primary key 10136
23:06:08,015 ERROR [IncludeTag:154] com.liferay.portal.NoSuchGroupException: No Group exists with the primary key 10136

Alguna idea?
Solo Imr
RE: Parche a aplicar antes de hacer upgrade de 5.2.3 a 6.0.6
11 agosto 2011 8.22
Risposta

Solo Imr

Punteggio: Junior Member

Messaggi: 38

Data di Iscrizione: 9 ottobre 2008

Messaggi recenti

Hola Carlos.
Has podido solucionar el problema ?
Saludos y gracias