フォーラム

ホーム » Liferay Portal » English » 6. Portal Framework

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Vaneet Sharma
Internet Proxy Settings
2008/09/08 8:36
答え

Vaneet Sharma

ランク: Regular Member

投稿: 195

参加年月日: 2008/07/25

最近の投稿

Hi,

Where to change the proxy settings for connecting to Plugin Repository at http://plugins.liferay.com/community.

Thanks
Vaneet Sharma
RE: Internet Proxy Settings
2008/09/12 9:00
答え

Vaneet Sharma

ランク: Regular Member

投稿: 195

参加年月日: 2008/07/25

最近の投稿

I tried doing changes in sytem.ext.properties file but nothing happened.
Any one.......any idea how to do this.


Thanks in advance
Frederik Weishäupl
RE: Internet Proxy Settings
2008/10/24 3:57
答え

Frederik Weishäupl

ランク: Junior Member

投稿: 46

参加年月日: 2006/01/07

最近の投稿

Have you solved this issue? I've got the same problem.

Thx.

Regards
Frederik
Vaneet Sharma
RE: Internet Proxy Settings
2008/11/06 21:40
答え

Vaneet Sharma

ランク: Regular Member

投稿: 195

参加年月日: 2008/07/25

最近の投稿

Still not able to figure out , how to connect to plugin repository
Holger Widmann
RE: Internet Proxy Settings
2008/11/27 6:13
答え

Holger Widmann

ランク: New Member

投稿: 4

参加年月日: 2008/11/27

最近の投稿

This helped me to get acces to the plugin repository from behind a proxy:

I've tracked down a bit of code in Liferay 5.1.0 that needs to be rewritten. In com.liferay.portal.util.HttpImpl where it says:
 1public boolean isNonProxyHost(String host) {
 2    if (_nonProxyHostsPattern [b]== null ||[/b]
 3        _nonProxyHostsPattern.matcher(host).matches()) {
 4            return true;
 5    }
 6    else {
 7        return false;
 8    }
 9}


it SHOULD say:
 1public boolean isNonProxyHost(String host) {
 2    if (_nonProxyHostsPattern [b]!= null &&[/b]
 3        _nonProxyHostsPattern.matcher(host).matches()) {
 4           return true;
 5    }
 6    else {
 7        return false;
 8    }
 9}


To avoid recompiling code, if you are behind a proxy make sure you set the system property http.nonProxyHosts to a non null value. Basically, set it to "dummy.at.nowhere" if you don't have real values to put in there. Set http.proxyPort and http.proxyHost normally.

Under SJAS/Glassfish you can easily set the system properties in Admin Console/Application Server/JVM Settings/JVM Options.

Found in this post.
David Tildesley
RE: Internet Proxy Settings
2009/05/07 19:34
答え

David Tildesley

ランク: Junior Member

投稿: 34

参加年月日: 2008/08/03

最近の投稿

5.2.2 still has this faulty code as below. The workaround is as described to have at least one nonProxyHost specified. You should put the proxy settings in the system-ext.properties file. Even though the admin manual is not clear, you can still create a system-ext.properties file and put it in the same place as portal-ext.properties file and expect Liferay to pick it up.

1
2http.proxyHost=<your proxy host name>
3https.proxyHost=<your proxy host name>
4https.proxyPort=8080
5http.proxyPort=8080
6http.nonProxyHosts="localhost"


NB1. If your proxy server requires authentication you should put the authentication settings in the portal-ext.properties file I believe (although I have not tested this out).

NB2. This is nothing to do with reverse proxy server (where clients access liferay portal via a DMZ reverse proxy server such as Apache with mod_proxy.

NB3. This is everything to do with allowing liferay application and portlets to access an external web resource via a (forward) proxy server e.g. to allow acess to the official and community plugin repositories.

Holger Widmann:
This helped me to get acces to the plugin repository from behind a proxy:

I've tracked down a bit of code in Liferay 5.1.0 that needs to be rewritten. In com.liferay.portal.util.HttpImpl where it says:
 1public boolean isNonProxyHost(String host) {
 2    if (_nonProxyHostsPattern [b]== null ||[/b]
 3        _nonProxyHostsPattern.matcher(host).matches()) {
 4            return true;
 5    }
 6    else {
 7        return false;
 8    }
 9}


it SHOULD say:
 1public boolean isNonProxyHost(String host) {
 2    if (_nonProxyHostsPattern [b]!= null &&[/b]
 3        _nonProxyHostsPattern.matcher(host).matches()) {
 4           return true;
 5    }
 6    else {
 7        return false;
 8    }
 9}


To avoid recompiling code, if you are behind a proxy make sure you set the system property http.nonProxyHosts to a non null value. Basically, set it to "dummy.at.nowhere" if you don't have real values to put in there. Set http.proxyPort and http.proxyHost normally.

Under SJAS/Glassfish you can easily set the system properties in Admin Console/Application Server/JVM Settings/JVM Options.

Found in this post.
Kolja Köster
RE: Internet Proxy Settings
2009/05/19 2:09
答え

Kolja Köster

ランク: Regular Member

投稿: 164

参加年月日: 2009/05/11

最近の投稿

David Tildesley:
5.2.2 still has this faulty code as below. The workaround is as described to have at least one nonProxyHost specified. You should put the proxy settings in the system-ext.properties file. Even though the admin manual is not clear, you can still create a system-ext.properties file and put it in the same place as portal-ext.properties file and expect Liferay to pick it up.

Could anybode state, where to put this file? Changing catalina.properties and portal.properties did not work for me. There is no system-ext.properties in the standard bundle.

Regards
Kolja
Arnaud Deslandes
RE: Internet Proxy Settings
2009/05/19 6:28
答え

Arnaud Deslandes

ランク: New Member

投稿: 23

参加年月日: 2007/06/25

最近の投稿

You just have to create this plain text file, containing only :

http.proxyHost=xx.xx.xx.xx
https.proxyHost=xx.xx.xx.xx
http.proxyPort=xx
https.proxyPort=xx
http.nonProxyHosts="localhost"

and place it in {appserver}/webapps/ROOT/WEB-INF/classes
Kolja Köster
RE: Internet Proxy Settings
2009/06/05 5:36
答え

Kolja Köster

ランク: Regular Member

投稿: 164

参加年月日: 2009/05/11

最近の投稿

Arnaud Deslandes:
You just have to create this plain text file, containing only :

http.proxyHost=xx.xx.xx.xx
https.proxyHost=xx.xx.xx.xx
http.proxyPort=xx
https.proxyPort=xx
http.nonProxyHosts="localhost"

and place it in {appserver}/webapps/ROOT/WEB-INF/classes

I apologize for taking so long for a reply. This approach worked. Many thanks.

Regards
Kolja
Christian Merkel
RE: Internet Proxy Settings
2010/01/06 23:49
答え

Christian Merkel

ランク: Regular Member

投稿: 111

参加年月日: 2009/12/14

最近の投稿

I got the same problem!

But our Proxy needs authentication!

What lines i have to add emoticon

something like:
1http.user=admin
2http.password=password


??

Thx for the help!
William Fleming
RE: Internet Proxy Settings
2011/03/07 3:56
答え

William Fleming

ランク: Regular Member

投稿: 180

参加年月日: 2010/09/15

最近の投稿

I had issues but found that you need it entered in

catalina.properties and you portal-ext.properties

http.proxyHost=yourProxyURL
http.proxyPort=yourProxyPort
http.proxyUser=yourUserName
http.proxyPassword=yourPassword

Boom! Bask in glory on the internet in your portal.
Yan Naing Oo
RE: Internet Proxy Settings
2011/10/18 0:29
答え

Yan Naing Oo

ランク: Regular Member

投稿: 180

参加年月日: 2011/02/17

最近の投稿

William Fleming:
I had issues but found that you need it entered in

catalina.properties and you portal-ext.properties

http.proxyHost=yourProxyURL
http.proxyPort=yourProxyPort
http.proxyUser=yourUserName
http.proxyPassword=yourPassword

Boom! Bask in glory on the internet in your portal.


Hi William,

I have to ask you for following value, that i mentioned is anything wrong ? let me know if you can correct ?

http.proxyHost=yourProxyURL (by pass URL based on browser options) ?
http.proxyPort=8080 (default) ?
http.proxyUser= if no user - leave blank ?
http.proxyPassword= if no pwd - leave blank ?


Thanks
Jevon Wright
RE: Internet Proxy Settings
2011/12/08 13:59
答え

Jevon Wright

ランク: New Member

投稿: 8

参加年月日: 2011/12/05

最近の投稿

Yan Naing Oo:
http.proxyHost=yourProxyURL (by pass URL based on browser options) ?
http.proxyPort=8080 (default) ?
http.proxyUser= if no user - leave blank ?
http.proxyPassword= if no pwd - leave blank ?

Thanks


Yes, if your proxy does not have a username or password you can leave these fields blank, or (even better) not include them in your .properties file at all.