フォーラム

ホーム » Liferay Portal » English » 3. Development

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
Sushil Mayengbam
Email attachment not coming
2012/04/23 23:36
答え

Sushil Mayengbam

ランク: Junior Member

投稿: 53

参加年月日: 2010/02/16

最近の投稿

Hi,

In message board, I posted a message with an attachment and I've also configured my mailing alias in the configuration panel.
I received only the text message w/o the attachment in my mail box. I'm using 6.0 version.
Is there any limitation or known bug on message board's mailing with attachment(s)?

Any information is appreciated.

Thanks,
Sushil
David H Nebinger
RE: Email attachment not coming
2012/04/24 5:11
答え

David H Nebinger

ランク: Liferay Legend

投稿: 6290

参加年月日: 2006/09/01

最近の投稿

Possibly your mail server interfered to strip the attachment if it exceeded size limitations...

Basically if it left Liferay intact (no error reported in the logs), the problem is elsewhere.
Hitoshi Ozawa
RE: Email attachment not coming
2012/04/27 18:19
答え

Hitoshi Ozawa

ランク: Liferay Legend

投稿: 7990

参加年月日: 2010/03/23

最近の投稿

There's this unresolved issue:

http://issues.liferay.com/browse/LPS-20923
Sushil Mayengbam
RE: Email attachment not coming
2012/04/30 3:33
答え

Sushil Mayengbam

ランク: Junior Member

投稿: 53

参加年月日: 2010/02/16

最近の投稿

Hitoshi Ozawa:
There's this unresolved issue:

http://issues.liferay.com/browse/LPS-20923


Thanks Hitoshi for your quick reply. I tried again by giving the 'smtp.gmail.com:465' as my SMTP Server configuration (control panel).
When I subscribed a message with attachment (using my Gmail account), I got simply the message (when there's any update on it ) at my GMAIL inbox but w/o the attachment.

With your reply, I've got to believe that this is still an issue currently on 6.0 version.

@David: It seems (from your reply) that it's working at your end. May I request you to please confirm on this?

Thanks dude.

Regards,
Sushil
David H Nebinger
RE: Email attachment not coming
2012/04/30 5:12
答え

David H Nebinger

ランク: Liferay Legend

投稿: 6290

参加年月日: 2006/09/01

最近の投稿

Sure, I've been using 6.0 for awhile now w/ no problem w/ attachments...

But then, I'm not hitting gmail like you are, I'm hitting a regular SMTP server (postfix).
Sushil Mayengbam
RE: Email attachment not coming
2012/04/30 5:50
答え

Sushil Mayengbam

ランク: Junior Member

投稿: 53

参加年月日: 2010/02/16

最近の投稿

David H Nebinger:
Sure, I've been using 6.0 for awhile now w/ no problem w/ attachments...

But then, I'm not hitting gmail like you are, I'm hitting a regular SMTP server (postfix).



This is strange. If this is the case, I think there's some problem in the way SMTP 'push' protocol is implemented in Liferay. Delivering attachment successfully on one SMTP Server and ignoring it on another - isn't this a bug emoticon? I am sure it is. Thanks David for your info.

Regards,
Sushil
David H Nebinger
RE: Email attachment not coming
2012/04/30 6:27
答え

David H Nebinger

ランク: Liferay Legend

投稿: 6290

参加年月日: 2006/09/01

最近の投稿

It's not a bug, it's a security feature...

Email systems can handle attachments differently. My email server, for example, includes virus scanning for all incoming emails. Some attachments will be automatically stripped (i.e. any with a .exe extension), and any flagged with a virus will also be stripped. I can set a size limit on attachments, too - any that are too big are also stripped. I can whitelist and/or blacklist senders, so that only authorized users can send attachments; I can even limit the kinds of attachments (by filename extension) they can send. This does not represent a bug in the system, it represents my ideal of how security should be handled within my email system, and my requirements are probably different than yours or Hitoshi's or Gmail's.

Much of this would be totally transparent to the process sending the email w/ the attachment - it will get the response code indicating success, but the attachment will not be available in the email.

Who knows what gmail may or may not be doing w/ your attachment, since there is no visibility inside of their system to determine what is going on or why.

Long story short, no production Liferay system should ever be using an individual's gmail account for sending out emails.

6.0 has been out for quite awhile and, had there been any issues w/ attachments, there would have been lots of folks complaining about it long before now.

I'm fairly certain it is not a bug. The only way you could prove to me that it was would be to create a stand-alone java program sending email to gmail using your attachment and it going through. I'm willing to bet that if you boiled it down to just these steps you'd probably find gmail was tossing out the attachment and was probably the culprit, not Liferay.
Sushil Mayengbam
RE: Email attachment not coming
2012/05/02 2:46
答え

Sushil Mayengbam

ランク: Junior Member

投稿: 53

参加年月日: 2010/02/16

最近の投稿

David, greetings!
See, I sent the same attachment with the same SMTP configuration (of GMAIL with my user name/password as I configured on Liferay's control panel >Adminstraction> Mail) on Mozilla's Thunderbird just to ascertain that the issue is not with Liferay 6.0. You know what - the attachment has landed happily on my gmail account showing my cute baby's picture. In this situation, I was tempted to feel that there might be an issue in Liferay system. If something works with Thunderbird (an SMPT client ) and not working on another SMTP client (implemented by Liferay) passing the same information, I think one would obviously think that there could be an issue with the later (w.r.t SMTP related things). I think I answered your last question here. Please keep on sharing your thoughts. I'm indeed enlightened by your explanation.

Note: I agreed upon your observation that one must not use GMAIL account to relay messages to others in prod. I was using GMAIL a/c just for my testing emoticon

Cheers!,
Sushil
David H Nebinger
RE: Email attachment not coming
2012/05/02 5:27
答え

David H Nebinger

ランク: Liferay Legend

投稿: 6290

参加年月日: 2006/09/01

最近の投稿

I can point my mail client at gmail too, but that is not a valid test scenario.

Until you get down and dirty with Javamail and hooking it up to your SMTP server, you're not going to know whether it's a communication issue, javamail issue, or Liferay bug.
Tobias Jansson
RE: Email attachment not coming
2012/08/30 4:36
答え

Tobias Jansson

ランク: New Member

投稿: 7

参加年月日: 2010/12/15

最近の投稿

We have the same problem, with both CE 6.1 GA1 and GA2
We run our own mail server. And everything works just as it should.
We are supposed to start using Liferay as intranet.
When we connect ourselves to our mail server through Liferay i will not find any email attachment.
But if we use our existing intranet (horde) or if we connect via outlook / thunderbird we sees the e-mail attachment.
There isent any errors in catalina.out.
Any one has any idea whats wrong?
David H Nebinger
RE: Email attachment not coming
2012/08/30 14:24
答え

David H Nebinger

ランク: Liferay Legend

投稿: 6290

参加年月日: 2006/09/01

最近の投稿

You'll need to check your mailserver logs to see what it's doing with the attachments.
Kevin Pennock
RE: Email attachment not coming
2012/10/19 12:48
答え

Kevin Pennock

ランク: New Member

投稿: 10

参加年月日: 2012/07/10

最近の投稿

Brian,

I have been able to do some testing on this issue since I talked with you at the Symposium. I actually do believe this is a bug in the mail portlet for 6.1.

I pointed a version of RoundCube to our Postfix server and I can see the attachments.
I have installed version 6.0.6 and using the mail portlet in that version I can see the attachments.
I have installed both version GA1 and GA2 of 6.1 and neither of these versions with the mail portlet will display attachments.

The other thing I have tried is getting the 6.0.6 version of the mail portlet into 6.1 but it does not deploy.

At this point, I guess I will pull down the source for the most recent mail portlet and see if I can figure out what is going on. Let me know if you have any other suggestions.

Thanks,
Kevin
Hitoshi Ozawa
RE: Email attachment not coming
2012/10/20 5:00
答え

Hitoshi Ozawa

ランク: Liferay Legend

投稿: 7990

参加年月日: 2010/03/23

最近の投稿

Have you created an issue in jira explaining your issue?
Kevin Pennock
RE: Email attachment not coming
2012/10/22 9:03
答え

Kevin Pennock

ランク: New Member

投稿: 10

参加年月日: 2012/07/10

最近の投稿

Hitoshi,

I have not but I plan to do that today.

Thanks
Kevin Pennock
RE: Email attachment not coming
2012/10/22 9:32
答え

Kevin Pennock

ランク: New Member

投稿: 10

参加年月日: 2012/07/10

最近の投稿

Looks like an issue was created a couple of weeks ago. LPS-30366