構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Peter Hellstrand
The portal is slow (very few users)
2012/07/11 12:24
答え

Peter Hellstrand

ランク: Regular Member

投稿: 167

参加年月日: 2011/11/30

最近の投稿

Hi

I have a problem with an application. It is not in production yet so very few users. The problem only occur sometimes. Most times if you havent touched anything for a while. It is not our portlets generally speaking. I it for example when uploading files. creating web content and so on. Can you give me a hint we to start? Do you have any tools for this.

I use the tomcat bundled version.
David H Nebinger
RE: The portal is slow (very few users)
2012/07/11 13:46
答え

David H Nebinger

Community Moderator

ランク: Liferay Legend

投稿: 9421

参加年月日: 2006/09/01

最近の投稿

If you run it under eclipse you can use the profiling tools...
Peter Hellstrand
RE: The portal is slow (very few users)
2012/07/11 22:26
答え

Peter Hellstrand

ランク: Regular Member

投稿: 167

参加年月日: 2011/11/30

最近の投稿

Thank you as usual david. You mean on my local liferay portal?

I installed VisualVM and it looks like nothing strange as I can see. Maybe a network problem.


image host
David H Nebinger
RE: The portal is slow (very few users)
2012/07/11 14:37
答え

David H Nebinger

Community Moderator

ランク: Liferay Legend

投稿: 9421

参加年月日: 2006/09/01

最近の投稿

Is the snapshot taken during the slow period, or are you saying it is consistently slow?
Hitoshi Ozawa
RE: The portal is slow (very few users)
2012/07/11 15:08
答え

Hitoshi Ozawa

ランク: Liferay Legend

投稿: 7949

参加年月日: 2010/03/23

最近の投稿

If you are having performance issue while uploading file or creating web content (do you mean when saving web content?), it may be an issue with network or your database.

Check if performance slows down while other is uploading a file or if it's just slow to upload your file.
Peter Hellstrand
RE: The portal is slow (very few users)
2012/07/11 22:25
答え

Peter Hellstrand

ランク: Regular Member

投稿: 167

参加年月日: 2011/11/30

最近の投稿

Thank you. I have to investigate this further beacuse the slow periods is very rare and did not happend to me during the 30+min I was clicking around. The snapshot is not during a slow period.
Peter Hellstrand
RE: The portal is slow (very few users)
2012/07/11 22:32
答え

Peter Hellstrand

ランク: Regular Member

投稿: 167

参加年月日: 2011/11/30

最近の投稿

This is how our customer describes it.

"When it comes to performance, I have sometimes experienced this when I go between pages or open an editor such as when I am editing an article."
Hitoshi Ozawa
RE: The portal is slow (very few users)
2012/07/12 6:23
答え

Hitoshi Ozawa

ランク: Liferay Legend

投稿: 7949

参加年月日: 2010/03/23

最近の投稿

The editor performance is probably javascript download time as it oftens happens here on liferay.com
OR
it just may be that your customer is running something else while viewing or editing a page.
Peter Hellstrand
RE: The portal is slow (very few users)
2012/07/12 7:25
答え

Peter Hellstrand

ランク: Regular Member

投稿: 167

参加年月日: 2011/11/30

最近の投稿

I put this in portal-ext.properties. Hopes it help.


last.modified.check=false
theme.css.fast.load=true
javascript.fast.load=true
Linus Sphinx
RE: The portal is slow (very few users)
2012/07/12 10:42
答え

Linus Sphinx

ランク: Junior Member

投稿: 89

参加年月日: 2010/08/12

最近の投稿

I have found this quite helpful in similar situations;
http://httpd.apache.org/docs/2.0/programs/ab.html
God speed and good luck.