フォーラム

ホーム » Liferay Portal » English » 2. Using Liferay » General

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Przemek Krysztofiak
Message board problem after setting web.server.host
2012/07/26 3:37
答え

Przemek Krysztofiak

ランク: New Member

投稿: 4

参加年月日: 2012/07/26

最近の投稿

Hello,
I got problem with message board after opening my portal to the world. When I work on localhost:8080 everything with message board works fine. But after i change
portal-ext.properties and add following lines:

web.server.host=my.company
web.server.protocol=https
web.server.http.port=80

I can not post new thread, add category. I can replay to message but it also does not work good. When I replay there is an annoucement: "Your request completed successfully.", but I'm not redirected to the messaged I just added. Instead I can add another message. That is not the way it should works. It also work well on localhost.

I working with liferay Liferay Portal 6.1 Community Edition 6.1 GA 1 bundled with tomcat.

I would apreaciate any help.
Jignesh Vachhani
RE: Message board problem after setting web.server.host
2012/07/26 4:15
答え

Jignesh Vachhani

ランク: Liferay Master

投稿: 780

参加年月日: 2008/03/10

最近の投稿

Does it giving any error in server console ?
Przemek Krysztofiak
RE: Message board problem after setting web.server.host
2012/07/26 4:34
答え

Przemek Krysztofiak

ランク: New Member

投稿: 4

参加年月日: 2012/07/26

最近の投稿

There is nothing in catalina.out
Jignesh Vachhani
RE: Message board problem after setting web.server.host
2012/07/26 4:45
答え

Jignesh Vachhani

ランク: Liferay Master

投稿: 780

参加年月日: 2008/03/10

最近の投稿

Did you make any message board related code changes part from this properties ?
Przemek Krysztofiak
RE: Message board problem after setting web.server.host
2012/07/26 4:51
答え

Przemek Krysztofiak

ランク: New Member

投稿: 4

参加年月日: 2012/07/26

最近の投稿

I did not. I just use standard Message board portlet.
Jignesh Vachhani
RE: Message board problem after setting web.server.host
2012/07/26 5:08
答え

Jignesh Vachhani

ランク: Liferay Master

投稿: 780

参加年月日: 2008/03/10

最近の投稿

Ok so i think some problem with the properties you set here only.

web.server.host=my.company
web.server.protocol=https
web.server.http.port=80

Can you please give idea for which purpose you set this properties because i am seeing some conflicting here that you used protocol https and use http port.
Przemek Krysztofiak
RE: Message board problem after setting web.server.host
2012/07/26 6:15
答え

Przemek Krysztofiak

ランク: New Member

投稿: 4

参加年月日: 2012/07/26

最近の投稿

I use web.server.http.port=80 for one reason.

When I did not use it. I could get the page https://my.company.com but when i tried to log in I was redirected to
https://my.company.com:8080/web/guest/home?p_p_id=58&p_p_lifecycle=0&p_p_state=maximized&p_p_mode=view&saveLastPath=0&_58_struts_action=%2Flogin%2Flogin
and site is unavailable.
I found solution on liferay forum and it was web.server.http.port=80.
Everything works fine excpet forum.
Manuel Hoyos
RE: Message board problem after setting web.server.host
2013/01/22 0:41
答え

Manuel Hoyos

ランク: Junior Member

投稿: 49

参加年月日: 2012/06/10

最近の投稿

Hi,

i have the same problem, when we open the portal to the world with a https connection, the forum portlet works bad.

Any idea??

Thanks
Arcane Huang
RE: Message board problem after setting web.server.host
2013/09/24 16:29
答え

Arcane Huang

ランク: Junior Member

投稿: 32

参加年月日: 2010/04/13

最近の投稿

Hi,
Go to Control Panel -> Portal Settings -> Main Configuration -> Virtual host
the value should be the same with the value of web.server.host
Then it works!