フォーラム

ホーム » Liferay Portal » English » 3. Development

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Ranen Das
Whats wrong with Liferay
2012/11/09 7:13
答え

Ranen Das

ランク: Regular Member

投稿: 137

参加年月日: 2011/04/06

最近の投稿

This is becoming a regular feature - mixing english with other languages???
添付ファイル: watsWrongWithLiferay.bmp (1,317.8k)
Florencia Gadea
RE: Whats wrong with Liferay
2012/11/09 7:27
答え

Florencia Gadea

ランク: Regular Member

投稿: 146

参加年月日: 2012/03/27

最近の投稿

Yes, it happens to me all the time...
David H Nebinger
RE: Whats wrong with Liferay
2012/11/09 7:30
答え

David H Nebinger

Community Moderator

ランク: Liferay Legend

投稿: 8378

参加年月日: 2006/09/01

最近の投稿

I don't know that there is anything wrong here...

Looks like your default locale is set so you see the surrounding content in the locale of your selection.

But forum posts, like mine for example, are done in my locale only. I'm not writing the forum post in all other languages that Liferay supports. So I think you're stuck seeing the original english post...

Other things in the portal itself can and are localized. You can localize your web content, your labels, etc. When the content supports localization, you get the localization.

But if the content does not support localization (i.e. my forum response), the content cannot be localized.

I'll typically use chrome's ability to translate pages when I get to a forum post that is in another language that I'm concerned about. Doesn't do an awesome job (it sucks at translating source code), but typically does enough that I can get the gist of what is being said...
Juan Gonzalez
RE: Whats wrong with Liferay
2012/11/09 11:48
答え

Juan Gonzalez

LIFERAY STAFF

ランク: Liferay Legend

投稿: 2140

参加年月日: 2008/10/28

最近の投稿

Happens the same to a mate in office.

I didn't see anything wrong. Probably is a browser language setting misconfiguration, and you can see now because of an upgrade in Liferay.com.
Jack Bakker
RE: Whats wrong with Liferay
2012/11/09 13:49
答え

Jack Bakker

ランク: Liferay Master

投稿: 730

参加年月日: 2010/01/03

最近の投稿

I get same thing once in a while but then clear my cache/cookies and all seems fine again

no idea why except that it seems to happen after I google then go to liferay page in other language then find myself in other language by default
Milan Kostoláni
RE: Whats wrong with Liferay
2012/11/12 0:55
答え

Milan Kostoláni

ランク: Junior Member

投稿: 92

参加年月日: 2012/07/26

最近の投稿

The thing is that when you someone posts a link to wiki/forum/blog with his personal language option and you click on it, it changes your default language in liferay to language that has that someone as default.

So basically that was you see is not problem with liferay, just your default language changed to Magyar, probably after you clicked on some link to content posted by someone with default language - Magyar. (but I think it can be classified as bug, because it should not change your default language)