構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Janne Hietala
1.2.1 Version released
2013/01/21 10:10
答え

Janne Hietala

ランク: Junior Member

投稿: 96

参加年月日: 2009/06/16

最近の投稿

Good news everybody!

Project Learn 1.2.1 has been released. It now supports Scopes, so it allows much more flexibility in your learning environment. You can configure scope for a instance, site, page or on a portlet level. This way you can create and control curriculums. You can find the source code in github.

We've received a good amount of feedback and there seems to be many users of the application. All your feedback and suggestions are highly appreciated. We've also tested with some of commercial content authoring tools. Some of them seem to produce non-standard SCORM packages. If you find a SCORM package, which does not work on Learn, please let us know, so we can take a look into it.

On the next release we will be focusing on some more configuration options for the application. Also we will be re-branding the application to be ready for upcoming Marketplace release. Stay tuned for more information emoticon

Here is direct download link for the war-package.

Here are the release notes:

Version 1.2.1 Update: 18.01.2013

Implemented Scope to all portlets
Added possibility to add manual comment and grade for essay and for whole course
Player continue playing course at the same location when user reload page
Static user roles for permissions: Student and Teacher


Br,
Janne
Janne Hietala
RE: 1.2.1 Version released
2013/01/21 22:59
答え

Janne Hietala

ランク: Junior Member

投稿: 96

参加年月日: 2009/06/16

最近の投稿

Short installation instructions:

By default Learn 1.2.1 release has PACL security turned on, which causes the issue when deploying to 6.1.1. Another issue is that the default database configuration is for PostgreSQL instead of embedded H2. If you do not have Postgre installed and credentials configured the portlets wont work out-of-the-box.

We will be doing a update for distributable and change the default configuration, but here's a quick instructions how to fix this in-case you've already tried to install it:

1. After you've deployed to 6.1.1 (no need to do this for 6.0.x or 6.1.0), edit webapps\learn-web\WEB-INF\liferay-plugin-package.properties
1.2. Change text security-manager-enabled=true -> false
1.3 Restart Liferay
2. Login to Liferay as a Admin, go to control panel and to SCORM Admin Application
2.1 Click Administering icon (wrench and star)
2.2 Select H2 and click Reinitialize DB and Save

Things should work now! Also note, that you have to create roles for Teacher and Student. These should be site roles, so you can select which users are students in a course and which are Teachers. Teachers can do custom grading to gradebook. Students can see only their own grading.

Br,
Janne
Szymon Gołębiewski
RE: 1.2.1 Version released
2013/01/22 1:24
答え

Szymon Gołębiewski

ランク: Regular Member

投稿: 247

参加年月日: 2009/06/08

最近の投稿

Good news indeed emoticon

When it will be available in Liferay Marketplace?
Juan Gonzalez
RE: 1.2.1 Version released
2013/01/22 1:45
答え

Juan Gonzalez

LIFERAY STAFF

ランク: Liferay Legend

投稿: 2297

参加年月日: 2008/10/28

最近の投稿

Wouldn't be great if this portlet uses ServiceBuilder so would be 100% compatible with all databases out the box?

Perhaps I can contribute this whenever I have some free time...
Janne Hietala
RE: 1.2.1 Version released
2013/01/22 6:15
答え

Janne Hietala

ランク: Junior Member

投稿: 96

参加年月日: 2009/06/16

最近の投稿

Szymon Gołębiewski:
Good news indeed emoticon

When it will be available in Liferay Marketplace?


Hi,

We're still working out some kinks with PACL. We hope to release it to Marketplace soon as we get it working!
Janne Hietala
RE: 1.2.1 Version released
2013/01/22 6:24
答え

Janne Hietala

ランク: Junior Member

投稿: 96

参加年月日: 2009/06/16

最近の投稿

Hi Juan,

Sounds cool emoticon Let me know, if you start planning this!
Janne Hietala
RE: 1.2.1 Version released
2013/01/22 9:33
答え

Janne Hietala

ランク: Junior Member

投稿: 96

参加年月日: 2009/06/16

最近の投稿

Just a quick update. We've now updated the 1.2.1 release configuration and also updated the distributable. Changes are the following:

-Default database is set to H2. For production environment it's recommended to use PostgreSQL
-Liferay PACL security is turned off as default. This was causing issue when deploying to Liferay 6.1.1 or newer.

Now you should be able to deploy and run it out-of-the-box!

Br,
Janne
David Thompson
RE: 1.2.1 Version released
2013/02/19 8:44
答え

David Thompson

ランク: New Member

投稿: 4

参加年月日: 2010/06/15

最近の投稿

Hi,

Is there a way to configure Learn to use MySQL as the database? That is the database I run with Liferay.
Will using MySQL as the database be a configuration option in a future release?

Thanks,

Dave
Janne Hietala
RE: 1.2.1 Version released
2013/02/25 0:50
答え

Janne Hietala

ランク: Junior Member

投稿: 96

参加年月日: 2009/06/16

最近の投稿

Hi,

This is in the roadmap, but no release date is set yet.

In future, we will provide support for MySQL as well. At the moment we are able to implement it to your customer specific project if needed.

Best regards,
Janne Hietala