構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Shriharsh Ambhore
INTEGRATING SOLR 4.1 WITH LIFERAY 6.1CE
2013/03/10 10:58
答え

Shriharsh Ambhore

ランク: New Member

投稿: 11

参加年月日: 2013/03/05

最近の投稿

Hi
Can anyone tell me the exact steps to follow to integrate Solr 4.1 with Liferay 6.1 CE ??
Jignesh Vachhani
RE: INTEGRATING SOLR 4.1 WITH LIFERAY 6.1CE
2013/03/10 22:19
答え

Jignesh Vachhani

ランク: Liferay Master

投稿: 780

参加年月日: 2008/03/10

最近の投稿

Hi Shri,

You can take a quick look on http://www.liferaysolution.com/2013/03/solr-integration-with-liferay-61.html.

Hope this will helpful to you !!!
Put your comment here if you are not clear with the steps
Juan Gonzalez
RE: INTEGRATING SOLR 4.1 WITH LIFERAY 6.1CE
2013/03/11 1:53
答え

Juan Gonzalez

LIFERAY STAFF

ランク: Liferay Legend

投稿: 1864

参加年月日: 2008/10/28

最近の投稿

Guess it isn't what he asked for.

He wanted to integrate Solr 4.1, not 1.4.1 (which is the version of that blog post).
Jignesh Vachhani
RE: INTEGRATING SOLR 4.1 WITH LIFERAY 6.1CE
2013/03/11 3:52
答え

Jignesh Vachhani

ランク: Liferay Master

投稿: 780

参加年月日: 2008/03/10

最近の投稿

Juan Gonzalez P:
Guess it isn't what he asked for.

He wanted to integrate Solr 4.1, not 1.4.1 (which is the version of that blog post).


Yes Agreed Juan that was my mistake.
Actually that was integration with 1.4.1 ...
Shriharsh Ambhore
RE: INTEGRATING SOLR 4.1 WITH LIFERAY 6.1CE
2013/03/11 7:51
答え

Shriharsh Ambhore

ランク: New Member

投稿: 11

参加年月日: 2013/03/05

最近の投稿

Hey Jignesh & Juan thanks for such quick reply ..
I followed the steps mentioned and could set up the Solr sever on tomcat ... but encountered error while configuring Solr web plugin in liferay 6.1 CE
here is the error "“collection1: org.apache.solr.common.SolrException:org.apache.solr.common.SolrException: Could not load config for solrconfig.xml”"

TIA
Jack Chung
RE: INTEGRATING SOLR 4.1 WITH LIFERAY 6.1CE
2013/03/14 16:41
答え

Jack Chung

ランク: New Member

投稿: 19

参加年月日: 2011/11/30

最近の投稿

Most of the time, solr 1.4.1 has been sufficient, but I recall that once I was able to get it working with solr 3.4.0. I have not tried it with solr 4.1, but for solr 3.4.0, I had to replace the solr-solrj and the solr-core .jar files in the WEB-INF/lib directory of the solr-web plugin with the solr 3.4.0 versions.
Hitoshi Ozawa
RE: INTEGRATING SOLR 4.1 WITH LIFERAY 6.1CE
2013/03/14 20:23
答え

Hitoshi Ozawa

ランク: Liferay Legend

投稿: 7990

参加年月日: 2010/03/23

最近の投稿

Yes, the version of Solr in the plugin has to match the Solr server version. However, I think the error of not being able to find Solr configuration file is simply because it's not in the path specified in Solr.
Emanuele Righetto
RE: INTEGRATING SOLR 4.1 WITH LIFERAY 6.1CE
2013/09/10 7:48
答え

Emanuele Righetto

ランク: New Member

投稿: 4

参加年月日: 2010/10/05

最近の投稿

The major problem with solr 4.0+ is the use of apache httpclient 4, witch is quite different from 3.x.
You must include solr 4.x (core and solr) libs, as well as httpclient-4.x, httpcore-4.x and httpmime-4.x.
You also have do rewrite some classes in order to use new classes (most of work is on BasicAuthSolrServer) and redeploy the plugin.

i've successfully deployed it with solr 4.4 and httpclient 4.2.3 version