フォーラム

ホーム » Liferay Portal » English » 3. Development

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Pawal Adhikari
Password Placeholder not working on Firefox while using <aui:form>
2013/04/12 1:09
答え

Pawal Adhikari

ランク: New Member

投稿: 18

参加年月日: 2013/03/06

最近の投稿

I have encountered a strange problem while using placeholder. Password Placeholder works just fine in chrome but in firefox it shows '*****' instead of intended plain text which i used in placeholder.

1   <aui:input placeholder="Password" name="password" showRequiredLabel="<%= false %>" type="password" autocomplete="off"/>


Strange thing is firefox do support placeholder and when used outside of <aui:form> it's working just fine. Moreover, when used in simple html form tag it's working fine.

What am i doing wrong? I just don't want to switch to simple html form as i am using aui validation.

Moreover, at first dot appears in the password field of same length as placeholder but when it is clicked the placeholder appears.
Subhash Pavuskar
RE: Password Placeholder not working on Firefox while using <aui:form>
2013/04/12 2:00
答え

Subhash Pavuskar

ランク: Regular Member

投稿: 234

参加年月日: 2012/03/12

最近の投稿

Hi Pawan ,
Which version Firefox you are using ?
Pawal Adhikari
RE: Password Placeholder not working on Firefox while using <aui:form>
2013/04/12 2:51
答え

Pawal Adhikari

ランク: New Member

投稿: 18

参加年月日: 2013/03/06

最近の投稿

18.0.1 and i am pretty sure that it is compatible, http://caniuse.com/input-placeholder . And, i just found that it's not only password placeholder issue but too of text field.
Subhash Pavuskar
RE: Password Placeholder not working on Firefox while using <aui:form>
2013/04/12 4:11
答え

Subhash Pavuskar

ランク: Regular Member

投稿: 234

参加年月日: 2012/03/12

最近の投稿

hi,
I tested your code its working fine on my Firefox browser and i am using Ver 21.0 !!
Pawal Adhikari
RE: Password Placeholder not working on Firefox while using <aui:form>
2013/04/12 18:35
答え

Pawal Adhikari

ランク: New Member

投稿: 18

参加年月日: 2013/03/06

最近の投稿

hi,
It's working just fine in firefox but issue appears when i use it inside <aui:form>.
Using outside of form or in simple html form doesn't show any problem.
Raffael Tregilgas
RE: Password Placeholder not working on Firefox while using <aui:form>
2013/04/22 7:56
答え

Raffael Tregilgas

ランク: New Member

投稿: 7

参加年月日: 2012/04/23

最近の投稿

hi
did you have any luck finding a solution for this problem? have the same thing in ff 20.0.1 and its not working
Pawal Adhikari
RE: Password Placeholder not working on Firefox while using <aui:form>
2013/05/08 2:32
答え

Pawal Adhikari

ランク: New Member

投稿: 18

参加年月日: 2013/03/06

最近の投稿

nope