フォーラム

ホーム » Liferay Portal » English » x. Miscellaneous

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Stefanie Taepke
Change existing enterprise edition environment to community edition
2013/04/24 8:22
答え

Stefanie Taepke

ランク: New Member

投稿: 2

参加年月日: 2013/04/16

最近の投稿

Hey there,

I have been searching for this for a while but haven't found anything on this topic yet:
We are considering to switch an existing Liferay EE Installation (5.2) to a Liferay CE(6.1). Is that somewhat possible, or has someone even done that yet?

The idea at this stage is to update the Liferay Installation to 6.1 first (in those steps recommended in various explanations) and then "switch to CE"

On top of that we will have to make sure, that portlets and especially the ext-environment-plugins will still be compatible.


Would be great to hear your thoughts or suggestions on doing this and discuss possible problems which come to your mind. To lead me to any links regarding this topic is highly appreciated as well!


Cheers
David H Nebinger
RE: Change existing enterprise edition environment to community edition
2013/04/24 10:24
答え

David H Nebinger

ランク: Liferay Legend

投稿: 6523

参加年月日: 2006/09/01

最近の投稿

I wouldn't go to 6.1 EE if you're going to end up on CE. EE is a newer edition than CE, so you'll have downgrading issues that are not supported.

However, upgrading to 6.1 CE (if you really call that an upgrade from an EE version emoticon) should be handled mostly from the CE edition itself.

From 5 to 6, however, many things changed. You don't have an Extension environment anymore, you have to migrate to an EXT plugin (if, in fact, you still need an EXT considering there are new hooking opportunities in 6 that did not exist in 5). All of your portlets and other plugins will probably require some rework (APIs have changed, etc).

It can seem like a daunting challenge, but if you're organized and have a solid backup/upgrade/rollback plan ready, you should be able to get through the process...
Stefanie Taepke
RE: Change existing enterprise edition environment to community edition
2013/04/25 1:34
答え

Stefanie Taepke

ランク: New Member

投稿: 2

参加年月日: 2013/04/16

最近の投稿

Thank you very much for your quick reply on that matter!

Well, I guess to migrate the former EXT-Environment-Code to the new Ext-Plugin will be the biggest challenge anyways.

Right now it seems that there are two possible approaches (to my understanding at least)
1. upgrade the existing Liferay Installation to 6.0 EE and handle the ext-Plugin-issue right away and then "switch" to the 6.1 CE
2. upgrade the existing Liferay Installation to 6.0 CE right from the start, handling the ext-Plugin-matter and hopefully upgrade easily to 6.1 CE then

The second way seems more realistic to me, though it causes a bit of tension to deal with the former ext-code and probably a few changes due to the EE to CE-switch at the same time.

Will see how we manage this, thank you so far! Would still appreciate it, if you keep me updated on your opinions and suggestions, though!