フォーラム

ホーム » Liferay Portal » English » 2. Using Liferay » General

構造的に表示 平面上に表示 ツリー上に表示
スレッド [ 前へ | 次へ ]
toggle
Amit Kumar Singh
Mail is not working with liferay
2010/12/26 6:39
答え

Amit Kumar Singh

ランク: Junior Member

投稿: 71

参加年月日: 2010/10/11

最近の投稿

I tried to setup the mail configuration from control panel but mail functionality is not working with liferay. I configured Root.xml and tried with gmail and also own server but still mail server is not working. I tried with portal.properties to set smtp configuration but still there is issue with liferay to sending mail. Let me know if any one have idea regarding this issue. thanks in advance to all liferay users.
Apoorva Prakash
RE: Mail is not working with liferay
2010/12/26 8:49
答え

Apoorva Prakash

ランク: Liferay Master

投稿: 659

参加年月日: 2010/06/15

最近の投稿

Hello Amit,
I've got email working on my project stack with SMTP settings in portal-ext.properties file... Hope you are doing some tiny mistake... But the things you are mentioning are not explaining your problem clearly... Please explain in detail, and mention code snippet if needed...

Thanks and Regards...
Amit Kumar Singh
RE: Mail is not working with liferay
2010/12/28 4:43
答え

Amit Kumar Singh

ランク: Junior Member

投稿: 71

参加年月日: 2010/10/11

最近の投稿

Hi Apoorva,

Thanks for your response. Below, i mentioned code of bunch for portal.properties & Root.xml that i configured in my liferay.

portal.properties

mail.session.mail.transport.protocol=smtp
mail.session.mail.smtp.host=smtphost
mail.session.mail.smtp.password=pass
mail.session.mail.smtp.user=user
mail.session.mail.smtp.port=25
mail.session.mail.smtp.auth=true

root.xml

<Resource
name="mail/MailSession"
auth="Container"
type="javax.mail.Session"
mail.imap.host="imap.gmail.com"
mail.imap.port="993"
mail.pop.host="pop.gmail.com"
mail.store.protocol="imap"
mail.transport.protocol="smtp"
mail.smtp.host="smtp.gmail.com"
mail.smtp.port="465"
mail.smtp.auth="true"
mail.smtp.starttls.enable="true"
mail.smtp.user=""
password=""
mail.smtp.socketFactory.class="javax.net.ssl.SSLSocketFactory"
/>

i tried both example. so please let me know where i am doing wrong.
Manish Kumar Gupta
RE: Mail is not working with liferay
2010/12/28 7:29
答え

Manish Kumar Gupta

LIFERAY STAFF

ランク: Liferay Master

投稿: 535

参加年月日: 2008/05/15

最近の投稿

Hey Amit,

When you are configuring mail using root.xml, you need to add mail.session.jndi.name=mail/MailSession in your portal-ext.properties. Have you done that?
Amit Kumar Singh
RE: Mail is not working with liferay
2010/12/28 21:24
答え

Amit Kumar Singh

ランク: Junior Member

投稿: 71

参加年月日: 2010/10/11

最近の投稿

HI Manish,

I tried to add mail.session.jndi.name=mail/MailSession in portal.properties. But still, i am not able to send mail. While testing for forget password, it's showing me that password sent successfully but user is not getting any mail. Please help me to resolve this issue.

Thanks.
Manish Kumar Gupta
RE: Mail is not working with liferay
2010/12/28 21:46
答え

Manish Kumar Gupta

LIFERAY STAFF

ランク: Liferay Master

投稿: 535

参加年月日: 2008/05/15

最近の投稿

Can you attach you portal-ext.properties? You can remove your mail password but I was other details as it is.

Also, it may be that portal is not able to detect your ext properties file. Where are you copying portal-ext.properties?
Amit Kumar Singh
RE: Mail is not working with liferay
2010/12/28 22:00
答え

Amit Kumar Singh

ランク: Junior Member

投稿: 71

参加年月日: 2010/10/11

最近の投稿

I attached portal.properties. Please have a look.
portal.properties dir = Root\Web-Inf\Classes\portal.properties
添付ファイル: portal-ext.properties (0.4k)
Manish Kumar Gupta
RE: Mail is not working with liferay
2010/12/28 21:58
答え

Manish Kumar Gupta

LIFERAY STAFF

ランク: Liferay Master

投稿: 535

参加年月日: 2008/05/15

最近の投稿

Is this the actual portal-ext.properties or you have removed values for mail.session.mail.smtp.host, mail.session.mail.smtp.user etc?
Amit Kumar Singh
RE: Mail is not working with liferay
2010/12/28 22:00
答え

Amit Kumar Singh

ランク: Junior Member

投稿: 71

参加年月日: 2010/10/11

最近の投稿

i removed smtp, user and pass.
Manish Kumar Gupta
RE: Mail is not working with liferay
2010/12/28 22:14
答え

Manish Kumar Gupta

LIFERAY STAFF

ランク: Liferay Master

投稿: 535

参加年月日: 2008/05/15

最近の投稿

My last 2 suggestions -

1. Try after removing mail resource entry from root.xml and property mail.session.jndi.name=mail/MailSession from portal-ext.properties.

2. Make sure that your portal-ext.properties is being picked by the portal. To verify this, go to control panel -> server administration -> properties -> portal properties.
Amit Kumar Singh
RE: Mail is not working with liferay
2010/12/28 22:38
答え

Amit Kumar Singh

ランク: Junior Member

投稿: 71

参加年月日: 2010/10/11

最近の投稿

i verified portal.properties. it's setting all the configuration. but still, issue not resolved.
Christopher Lui
RE: Mail is not working with liferay
2010/12/29 11:11
答え

Christopher Lui

LIFERAY STAFF

ランク: Junior Member

投稿: 38

参加年月日: 2010/03/22

最近の投稿

Hi Amit,

Have you seen this blog? http://www.liferay.com/web/craig.kaneko/blog/-/blogs/243468/maximized

It is an easy way to setup Gmail.

Thanks,
Chris
Amit Kumar Singh
RE: Mail is not working with liferay
2010/12/30 22:35
答え

Amit Kumar Singh

ランク: Junior Member

投稿: 71

参加年月日: 2010/10/11

最近の投稿

Hi Christopher,

i tried with this also but mail service is not working.
raghu batchu
RE: Mail is not working with liferay
2010/12/31 9:29
答え

raghu batchu

ランク: New Member

投稿: 9

参加年月日: 2009/08/23

最近の投稿

Hi Amith

verify your outgoing smtp server ip and outgoing port number under Control panel --> Server administrator --> mail

Thanks
Raghu
Gaurav Jain
RE: Mail is not working with liferay
2011/02/09 23:31
答え

Gaurav Jain

ランク: Regular Member

投稿: 141

参加年月日: 2011/01/31

最近の投稿

Hey Amit,

have you resolved out your problems with email?
Amit Kumar Singh
RE: Mail is not working with liferay
2011/02/10 19:14
答え

Amit Kumar Singh

ランク: Junior Member

投稿: 71

参加年月日: 2010/10/11

最近の投稿

Hi Gaurav,

I resolved my issue. Are you facing the problem????
Eldho Issac
RE: Mail is not working with liferay
2012/12/20 2:44
答え

Eldho Issac

ランク: New Member

投稿: 4

参加年月日: 2012/11/28

最近の投稿

Hi Amit
plz share how u resolved this problem.

Thanks