« Liferay IDE に戻る

m2e-liferay - early access

m2e-liferay has been released #

m2e-liferay has been releases as a part of latest IDE milestone release. http://www.liferay.com/web/gregory.amerson/blog/-/blogs/new-release-liferay-ide-2-0-milestone-1 All of the information about m2e-liferay can be found on this page.

0 添付ファイル
11057 参照数
平均 (0 投票)
平均評価は0.0星中の5です。
コメント
コメント 作成者 日時
Hi Greg, Import existing maven project worked... Tejas Kanani 2013/04/08 23:41
Thanks Tejas. Do you think you could email me... Gregory Amerson 2013/04/09 1:42
Hi Greg, I installed the Liferay IDE 2.0 EA... Gordon Augat 2013/04/15 11:47
Hi Gordon, that is not yet possible. We have... Gregory Amerson 2013/04/16 2:34
Hi, I just tried to configure a Liferay Project... F. K. 2013/04/18 4:37
Can you post any errors that you see occur? ... Gregory Amerson 2013/04/18 22:33
Can you post any errors that you see occur? ... Gregory Amerson 2013/04/18 22:33
Hi, I personnaly have 2 problems : - when I... Olivier B 2013/06/05 7:37
Hi Olivier, As it turns out Liferay IDE... Gregory Amerson 2013/06/06 2:16

Hi Greg,

Import existing maven project worked fine for me. But when I do Project(Right click) --> Maven --> Update Project, I am getting below error.

An internal error occurred during: "Updating Maven Project".
Unsupported IClasspathEntry kind=4

I don't see any negative impact of this after update completes. And also I am able to drag my maven based Liferay hook to already configured Liferay server inside Eclipse and its deployed properly. So looks like its working fine so far.

I am using Eclipse Juno SR2.

Thanks,
Tejas
投稿日時:13/04/08 23:41
Thanks Tejas. Do you think you could email me the whole stack trace that is shown in the Eclipse error log? Also, do you think you can send me your .classpath file from your project so I can see which entry it is failing on? Thanks.
Tejas Kananiへのコメント。投稿日時:13/04/09 1:42
Hi Greg,

I installed the Liferay IDE 2.0 EA release. Was curious if issue http://issues.liferay.com/browse/IDE-234 was in this release and if so, how do I tell the Liferay IDE to use my custom context?
投稿日時:13/04/15 11:47
Hi Gordon, that is not yet possible. We have it planned in the 2.0 release.
Gordon Augatへのコメント。投稿日時:13/04/16 2:34
F. K.
Hi, I just tried to configure a Liferay Project to use maven. I installed LiferayIDE 2.00EA and its dependencies, but i cant get to the update the project to use maven. I have tried to build a simple portlet and update it but even this doesnt work. what would i hacve to do to get things working?
投稿日時:13/04/18 4:37
Can you post any errors that you see occur? Also could you post a sample project? You could start a new thread on the IDE forums since I don't think you can upload here.
F. K.へのコメント。投稿日時:13/04/18 22:33
Can you post any errors that you see occur? Also could you post a sample project? You could start a new thread on the IDE forums since I don't think you can upload here.
F. K.へのコメント。投稿日時:13/04/18 22:33
Hi,

I personnaly have 2 problems :
- when I import a project created with mvn archetype:generate (liferay-web-archetype), the project is not imported as a liferay plugin. There is no facet "liferay-web" but when I try with "liferay-portlet" I have this error "Project is not located in a Liferay Plugins SDK. Please copy the project to valid SDK directory based on plugin type."
- when I add my web plugin to a Liferay 6.1 runtime, it is not correctly deployed, I have to manually run "mvn package liferay:deploy"
投稿日時:13/06/05 7:37
Hi Olivier,

As it turns out Liferay IDE doesn't support web-type plugins at all emoticon. Also we don't currently have supported web-type plugins on our roadmap. Here is the ticket you can watch:

http://issues.liferay.com/browse/IDE-479
Olivier Boudetへのコメント。投稿日時:13/06/06 2:16