Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Naveen Sharma
Liferay not accepting LDAP user password
17 de Agosto de 2011 23:50
Resposta

Naveen Sharma

Ranking: New Member

Mensagens: 2

Data de entrada: 17 de Agosto de 2011

Mensagens recentes

Hi All,

I recently installed liferay 6.0.6. I had the requirement for using LDAP authentication which I did in Portal Settings.
All went off well and users/groups were imported from LDAP server successfully.
However, they cannot login using their passwords with LDAP server. I tried using the LDAP password policy in liferay but that did not work out.

Any idea of how to make liferay talk to ldap server for password verification ?

Do I need the patch mentioned here:
http://www.liferay.com/community/forums/-/message_boards/message/10090229

Regards,
Naveen Sharma.
Ravi Kumar Gupta
RE: Liferay not accepting LDAP user password
17 de Agosto de 2011 23:56
Resposta

Ravi Kumar Gupta

Ranking: Liferay Legend

Mensagens: 1145

Data de entrada: 23 de Junho de 2009

Mensagens recentes

I did use LDAP with LR 6.0.6 some time back and it works fine. Can you please share the logs to analyze any error thats coming.

Thanks and Regards
Ravi
Naveen Sharma
RE: Liferay not accepting LDAP user password
18 de Agosto de 2011 01:25
Resposta

Naveen Sharma

Ranking: New Member

Mensagens: 2

Data de entrada: 17 de Agosto de 2011

Mensagens recentes

Dear Ravi,

> I did use LDAP with LR 6.0.6 some time back and it works fine

I can see all users imported from LDAP.
However, ldap passwords don't work. I have no clues.

Which log file to look for authentication failures. server/log doesn't show any errors.

Regards,
Naveen Sharma.
Ravi Kumar Gupta
RE: Liferay not accepting LDAP user password
18 de Agosto de 2011 02:11
Resposta

Ravi Kumar Gupta

Ranking: Liferay Legend

Mensagens: 1145

Data de entrada: 23 de Junho de 2009

Mensagens recentes

okay.. and what LDAP access logs. Which LDAP you are using.. there should be some logs folder or so..

My approach to this problem is to check whether at login time LR is using LDAP or not.. if not then there is some problem in LR settings. If yes then check proper ldap credentials.
Sreeraj AV
RE: Liferay not accepting LDAP user password
24 de Agosto de 2011 23:46
Resposta

Sreeraj AV

Ranking: Regular Member

Mensagens: 223

Data de entrada: 26 de Abril de 2010

Mensagens recentes

Naveen Sharma:
Dear Ravi,

> I did use LDAP with LR 6.0.6 some time back and it works fine

I can see all users imported from LDAP.
However, ldap passwords don't work. I have no clues.

Which log file to look for authentication failures. server/log doesn't show any errors.

Regards,
Naveen Sharma.


I think the problem is in your Authentication Search Filter filed. I've integrated Active Directory with LR 6.0.5, 6.0.6 and LR 6 EE SP2.
i gave (&(objectCategory=Person)(sAMAccountName=@screen_name@)) in my Authentication Search Filter filed. and configured authentication using screen name
Anexo

Anexo

Anexos: Screenshot_1.png (4,1k), Screenshot_2.png (19,2k)
Brian Scott Schupbach
RE: Liferay not accepting LDAP user password
5 de Outubro de 2011 14:13
Resposta

Brian Scott Schupbach

Ranking: Expert

Mensagens: 331

Data de entrada: 23 de Outubro de 2008

Mensagens recentes

Hello,

Thanks for posting those screen shots. I had an issue where users could use ANY password to authenticate into the portal. That issue has been fixed.

However, I have run into a new problem... If a user has the role of the portal Administrator (omniadmin) any password can be entered with the username and they are allowed to enter the portal.

Any suggestions? are you experiencing something similar?

Thanks in advance.

Brian
Drew Blessing
RE: Liferay not accepting LDAP user password
16 de Outubro de 2011 20:09
Resposta

Drew Blessing

Ranking: Junior Member

Mensagens: 79

Data de entrada: 27 de Janeiro de 2011

Mensagens recentes

Out of curiosity, you're not using Chrome browser are you? I haven't ever seen this in Liferay 6.0.6 except with Chrome. The browser holds into the Session objects and makes Liferay, and other apps, appear to accept invalid passwords. It's worth a shot anyway.

By the way, I can't help but notice the giant red N you have as your pic. Do you work in NE? I know this is outside the scope of this forum. I work in K12 education in NE and we're doing a huge deployment of LR. If you're interested in collaborating or just chatting about LR, send me a dm on Twitter @drewblessing.
Brian Scott Schupbach
RE: Liferay not accepting LDAP user password
17 de Outubro de 2011 09:48
Resposta

Brian Scott Schupbach

Ranking: Expert

Mensagens: 331

Data de entrada: 23 de Outubro de 2008

Mensagens recentes

Oops, I should have updated this post...

The issue has been corrected. I received a patch to get the LDAP import feature working the way I needed and somewhere in that patch it allowed users to authenticate with any password. I removed the patch and everything is working correctly now.

Yes, I do work in Nebraska! I'll send you a dm on twitter. It would be nice to see if we can collaborate on something.

Brian
Brandon Wagner
RE: Liferay not accepting LDAP user password
26 de Outubro de 2011 15:25
Resposta

Brandon Wagner

Ranking: Junior Member

Mensagens: 67

Data de entrada: 14 de Maio de 2008

Mensagens recentes

Ravi -- cheers, you helped me greatly with these screenshots. The General tab was the key, for me.
Born Telefrag
RE: Liferay not accepting LDAP user password
20 de Junho de 2013 05:34
Resposta

Born Telefrag

Ranking: New Member

Mensagens: 1

Data de entrada: 7 de Junho de 2013

Mensagens recentes

thx a lot, you saved a bunch of my time