Fóruns

Início » Liferay Portal » English » 3. Development

Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
Amirtha Mira
Upgrade liferay 6.0.6 to 6.1.0
27 de Outubro de 2011 02:49
Resposta

Amirtha Mira

Ranking: New Member

Mensagens: 10

Data de entrada: 11 de Agosto de 2011

Mensagens recentes

Hi i wan to upgrade my liferay 6.0.6 to 6.1.0. I am using tomcat with mysql database..
Manikandan S
RE: Upgrade liferay 6.0.6 to 6.1.0
27 de Outubro de 2011 03:58
Resposta

Manikandan S

Ranking: Expert

Mensagens: 492

Data de entrada: 15 de Setembro de 2010

Mensagens recentes

Hi Amirtha,

you should run this sql scripts in your database, then restart the server.

UserName : guest
Pwd : no pwd give empty space
Amirtha Mira
RE: Upgrade liferay 6.0.6 to 6.1.0
2 de Novembro de 2011 01:43
Resposta

Amirtha Mira

Ranking: New Member

Mensagens: 10

Data de entrada: 11 de Agosto de 2011

Mensagens recentes

Yes.. Sql scripts itself it's working. But after that execute all like clear the cache, Reindex etc in server administrator is must to retrieve all data from previous version.
Thanks Mani kandan--emoticon
Rumeet Tanna
RE: Upgrade liferay 6.0.6 to 6.1.0
15 de Novembro de 2011 00:59
Resposta

Rumeet Tanna

Ranking: New Member

Mensagens: 10

Data de entrada: 30 de Julho de 2011

Mensagens recentes

Hi...

I have Liferay 6.0.6 with Tomcat and SQL Server 2005 Database... Will the SQL script still apply for this Database?

If not, can you guide me in the right direction...

Thanks,

Rumeet
Jordi Buendia
RE: Upgrade liferay 6.0.6 to 6.1.0
18 de Novembro de 2011 02:16
Resposta

Jordi Buendia

Ranking: New Member

Mensagens: 4

Data de entrada: 8 de Novembro de 2011

Mensagens recentes

Hello,

I am trying to migrate from 6.0 EE SP2 to 6.1 Community Beta 4

When I run the script Mani Kandan posted, i get some trouble. I have tried to run this script both in a database with some personal data an in a clean 6.0 EE SP2 database.
The errors type i get are the same in the two cases. If I don't care and continue with the upgrade process, when I run the server an error occur an shuts down.

I attach the Mysql log I obtain when running the upgrade script on the clean liferay 6.0 EE SP2 database. If someone can guide me in what to do it would be great.

Thanks
Anexos: logMysqlUpgradeCleanDatabase.txt (16,9k)
Anis Boutouria
RE: Upgrade liferay 6.0.6 to 6.1.0
28 de Novembro de 2011 07:42
Resposta

Anis Boutouria

Ranking: New Member

Mensagens: 4

Data de entrada: 28 de Novembro de 2011

Mensagens recentes

Hi guys,
I have got the same error, Mysql Database didn't support the String type.
I tried every kind of test, did any one of you have succeded this upgrade ?.

Thinks.
Anis Boutouria
RE: Upgrade liferay 6.0.6 to 6.1.0
28 de Novembro de 2011 08:27
Resposta

Anis Boutouria

Ranking: New Member

Mensagens: 4

Data de entrada: 28 de Novembro de 2011

Mensagens recentes

Anis Boutouria:
Hi guys,
I have got the same error, Mysql Database didn't support the String type.
I tried every kind of test, did any one of you have succeded this upgrade ?.

Thinks.

After a couple of search, i found this jira issue : http://issues.liferay.com/browse/LPS-23421
There is a problem when migrating from the 5.2.3 and 6.0.6 to the 6.1.

Thinks.
Manikandan S
RE: Upgrade liferay 6.0.6 to 6.1.0
31 de Outubro de 2011 21:45
Resposta

Manikandan S

Ranking: Expert

Mensagens: 492

Data de entrada: 15 de Setembro de 2010

Mensagens recentes

Or else,

I have done the migration from 5.2.3 to 6.0.

Same thing you must follow for migrating 6.0.6 to 6.1

Here you go Migration
Hitoshi Ozawa
RE: Upgrade liferay 6.0.6 to 6.1.0
28 de Novembro de 2011 13:26
Resposta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensagens: 7952

Data de entrada: 23 de Março de 2010

Mensagens recentes

I won't recommend upgrading to 6.1 because there seems to be some api differences between 6.0.6 and 6.1 as well.
There's also the performance issue still.

Recommend to wait until the GA release to reevaluate if it is worth taking trouble to upgrade.
Amirtha Mira
RE: Upgrade liferay 6.0.6 to 6.1.0
6 de Dezembro de 2011 00:30
Resposta

Amirtha Mira

Ranking: New Member

Mensagens: 10

Data de entrada: 11 de Agosto de 2011

Mensagens recentes

yes..me too face problem in upgradation.
Hitoshi Ozawa
RE: Upgrade liferay 6.0.6 to 6.1.0
6 de Dezembro de 2011 21:04
Resposta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensagens: 7952

Data de entrada: 23 de Março de 2010

Mensagens recentes

If you find any issue that's still not reported in issues, recommend that you create one so it'll get fixed in the GA.
Jordi Buendia
RE: Upgrade liferay 6.0.6 to 6.1.0
22 de Dezembro de 2011 03:54
Resposta

Jordi Buendia

Ranking: New Member

Mensagens: 4

Data de entrada: 8 de Novembro de 2011

Mensagens recentes

Hello,

Just wanted to observe here that version 6.1 RC doesn't improve in upgrading 6.0 EE to 6.1 CE. I get errors trying two upgrade processes:
- runnig the sql script posted in the top of this thread on my database
- only pointing my 6.1 server to my 6.0 database to laung the automatic upgrade process.

I reported the bug in JIRA, but I have seen someona has been able to upgrade from 6.0 EE to 6.1 CE in this other issue

I will comment my progresses here
Vikash Pareek
RE: Upgrade liferay 6.0.6 to 6.1.0
30 de Janeiro de 2013 20:13
Resposta

Vikash Pareek

Ranking: New Member

Mensagens: 15

Data de entrada: 10 de Dezembro de 2012

Mensagens recentes

Hi,
i am using liferay 6.1.1 CE and facing problem while upgrading liferay 6.0 to 6.1.
I have done following steps for upgrading.

1.) I have follow steps described in following Wiki.
http://www.liferay.com/documentation/liferay-portal/6.1/user-guide/-/ai/upgrading-lifer-5

2.) I have try these steps 3 times but could not success.
During this process I found database of older version (i.e. Liferay 6.0) upgraded automatically during startup of new liferay 6.1 as described in above user guide.
But Tomcat Server of liferay 6.1 could not start with upgraded database of liferay 6.0.
3.) I have search and download a tool for comparing databases, and compare upgraded database and database connected with released KMS Portal.
And found difference in some tables but these differences are in only empty tables. Difference means different columns.
Then I have make both schema similar by modifying upgraded database. Now both the database has similar schema.
But it could not work and I could not found what is the problem with upgraded database.

So please tell me whether i missing any steps or doing something wrong.
Rafael Lluis
RE: Upgrade liferay 6.0.6 to 6.1.0
31 de Janeiro de 2013 05:18
Resposta

Rafael Lluis

Ranking: Junior Member

Mensagens: 29

Data de entrada: 15 de Outubro de 2012

Mensagens recentes

If tomcat is not starting I think you could see the logs and put them here in order to try helping you. I have migrated succesfully from 5.1.1 to 6.1.1 but it's not easy as its explained on the wiki. Logs and debugging the source code while upgrading are a good starting point.

have you cheked your release_ table on the upgraded database? still shows version 6.0.6 or 6.1.1 (column buildnumber)? can you see a column named state_ If its value is 2 then it is showing that there was a problem during upgrade/verify process so the portal is not going to start anymore. Then you have two options: check the upgrade logs (send them here and we'll try to take a look) or change yourself the value from 2 to 0 (database in correct state) and see if your portal starts well (of course still you'll have to investigate what error happened during the upgrade process because some of your data/tables are not conssistent, but maybe you are not ussing some liferay's functionalities, ...)
Vikash Pareek
RE: Upgrade liferay 6.0.6 to 6.1.0
31 de Janeiro de 2013 20:50
Resposta

Vikash Pareek

Ranking: New Member

Mensagens: 15

Data de entrada: 10 de Dezembro de 2012

Mensagens recentes

Thanks Rafael,
I have checked release_ table , it showing buildnumber 6006 and state_ 1.
I have changed state_ value to 0 but not changing buildnumber and then start tomcat server again but same as last time again i FAILED.

Log file created after starting tomcat server as follow :

/********************************************************************************************************************************************/

Feb 1, 2013 4:41:34 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: F:\liferay_upgraded\tomcat-7.0.27\jre1.6.0_20\win\bin;.;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Program Files (x86)\Xuggle\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\TortoiseSVN\bin;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files\MySQL\MySQL Server 5.5\bin;C:\Users\vikash.pareek\Downloads\ant\apache-ant-1.8.4\bin
Feb 1, 2013 4:41:34 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-7070"]
Feb 1, 2013 4:41:34 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
Feb 1, 2013 4:41:34 AM org.apache.coyote.AbstractProtocol init
SEVERE: Failed to initialize end point associated with ProtocolHandler ["ajp-bio-8009"]
java.net.BindException: Address already in use: JVM_Bind <null>:8009
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:393)
at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:566)
at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:417)
at org.apache.catalina.connector.Connector.initInternal(Connector.java:956)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.core.StandardService.initInternal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:814)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina.java:624)
at org.apache.catalina.startup.Catalina.load(Catalina.java:649)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:281)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:449)
Caused by: java.net.BindException: Address already in use: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:365)
at java.net.ServerSocket.bind(ServerSocket.java:319)
at java.net.ServerSocket.<init>(ServerSocket.java:185)
at java.net.ServerSocket.<init>(ServerSocket.java:141)
at org.apache.tomcat.util.net.DefaultServerSocketFactory.createSocket(DefaultServerSocketFactory.java:49)
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:380)
... 16 more
Feb 1, 2013 4:41:34 AM org.apache.catalina.core.StandardService initInternal
SEVERE: Failed to initialize connector [Connector[AJP/1.3-8009]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connector[AJP/1.3-8009]]
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:106)
at org.apache.catalina.core.StandardService.initInternal(StandardService.java:559)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:814)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
at org.apache.catalina.startup.Catalina.load(Catalina.java:624)
at org.apache.catalina.startup.Catalina.load(Catalina.java:649)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:281)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:449)
Caused by: org.apache.catalina.LifecycleException: Protocol handler initialization failed
at org.apache.catalina.connector.Connector.initInternal(Connector.java:958)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
... 12 more
Caused by: java.net.BindException: Address already in use: JVM_Bind <null>:8009
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:393)
at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:566)
at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:417)
at org.apache.catalina.connector.Connector.initInternal(Connector.java:956)
... 13 more
Caused by: java.net.BindException: Address already in use: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:365)
at java.net.ServerSocket.bind(ServerSocket.java:319)
at java.net.ServerSocket.<init>(ServerSocket.java:185)
at java.net.ServerSocket.<init>(ServerSocket.java:141)
at org.apache.tomcat.util.net.DefaultServerSocketFactory.createSocket(DefaultServerSocketFactory.java:49)
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:380)
... 16 more
Feb 1, 2013 4:41:34 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 496 ms
Feb 1, 2013 4:41:34 AM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
Feb 1, 2013 4:41:34 AM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.27
Feb 1, 2013 4:41:34 AM org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor F:\liferay_upgraded\tomcat-7.0.27\conf\Catalina\localhost\ROOT.xml
Feb 1, 2013 4:41:36 AM org.apache.catalina.startup.TaglibUriRule body
INFO: TLD skipped. URI: http://java.sun.com/portlet is already defined
Feb 1, 2013 4:41:36 AM org.apache.catalina.startup.TaglibUriRule body
INFO: TLD skipped. URI: http://alloy.liferay.com/tld/aui is already defined
Feb 1, 2013 4:41:36 AM org.apache.catalina.startup.TaglibUriRule body
INFO: TLD skipped. URI: http://alloy.liferay.com/tld/aui is already defined
Feb 1, 2013 4:41:36 AM org.apache.catalina.startup.TaglibUriRule body
INFO: TLD skipped. URI: http://liferay.com/tld/faces is already defined
Feb 1, 2013 4:41:36 AM org.apache.catalina.startup.TaglibUriRule body
INFO: TLD skipped. URI: http://java.sun.com/portlet is already defined
Feb 1, 2013 4:41:37 AM com.liferay.portal.kernel.log.Jdk14LogImpl info
INFO: Detected server tomcat
Feb 1, 2013 4:41:37 AM com.liferay.portal.kernel.log.Jdk14LogImpl info
INFO: Global shared lib directory /F:/liferay_upgraded/tomcat-7.0.27/lib/
Feb 1, 2013 4:41:37 AM com.liferay.portal.kernel.log.Jdk14LogImpl info
INFO: Global lib directory /F:/liferay_upgraded/tomcat-7.0.27/lib/ext/
Feb 1, 2013 4:41:37 AM com.liferay.portal.kernel.log.Jdk14LogImpl info
INFO: Portal lib directory /F:/liferay_upgraded/tomcat-7.0.27/webapps/ROOT/WEB-INF/lib/
Feb 1, 2013 4:41:37 AM com.liferay.portal.kernel.log.Jdk14LogImpl info
INFO: Properties for portal loaded from [file:/F:/liferay_upgraded/tomcat-7.0.27/webapps/ROOT/WEB-INF/classes/portal-ext.properties, file:/F:/liferay_upgraded/portal-setup-wizard.properties, jar:file:/F:/liferay_upgraded/tomcat-7.0.27/webapps/ROOT/WEB-INF/lib/portal-impl.jar!/portal.properties]

/********************************************************************************************************************************************/
Jitendra Rajput
RE: Upgrade liferay 6.0.6 to 6.1.0
31 de Janeiro de 2013 21:21
Resposta

Jitendra Rajput

Ranking: Liferay Master

Mensagens: 848

Data de entrada: 7 de Janeiro de 2011

Mensagens recentes

If it is upgraded to 6.1 successfully then it should show build number in release_ table w either 6110 or 6120
Jitendra Rajput
RE: Upgrade liferay 6.0.6 to 6.1.0
31 de Janeiro de 2013 21:24
Resposta

Jitendra Rajput

Ranking: Liferay Master

Mensagens: 848

Data de entrada: 7 de Janeiro de 2011

Mensagens recentes

Port you are trying is already occupied thats why you are getting 'Address Already bind message'. try with different port in server.xml
Vikash Pareek
RE: Upgrade liferay 6.0.6 to 6.1.0
31 de Janeiro de 2013 21:50
Resposta

Vikash Pareek

Ranking: New Member

Mensagens: 15

Data de entrada: 10 de Dezembro de 2012

Mensagens recentes

Hi Jitendra,
I try with different port too but result is same. Failed....
After executing tomcat startup.bat file on console a message is displayed "server is stop due to unexpected start up error" and console closed.

And you are right If it is upgraded to 6.1 successfully then it should show build number in release_ table either 6110 or 6120.
But my question is how to achieve this ?
What is going wrong here ?
Jitendra Rajput
RE: Upgrade liferay 6.0.6 to 6.1.0
31 de Janeiro de 2013 22:05
Resposta

Jitendra Rajput

Ranking: Liferay Master

Mensagens: 848

Data de entrada: 7 de Janeiro de 2011

Mensagens recentes

I dont see any upgrade logs in the above post . It all about port only . try to change start up and shut down port.