Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Wassim Kattan
Liferay setup on Centos
3 de Julho de 2012 10:00
Resposta

Wassim Kattan

Ranking: New Member

Mensagens: 1

Data de entrada: 3 de Julho de 2012

Mensagens recentes

Hi Everyone,

This is the first time I set up Liferay on a Centos machine, and I keep running into a weird problem.

This is the guide I followed: http://www.liferay.com/community/wiki/-/wiki/Main/Quick+Installation+Instructions

I have the latest Java installed , and have the liferay with tomcat bundle downloaded, copied to /usr , unzipped it there and did something very similar to this: Linux/OSX: cd /{directory}/liferay-{version}/tomcat-{version}/bin ./startup.sh }}}

here is what I get:


[root@webserver bin]# ./startup.sh
Using CATALINA_BASE: /usr/liferay-portal-6.0.6/tomcat-6.0.29
Using CATALINA_HOME: /usr/liferay-portal-6.0.6/tomcat-6.0.29
Using CATALINA_TMPDIR: /usr/liferay-portal-6.0.6/tomcat-6.0.29/temp
Using JRE_HOME: /usr
Using CLASSPATH: /usr/liferay-portal-6.0.6/tomcat-6.0.29/bin/bootstrap.jar
[root@webserver bin]#


and nothing happens afterwards... I tried to go to serveripaddress:8080 , nothing... IPtables are down, and Webmin is accessible (which means nothing wrong with network or iptables).

Any ideas on what I could be doing wrong?

Thanks
Linus Sphinx
RE: Liferay setup on Centos
3 de Julho de 2012 11:09
Resposta

Linus Sphinx

Ranking: Junior Member

Mensagens: 84

Data de entrada: 12 de Agosto de 2010

Mensagens recentes

Looks like it's starting up, execute as root;
# netstat -ant
and see if you can figure out what address the port is bound to, may only be listening on localhost.
Check the file /usr/liferay-portal-6.0.6/tomcat-6.0.29/logs/catalina.out, will usually complain loudly in there what the exact problem is.
Hitoshi Ozawa
RE: Liferay setup on Centos
3 de Julho de 2012 15:41
Resposta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensagens: 7990

Data de entrada: 23 de Março de 2010

Mensagens recentes

have the latest Java installed


This may not be the problem, but Liferay doesn't support JDK 1.7 nor OpenJDK. You'll have to use Oracle JDK 1.6

As to your question, try ps -ef to find is the process is up or not and look in tomcat log file to see if there's any error.
Chris Daly
RE: Liferay setup on Centos
16 de Maio de 2013 07:21
Resposta

Chris Daly

Ranking: New Member

Mensagens: 3

Data de entrada: 16 de Maio de 2013

Mensagens recentes

Was this issue ever resolved because I get the same error. Oracle no longer supports JDK 1.6 (according to their web-site). I have JDK 1.7 installed as well and get the exact same error.