Fóruns

Início » Liferay IDE » English

Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Joe D
Lost data on existing tables when re-deploy service builder on Liferay 6.1
16 de Novembro de 2012 13:15
Resposta

Joe D

Ranking: New Member

Mensagens: 12

Data de entrada: 19 de Abril de 2012

Mensagens recentes

Hi,

I'm using SB on Liferay 6.1. Every time I added new tables and re-deploy the service builder all data on existing tables were deleted. Does anyone know if the service builder drop the tables and re-create them? Do I need to modify the table.sql in the sql folder and remove "create" on existing tables or is there a config that I could set up?

Thanks in advantage.
Sushil Saini
RE: Lost data on existing tables when re-deploy service builder on Liferay
17 de Novembro de 2012 23:24
Resposta

Sushil Saini

Ranking: Regular Member

Mensagens: 104

Data de entrada: 27 de Julho de 2011

Mensagens recentes

Hi Joe,

SB generates the properties file service.properties in the src directory of your service. You can set the following property in this file to false so that it will not update the schema.
1
2
3build.auto.upgrade=false


And it is recommended don't modify the service.properties file directly. Create a service-ext.properties file in the src folder. And add the property build.auto.upgrade to file set it to false.

Cheers
Sushil Saini
Joe D
RE: Lost data on existing tables when re-deploy service builder on Liferay
20 de Novembro de 2012 10:49
Resposta

Joe D

Ranking: New Member

Mensagens: 12

Data de entrada: 19 de Abril de 2012

Mensagens recentes

Thanks Sushil