Fóruns

Início » Liferay IDE » English

Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Rob Silver
Theme deploying locally fine on localhost but remote application requires..
25 de Novembro de 2013 14:42
Resposta

Rob Silver

Ranking: Junior Member

Mensagens: 42

Data de entrada: 20 de Junho de 2013

Mensagens recentes

On two 6.1.1 servers Deploying locally occurs fine on a windows 7 box but on the remote unix box although the Velocity vm files are updated as well as the css files I still appear to need to clear the tomcat/work/Catalina and tomcat/temp folder after a shutdown, folder clearing , startup tomcat server

I find it odd. This is the community version in both cases so I am surprised that they behave so differently. Has anyone seen this as well and is there a better way than having to do this late at night to avoid shutting down and restarting tomcat servers. Does this also happen with Glassfish, Jboss or Weblogic servers?

Has anyone seen a difference in the new 6.2 which would make it more advantageous to use? I have not yet tried that server yet. Has anyone got any additional feedback regarding the deployment of themes in this way.
Also I had always thought the only the _diffs files are updated but when I take a closer look both files appear to be getting updated. Any Idea why that may be?
Is that normal? e.g If I update the portal_normal.vm in _diffs it also updates on the end server the templates folder directly. Why might that be and is that normal?
Anônimo
RE: Theme deploying locally fine on localhost but remote application requir
25 de Novembro de 2013 22:28
Resposta

Anônimo

Hi Rob,
Thanks for your reporting issue. Let's talk about your first odd finding first. This may be a bug for the remote server, and before I try to investigate it, let me ask you a few questions.
1, What server-manager-web plugin version are you using?
2, How do you deploy theme locally on windows? By IDE drag-n-drop deploy, by deploy from the IDE ant view or by directly deploy from the sdk command line?
3, " the Velocity vm files are updated as well as the css files", do you mean you got removed the theme from local IDE remote server, modified the files and got synchronized on the remote server or you redeployed the theme and be sychronized with remote? Does your theme after deploying really works fine on the remote?
Anônimo
RE: Theme deploying locally fine on localhost but remote application requir
26 de Novembro de 2013 00:07
Resposta

Anônimo

Hey Rob,

The sitations in your last 2 questions are normal. When you update your _diffs folder, the remote _diffs folder will also get updated through IDE remote server, and portal will merge the original folder with the folder under _diffs automatically when the _diffs folder changes has been sychronized, and you will see the merged file in the remote webapp deployed theme folder. Before you start to make remote deployment, I just want to make sure if you started remote server in dev mode or not. If not, you won't be able to update the theme. To start in dev, you can put a line include-and-override=portal-developer.properties into one of the portal-*.properties files, save it and restart the server.