Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Roman Hoyenko
Registering of deployed portlets/themes
2 de Maio de 2011 15:53
Resposta

Roman Hoyenko

Community Moderator

Ranking: Liferay Master

Mensagens: 868

Data de entrada: 8 de Outubro de 2007

Mensagens recentes

How are the portlets/themes that we deploy to portal regitered so Liferay knows about them?

It looks like when I try to deploy the theme it could be deployed, but it doesn't appear in the list of themes. The process in weblogic is 2-steps, first allow the Liferay autodeploy to do it's magic (unzip, add it's stuff, zip again), then use console to deploy the resulting file. The file shows as deployed in weblogic console, but I don't see it in the Look & Feel section. Hence the question.
Roman Hoyenko
RE: Registering of deployed portlets/themes
3 de Maio de 2011 11:51
Resposta

Roman Hoyenko

Community Moderator

Ranking: Liferay Master

Mensagens: 868

Data de entrada: 8 de Outubro de 2007

Mensagens recentes

Anyone has an idea how this works?
Joseph Wolfe
RE: Registering of deployed portlets/themes
15 de Dezembro de 2011 06:52
Resposta

Joseph Wolfe

Ranking: Regular Member

Mensagens: 103

Data de entrada: 22 de Fevereiro de 2011

Mensagens recentes

Roman Hoyenko:
Anyone has an idea how this works?



was there ever an answer to this?

I am having an issue where manually deployed themes are deploying as portlets, however, using the console correctly deploys as themes. It seems the manual script deployed themes all have portlet.xml included in the WEB-INF, which is causing the issue.

Does anyone have any insight on this?

Much obliged!
Roman Hoyenko
RE: Registering of deployed portlets/themes
6 de Fevereiro de 2012 09:57
Resposta

Roman Hoyenko

Community Moderator

Ranking: Liferay Master

Mensagens: 868

Data de entrada: 8 de Outubro de 2007

Mensagens recentes

I never got an answer on that. I just deployed the theme together with the portal, but would like to know how to do it properly, so I don't need to redeploy the portal every time I update the theme.