Fóruns

Início » Liferay Portal » English » 6. Portal Framework

Visualização combinada Visão plana Exibição em árvore
Tópicos [ Anterior | Próximo ]
toggle
Vaneet Sharma
Internet Proxy Settings
8 de Setembro de 2008 08:36
Resposta

Vaneet Sharma

Ranking: Regular Member

Mensagens: 195

Data de entrada: 25 de Julho de 2008

Mensagens recentes

Hi,

Where to change the proxy settings for connecting to Plugin Repository at http://plugins.liferay.com/community.

Thanks
Vaneet Sharma
RE: Internet Proxy Settings
12 de Setembro de 2008 09:00
Resposta

Vaneet Sharma

Ranking: Regular Member

Mensagens: 195

Data de entrada: 25 de Julho de 2008

Mensagens recentes

I tried doing changes in sytem.ext.properties file but nothing happened.
Any one.......any idea how to do this.


Thanks in advance
Frederik Weishäupl
RE: Internet Proxy Settings
24 de Outubro de 2008 03:57
Resposta

Frederik Weishäupl

Ranking: Junior Member

Mensagens: 46

Data de entrada: 7 de Janeiro de 2006

Mensagens recentes

Have you solved this issue? I've got the same problem.

Thx.

Regards
Frederik
Vaneet Sharma
RE: Internet Proxy Settings
6 de Novembro de 2008 21:40
Resposta

Vaneet Sharma

Ranking: Regular Member

Mensagens: 195

Data de entrada: 25 de Julho de 2008

Mensagens recentes

Still not able to figure out , how to connect to plugin repository
Holger Widmann
RE: Internet Proxy Settings
27 de Novembro de 2008 06:13
Resposta

Holger Widmann

Ranking: New Member

Mensagens: 4

Data de entrada: 27 de Novembro de 2008

Mensagens recentes

This helped me to get acces to the plugin repository from behind a proxy:

I've tracked down a bit of code in Liferay 5.1.0 that needs to be rewritten. In com.liferay.portal.util.HttpImpl where it says:
 1public boolean isNonProxyHost(String host) {
 2    if (_nonProxyHostsPattern [b]== null ||[/b]
 3        _nonProxyHostsPattern.matcher(host).matches()) {
 4            return true;
 5    }
 6    else {
 7        return false;
 8    }
 9}


it SHOULD say:
 1public boolean isNonProxyHost(String host) {
 2    if (_nonProxyHostsPattern [b]!= null &&[/b]
 3        _nonProxyHostsPattern.matcher(host).matches()) {
 4           return true;
 5    }
 6    else {
 7        return false;
 8    }
 9}


To avoid recompiling code, if you are behind a proxy make sure you set the system property http.nonProxyHosts to a non null value. Basically, set it to "dummy.at.nowhere" if you don't have real values to put in there. Set http.proxyPort and http.proxyHost normally.

Under SJAS/Glassfish you can easily set the system properties in Admin Console/Application Server/JVM Settings/JVM Options.

Found in this post.
David Tildesley
RE: Internet Proxy Settings
7 de Maio de 2009 19:34
Resposta

David Tildesley

Ranking: Junior Member

Mensagens: 34

Data de entrada: 3 de Agosto de 2008

Mensagens recentes

5.2.2 still has this faulty code as below. The workaround is as described to have at least one nonProxyHost specified. You should put the proxy settings in the system-ext.properties file. Even though the admin manual is not clear, you can still create a system-ext.properties file and put it in the same place as portal-ext.properties file and expect Liferay to pick it up.

1
2http.proxyHost=<your proxy host name>
3https.proxyHost=<your proxy host name>
4https.proxyPort=8080
5http.proxyPort=8080
6http.nonProxyHosts="localhost"


NB1. If your proxy server requires authentication you should put the authentication settings in the portal-ext.properties file I believe (although I have not tested this out).

NB2. This is nothing to do with reverse proxy server (where clients access liferay portal via a DMZ reverse proxy server such as Apache with mod_proxy.

NB3. This is everything to do with allowing liferay application and portlets to access an external web resource via a (forward) proxy server e.g. to allow acess to the official and community plugin repositories.

Holger Widmann:
This helped me to get acces to the plugin repository from behind a proxy:

I've tracked down a bit of code in Liferay 5.1.0 that needs to be rewritten. In com.liferay.portal.util.HttpImpl where it says:
 1public boolean isNonProxyHost(String host) {
 2    if (_nonProxyHostsPattern [b]== null ||[/b]
 3        _nonProxyHostsPattern.matcher(host).matches()) {
 4            return true;
 5    }
 6    else {
 7        return false;
 8    }
 9}


it SHOULD say:
 1public boolean isNonProxyHost(String host) {
 2    if (_nonProxyHostsPattern [b]!= null &&[/b]
 3        _nonProxyHostsPattern.matcher(host).matches()) {
 4           return true;
 5    }
 6    else {
 7        return false;
 8    }
 9}


To avoid recompiling code, if you are behind a proxy make sure you set the system property http.nonProxyHosts to a non null value. Basically, set it to "dummy.at.nowhere" if you don't have real values to put in there. Set http.proxyPort and http.proxyHost normally.

Under SJAS/Glassfish you can easily set the system properties in Admin Console/Application Server/JVM Settings/JVM Options.

Found in this post.
Kolja Köster
RE: Internet Proxy Settings
19 de Maio de 2009 02:09
Resposta

Kolja Köster

Ranking: Regular Member

Mensagens: 164

Data de entrada: 11 de Maio de 2009

Mensagens recentes

David Tildesley:
5.2.2 still has this faulty code as below. The workaround is as described to have at least one nonProxyHost specified. You should put the proxy settings in the system-ext.properties file. Even though the admin manual is not clear, you can still create a system-ext.properties file and put it in the same place as portal-ext.properties file and expect Liferay to pick it up.

Could anybode state, where to put this file? Changing catalina.properties and portal.properties did not work for me. There is no system-ext.properties in the standard bundle.

Regards
Kolja
Arnaud Deslandes
RE: Internet Proxy Settings
19 de Maio de 2009 06:28
Resposta

Arnaud Deslandes

Ranking: New Member

Mensagens: 23

Data de entrada: 25 de Junho de 2007

Mensagens recentes

You just have to create this plain text file, containing only :

http.proxyHost=xx.xx.xx.xx
https.proxyHost=xx.xx.xx.xx
http.proxyPort=xx
https.proxyPort=xx
http.nonProxyHosts="localhost"

and place it in {appserver}/webapps/ROOT/WEB-INF/classes
Kolja Köster
RE: Internet Proxy Settings
5 de Junho de 2009 05:36
Resposta

Kolja Köster

Ranking: Regular Member

Mensagens: 164

Data de entrada: 11 de Maio de 2009

Mensagens recentes

Arnaud Deslandes:
You just have to create this plain text file, containing only :

http.proxyHost=xx.xx.xx.xx
https.proxyHost=xx.xx.xx.xx
http.proxyPort=xx
https.proxyPort=xx
http.nonProxyHosts="localhost"

and place it in {appserver}/webapps/ROOT/WEB-INF/classes

I apologize for taking so long for a reply. This approach worked. Many thanks.

Regards
Kolja
Christian Merkel
RE: Internet Proxy Settings
6 de Janeiro de 2010 23:49
Resposta

Christian Merkel

Ranking: Regular Member

Mensagens: 111

Data de entrada: 14 de Dezembro de 2009

Mensagens recentes

I got the same problem!

But our Proxy needs authentication!

What lines i have to add emoticon

something like:
1http.user=admin
2http.password=password


??

Thx for the help!
William Fleming
RE: Internet Proxy Settings
7 de Março de 2011 03:56
Resposta

William Fleming

Ranking: Regular Member

Mensagens: 180

Data de entrada: 15 de Setembro de 2010

Mensagens recentes

I had issues but found that you need it entered in

catalina.properties and you portal-ext.properties

http.proxyHost=yourProxyURL
http.proxyPort=yourProxyPort
http.proxyUser=yourUserName
http.proxyPassword=yourPassword

Boom! Bask in glory on the internet in your portal.
Yan Naing Oo
RE: Internet Proxy Settings
18 de Outubro de 2011 00:29
Resposta

Yan Naing Oo

Ranking: Regular Member

Mensagens: 180

Data de entrada: 17 de Fevereiro de 2011

Mensagens recentes

William Fleming:
I had issues but found that you need it entered in

catalina.properties and you portal-ext.properties

http.proxyHost=yourProxyURL
http.proxyPort=yourProxyPort
http.proxyUser=yourUserName
http.proxyPassword=yourPassword

Boom! Bask in glory on the internet in your portal.


Hi William,

I have to ask you for following value, that i mentioned is anything wrong ? let me know if you can correct ?

http.proxyHost=yourProxyURL (by pass URL based on browser options) ?
http.proxyPort=8080 (default) ?
http.proxyUser= if no user - leave blank ?
http.proxyPassword= if no pwd - leave blank ?


Thanks
Jevon Wright
RE: Internet Proxy Settings
8 de Dezembro de 2011 13:59
Resposta

Jevon Wright

Ranking: New Member

Mensagens: 8

Data de entrada: 5 de Dezembro de 2011

Mensagens recentes

Yan Naing Oo:
http.proxyHost=yourProxyURL (by pass URL based on browser options) ?
http.proxyPort=8080 (default) ?
http.proxyUser= if no user - leave blank ?
http.proxyPassword= if no pwd - leave blank ?

Thanks


Yes, if your proxy does not have a username or password you can leave these fields blank, or (even better) not include them in your .properties file at all.