Combination View Flat View Tree View
Threads [ Previous | Next ]
Marvin Gumpoldsberger
Troubleshooting - Remote Staging
November 3, 2008 4:21 AM
Answer

Marvin Gumpoldsberger

Rank: New Member

Posts: 21

Join Date: October 29, 2008

Recent Posts

Hi all,

I want to set up my environment for remote publishing from staging machine to live, so i have two physical liferay servers configured for (remote) staging.


The staging in the same physical machine works fine, but the "publish to remote" results in:

"Could not connect to address http://<hostname or ip>:80. Please verify that the specified port is correct and that the remote server is configured to accept requests from this server."

Can somebody tell me where to configure the remote server to accept requests (the port must be correct) ?
I haven´t found sth. heplful in the community or even in the docs.



catalina says:

12:02:26,293 ERROR [GroupServiceHttp:60] com.liferay.portal.SystemException: java.io.StreamCorruptedException: invalid stream header: 3C21444F
com.liferay.portal.SystemException: java.io.StreamCorruptedException: invalid stream header: 3C21444F
at com.liferay.portal.service.http.GroupServiceHttp.getGroup(GroupServiceHttp.java:293)
at com.liferay.portlet.communities.util.StagingUtil.copyRemoteLayouts(StagingUtil.java:180)
at com.liferay.portlet.communities.util.StagingUtil._publishToRemote(StagingUtil.java:1129)
at com.liferay.portlet.communities.util.StagingUtil.publishToRemote(StagingUtil.java:596)
at com.liferay.portlet.communities.action.EditPagesAction.processAction(EditPagesAction.java:158)
at com.liferay.portal.struts.PortletRequestProcessor.process(PortletRequestProcessor.java:180)
at com.liferay.portlet.StrutsPortlet.processAction(StrutsPortlet.java:197)
at com.sun.portal.portletcontainer.appengine.filter.FilterChainImpl.doFilter(FilterChainImpl.java:93)
at com.liferay.portal.kernel.portlet.PortletFilterUtil.doFilter(PortletFilterUtil.java:57)
at com.liferay.portlet.InvokerPortletImpl.invoke(InvokerPortletImpl.java:589)
.
.
.
Caused by: java.io.StreamCorruptedException: invalid stream header: 3C21444F
at java.io.ObjectInputStream.readStreamHeader(Unknown Source)
at java.io.ObjectInputStream.<init>(Unknown Source)
at com.liferay.portal.service.http.TunnelUtil.invoke(TunnelUtil.java:69)
at com.liferay.portal.service.http.GroupServiceHttp.getGroup(GroupServiceHttp.java:282)
... 89 more

and wireshark says the remote host answers http code 302 moved temporarily....







Thanks!
Srikanth Reddy Sanivarapu
RE: Troubleshooting - Remote Staging
January 14, 2009 10:51 PM
Answer

Srikanth Reddy Sanivarapu

Rank: Regular Member

Posts: 193

Join Date: November 14, 2008

Recent Posts

Marvin Gumpoldsberger:
Hi all,

I want to set up my environment for remote publishing from staging machine to live, so i have two physical liferay servers configured for (remote) staging.


The staging in the same physical machine works fine, but the "publish to remote" results in:

"Could not connect to address http://<hostname or ip>:80. Please verify that the specified port is correct and that the remote server is configured to accept requests from this server."

Can somebody tell me where to configure the remote server to accept requests (the port must be correct) ?
I haven´t found sth. heplful in the community or even in the docs.



catalina says:

12:02:26,293 ERROR [GroupServiceHttp:60] com.liferay.portal.SystemException: java.io.StreamCorruptedException: invalid stream header: 3C21444F
com.liferay.portal.SystemException: java.io.StreamCorruptedException: invalid stream header: 3C21444F
at com.liferay.portal.service.http.GroupServiceHttp.getGroup(GroupServiceHttp.java:293)
at com.liferay.portlet.communities.util.StagingUtil.copyRemoteLayouts(StagingUtil.java:180)
at com.liferay.portlet.communities.util.StagingUtil._publishToRemote(StagingUtil.java:1129)
at com.liferay.portlet.communities.util.StagingUtil.publishToRemote(StagingUtil.java:596)
at com.liferay.portlet.communities.action.EditPagesAction.processAction(EditPagesAction.java:158)
at com.liferay.portal.struts.PortletRequestProcessor.process(PortletRequestProcessor.java:180)
at com.liferay.portlet.StrutsPortlet.processAction(StrutsPortlet.java:197)
at com.sun.portal.portletcontainer.appengine.filter.FilterChainImpl.doFilter(FilterChainImpl.java:93)
at com.liferay.portal.kernel.portlet.PortletFilterUtil.doFilter(PortletFilterUtil.java:57)
at com.liferay.portlet.InvokerPortletImpl.invoke(InvokerPortletImpl.java:589)
.
.
.
Caused by: java.io.StreamCorruptedException: invalid stream header: 3C21444F
at java.io.ObjectInputStream.readStreamHeader(Unknown Source)
at java.io.ObjectInputStream.<init>(Unknown Source)
at com.liferay.portal.service.http.TunnelUtil.invoke(TunnelUtil.java:69)
at com.liferay.portal.service.http.GroupServiceHttp.getGroup(GroupServiceHttp.java:282)
... 89 more

and wireshark says the remote host answers http code 302 moved temporarily....







Thanks!





Hi Marvin Gumpoldsberger,

did u get the solution for the above posted query by u?

Please reply me whether you got the solution or not ?

and reply me the procedure for that?

Plz...

Itz really very urgent..

Thanks in advance.,

Srikanth Reddy.S
Jonas Yuan
RE: Troubleshooting - Remote Staging
January 16, 2009 11:46 AM
Answer

Jonas Yuan

Rank: Liferay Master

Posts: 993

Join Date: April 26, 2007

Recent Posts

Hi Marvin and Srikanth,

This is just a configuration issue.

Check your configuration:

tunnel.servlet.hosts.allowed=127.0.0.1,SERVER_IP, YOUR_REMOTE_SERVER_IP
tunnel.servlet.https.required=false

make sure that you have set remote server IPs properly.

When publishing remotely, just input the YOUR_REMOTE_SERVER_IP in UI.

Good Luck!

Jonas Yuan
Rajeev K
RE: Troubleshooting - Remote Staging
March 13, 2012 11:45 PM
Answer

Rajeev K

Rank: Regular Member

Posts: 162

Join Date: June 18, 2009

Recent Posts

Jonas Yuan:
Hi Marvin and Srikanth,

This is just a configuration issue.

Check your configuration:

tunnel.servlet.hosts.allowed=127.0.0.1,SERVER_IP, YOUR_REMOTE_SERVER_IP
tunnel.servlet.https.required=false

make sure that you have set remote server IPs properly.

When publishing remotely, just input the YOUR_REMOTE_SERVER_IP in UI.

Good Luck!

Jonas Yuan


Hi Jonas,

I am getting the same error when trying to connect to a remote Live server.

These are the settings that I have done in portal-ext file of the Remote server:-

1tunnel.servlet.hosts.allowed=10.16.22.11
2tunnel.servlet.https.required=false
3
4#web.server.protocol=https
5#web.server.http.port=80
6#web.server.https.port=443


Error that I get is

1Caused by: java.io.StreamCorruptedException: invalid stream header: 3C21444F
2        at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:782)
3        at java.io.ObjectInputStream.<init>(ObjectInputStream.java:279)
4        at com.liferay.portal.service.http.TunnelUtil.invoke(TunnelUtil.java:61)
5        at com.liferay.portal.service.http.GroupServiceHttp.getGroup(GroupServiceHttp.java:216)


Kindly suggest something, what could be going wrong here.
Note: My Local server (from where I am doing the staging is https site)
Olaf Kock
RE: Troubleshooting - Remote Staging
March 14, 2012 1:34 AM
Answer

Olaf Kock

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2421

Join Date: September 23, 2008

Recent Posts

Rajeev K:
These are the settings that I have done in portal-ext file of the Remote server:-

1tunnel.servlet.hosts.allowed=10.16.22.11
2tunnel.servlet.https.required=false

...

Kindly suggest something, what could be going wrong here.
Note: My Local server (from where I am doing the staging is https site)


No guarantee - I'm always mixing these two settings (and can't try currently), but try
1    axis.servlet.hosts.allowed=10.16.22.11,127.0.0.1,SERVER_IP
2    axis.servlet.https.required=false


The https nature of the staging server should not matter, the settings you gave about the web server ports were commented and deactivated. For staging through https see this blog post
Randall Hidajat
RE: Troubleshooting - Remote Staging
March 14, 2012 6:27 AM
Answer

Randall Hidajat

LIFERAY STAFF

Rank: New Member

Posts: 15

Join Date: August 31, 2010

Recent Posts

Just to add to what Olaf has stated above, You'll want to have both the tunnel.servlet properties along with the axis.servlet property also.

a little adjustment of your property you may want to use
1tunnel.servlet.hosts.allowed=10.16.22.11,127.0.0.1,SERVER_IP