Combination View Flat View Tree View
Threads [ Previous | Next ]
Joss Sanglier
New Basic Configuration
December 23, 2011 3:59 AM
Answer

Joss Sanglier

Rank: Junior Member

Posts: 60

Join Date: July 15, 2009

Recent Posts

Wonderful idea!

Unfortunately, it doesn't quite work.

When it opens the configuration screen, two things are obviously missing:
  • Ability to not load the 7cogs sample data
  • Set a password for the new administrator


I installed on a windows 7 32bit local machine - here is what happened.

I filled in the fields for the admin and changed the database to MySQL (I had already created an empty database in MySQL)

I clicked to complete installation.

I had to wait several minutes, which it warned me (that bit is good).

Suddenly, the system changed to a page which only had the following:

"an-unexpected-system-error-occurred
java.lang.NullPointerException"

I started looking through the tomcat command window for an error, but tomcat shut down. The database had been populated.

I restarted using startup.bat

This time when it loaded it took me to the installed liferay (which seems to be working).

However, it is the 7cogs version and the user I had requested during the installation had not been created. I could only log in with Bruno.

Obviously two problems here. Firstly there is an error somewhere. Secondly, there should be an option to install the sample data at the top of the screen.

If the user chooses this option then they can choose the database type but they cant add a new admin user. (bruno will be admin as usual)

If they choose NOT to install 7cogs, then the form changes and they can set the following:
  • Portal Name:
  • Admin Screen Name
  • Admin Email
  • Admin First Name
  • Admin Last Name
  • Admin Password
  • Default domain (Could it suggest the domain based on what the installation domain is?)

(Anything else that makes sense at this stage that means the portal is ready to go?)

And below that, the database option.

At the end of this installation process, they can then login with the admin email address and username as specified and the portal is set up ready to go with no trace of "liferay" in any of the domain settings or anywhere else.

So, almost there! emoticon

Joss
David H Nebinger
RE: New Basic Configuration
December 23, 2011 5:25 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7512

Join Date: September 1, 2006

Recent Posts

This has been the standard for many releases.

Every installation reference I've ever seen has said:

* remove the 7cogs before starting the first time.
* edit database parms in the portal-ext.properties file.
* start liferay, log in as test@liferay.com (the administrator), create your own account and disable test.

Sounds like there's nothing new or different in the process, except for the exception that was unfortunately lost.
Joss Sanglier
RE: New Basic Configuration
December 23, 2011 5:56 AM
Answer

Joss Sanglier

Rank: Junior Member

Posts: 60

Join Date: July 15, 2009

Recent Posts

There is a new configuration page that now opens automatically when you first start liferay - that has not been on any previous release.

It tells you to enter the admin details you wish (though it does not allow you to enter a password) - except it throws an exception and does not save the details since the 7cogs overrides it, I suppose.
Jorge Ferrer
RE: New Basic Configuration
December 24, 2011 5:47 AM
Answer

Jorge Ferrer

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2762

Join Date: August 31, 2006

Recent Posts

Hi Joss,

Thanks for the report. It seems there are conflicts between the Setup Wizard (that's the official name) and the latest 7cogs.

Have you created a ticket in JIRA with this informaiton yet? If not, could you create it and post the link here?
Joss Sanglier
RE: New Basic Configuration
December 24, 2011 2:26 PM
Answer

Joss Sanglier

Rank: Junior Member

Posts: 60

Join Date: July 15, 2009

Recent Posts

Hi Jorge!

Issue filed (despite being christmas eve and enjoying some fine vintage port - a nice side of being in my second half century)

http://issues.liferay.com/browse/LPS-24400


Joss


Happy Christmas to all Bug-Squaddies!
Hitoshi Ozawa
RE: New Basic Configuration
December 25, 2011 8:01 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

Seems there's much more to this bug. If I select Japanese as a language and click on "Language", the language changes, but when the "New Password" page
shows up, it's in English. Pages after that are all in English even though the generated properties file sets the company.default.locale=ja_JP

Happy Holidays everyone!
Jorge Ferrer
RE: New Basic Configuration
December 27, 2011 1:21 AM
Answer

Jorge Ferrer

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2762

Join Date: August 31, 2006

Recent Posts

Hi Hitoshi,

Thanks for letting us know. That looks like another bug of the setup wizard although probably not related to the original one mentioned in this thread. Can you create an LPS ticket and post it here?