Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
biswajit sarkar
Liferay new Instance problem
May 24, 2012 1:34 AM
Answer

biswajit sarkar

Rank: Regular Member

Posts: 166

Join Date: October 17, 2011

Recent Posts

I create a new instance called "www.example.com" in my liferay 6.0.6 and cofigure the host file of my linux system.

this instance automatically generate a user "test@example.com" and I successfully logged in with this user and my instance worked.

but when i go for ldap settings in portal settings. i just put all the information of my ldap which need to import and export user from ldap.
I also test the connection that work perfect. and save the ldap settings.

after I logout from the test@example.com, again I try to login with the same user and its not working. I can't login with that user.


anyone aware of this problem???
biswajit sarkar
RE: Liferay new Instance problem
May 24, 2012 3:39 AM
Answer

biswajit sarkar

Rank: Regular Member

Posts: 166

Join Date: October 17, 2011

Recent Posts

plz reply
Amit Doshi
RE: Liferay new Instance problem
May 24, 2012 3:44 AM
Answer

Amit Doshi

Rank: Liferay Master

Posts: 547

Join Date: December 29, 2010

Recent Posts

I faced same problem, are you trying to authenticate with LDAP or with liferay. Are you getting any background errors.

And also check that users are active from DB in the users_ table.
Hitoshi Ozawa
RE: Liferay new Instance problem
May 27, 2012 6:19 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7952

Join Date: March 23, 2010

Recent Posts

You should be able to login as omniadministrator independent of LDAP.
Andras Aszodi
RE: Liferay new Instance problem
November 29, 2012 2:09 AM
Answer

Andras Aszodi

Rank: New Member

Posts: 10

Join Date: October 17, 2012

Recent Posts

Hitoshi Ozawa:
You should be able to login as omniadministrator independent of LDAP.


In theory, yes.

However, it did not work for me yesterday with 6.1.0 CE and OpenLDAP. LDAP is enabled but _NOT_ required, there is an omniadmin, his user ID is listed in $TOMCAT/webapps/ROOT/WEB-INF/classes/portal-ext.properties as "omniadmin.users=XXXXX" where XXXXX is his user ID. The LDAP server happened to be unreachable, and no login was possible! Which is doubly surprising. First, I thought if LDAP is NOT required, then all users should be able to log in if LDAP is not running (and that's why you should require LDAP in productive setups). Second, I thought at least omniadmins should be able to log in if the LDAP is down.

For what it is worth, LDAP import and export are both enabled and the omniadmin's entry was also exported to the LDAP before.

I have no idea what went wrong but this is pretty reproducible... :-( I would like to have an expert opinion before I file a bug report though.
Many thanks for any hints and help. AA
Andras Aszodi
RE: Liferay new Instance problem
December 4, 2012 7:42 AM
Answer

Andras Aszodi

Rank: New Member

Posts: 10

Join Date: October 17, 2012

Recent Posts

Andras Aszodi:
Hitoshi Ozawa:
You should be able to login as omniadministrator independent of LDAP.


In theory, yes.

However, it did not work for me yesterday with 6.1.0 CE and OpenLDAP. LDAP is enabled but _NOT_ required, there is an omniadmin, his user ID is listed in $TOMCAT/webapps/ROOT/WEB-INF/classes/portal-ext.properties as "omniadmin.users=XXXXX" where XXXXX is his user ID. The LDAP server happened to be unreachable, and no login was possible! ...


Update: I upgraded to 6.1.1 CE GA2, and I can now login if LDAP is not running. No idea what the problem was with my 6.1.0 installation... but the upgrade fixed it.