Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
Samita Bhujbal
response.sendRedirect not working properly
August 27, 2012 4:02 AM
Answer

Samita Bhujbal

Rank: Regular Member

Posts: 120

Join Date: July 5, 2011

Recent Posts

HI ,
I am using liferay 6.0.6. I have developed on custom portlet where I am redirecting from one page to another portlet using response.sendRedirect() mathod .
It was working on local server.But when I tries it on UAT site it is not redirecting to required page. it remains on same page with error message.Previously this was working properly.
Pls reply.
jaid shaik
RE: response.sendRedirect not working properly
August 27, 2012 4:09 AM
Answer

jaid shaik

Rank: Regular Member

Posts: 170

Join Date: October 7, 2010

Recent Posts

Hi samita,


For jsp page
actionResponse.setRenderParameter("jspPage","/html/check/Result.jsp");

For particular page in Liferay Portal
actionResponse.sendRedirect("/web/guest/Result");


check the above...and check the URLs like staging and live server URL's....................
Samita Bhujbal
RE: response.sendRedirect not working properly
August 27, 2012 4:10 AM
Answer

Samita Bhujbal

Rank: Regular Member

Posts: 120

Join Date: July 5, 2011

Recent Posts

Thanks for reply Jaid.
Subhash Pavuskar
RE: response.sendRedirect not working properly
August 27, 2012 4:15 AM
Answer

Subhash Pavuskar

Rank: Regular Member

Posts: 234

Join Date: March 12, 2012

Recent Posts

Hi ,

Can you Paste your Error message which you getting on your console !! So it may help to resolve your problem .