Combination View Flat View Tree View
Threads [ Previous | Next ]
gerald hemmers
[resolved] error in administration portlet
November 6, 2012 12:25 PM
Answer

gerald hemmers

Rank: Junior Member

Posts: 92

Join Date: May 13, 2008

Recent Posts

Hi all,

i have this strange error and i think it is a configuration error.

I'm running on the latest liferay 6.1 ce version.
when i go to to control panel and try to see the server administration portlet, portal instance option and the update manager portlet are not showing. Everything else is working correctly.
when i click on the administration porlet options in the control panel i get the error that the view.jsp is not found.

I'm running on ubuntu 12.04 with a apache in front and my portal is configured with a sub domain.
Ubuntu is updated to the latets version.

It is probably a configuration error but i have no clue where to look ... ANy one has an idea?
Thanks a lot.

greets, gerald
Hitoshi Ozawa
RE: error in administration portlet
September 22, 2012 7:58 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

Did you set the following properties? You have to add server's ip address to redirect.url.ips.allowed or choose to use domain instead of ip

redirect.url.security.mode=domain
#redirect.url.security.mode=ip


##
## Redirect
##

#
# Set this property to "ip" or "domain" for the redirect security method. If
# set to "domain", the portal will only redirect users to domains listed in
# the property "redirect.url.domain.allowed". If set to "ip", the portal
# will only redirect to domains whose IP address resolve to an IP address
# listed in the property "redirect.url.ip.allowed".
#
#redirect.url.security.mode=domain
redirect.url.security.mode=ip

#
# Input a list of comma delimited domains which the portal is allowed to
# redirect to. Input a blank list to allow any domain.
#
redirect.url.domains.allowed=

#
# Input a list of comma delimited IPs which the portal is allowed to
# redirect to. Input a blank list to allow any IP. SERVER_IP will be
# replaced with the IP of the host server.
#
redirect.url.ips.allowed=127.0.0.1,SERVER_IP
gerald hemmers
RE: error in administration portlet
September 23, 2012 1:58 AM
Answer

gerald hemmers

Rank: Junior Member

Posts: 92

Join Date: May 13, 2008

Recent Posts

Thnx Hitoshi,

I tried to insert the url setting in portal-ext, but without any luck. Same for the ip setting.
The exact error message is:

08:57:17,285 ERROR [ajp-bio-8009-exec-5][IncludeTag:253] Current URL /group/control_panel/manage?p_p_id=137&p_p_lifecycle=0&p_p_state=maximized&p_p_mode=view&doAsGroupId=10180&refererPlid=10665 generates exception: /html/portlet/admin/view.jsp (line: 17, column: 1) File "/html/portlet/admin/view.portal.jsp" not found
08:57:17,288 ERROR [ajp-bio-8009-exec-5][IncludeTag:154] org.apache.jasper.JasperException: /html/portlet/admin/view.jsp (line: 17, column: 1) File "/html/portlet/admin/view.portal.jsp" not found
at org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:42)
at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:408)
at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:133)
at org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:322)
at org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:357)
at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:467)
at org.apache.jasper.compiler.Parser.parseFileDirectives(Parser.java:1779)
at org.apache.jasper.compiler.Parser.parse(Parser.java:135)
at org.apache.jasper.compiler.ParserController.doParse(ParserController.java:242)
at org.apache.jasper.compiler.ParserController.parseDirectives(ParserController.java:119)
at org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:193)
at org.apache.jasper.compiler.Compiler.compile(Compiler.java:373)
at org.apache.jasper.compiler.Compiler.compile(Compiler.java:353)
at org.apache.jasper.compiler.Compiler.compile(Compiler.java:340)
at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:646)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:357)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:305)

All other portlets and the portal is working fine.
Juan Gonzalez
RE: error in administration portlet
September 23, 2012 2:45 AM
Answer

Juan Gonzalez

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1984

Join Date: October 28, 2008

Recent Posts

Did you installed Liferay in an encrypted user folder?

Can you search for that jsp to see if it exists and where?
gerald hemmers
RE: error in administration portlet
September 23, 2012 5:00 AM
Answer

gerald hemmers

Rank: Junior Member

Posts: 92

Join Date: May 13, 2008

Recent Posts

Juan Gonzalez P:
Did you installed Liferay in an encrypted user folder?

Can you search for that jsp to see if it exists and where?


Thnx for the tip,
the file isn't in the srv/liferay6x/tomcat-7.0.27/webapps/ROOT/html/portlet/admin/view.jsp

can i just copy the file to that location?

I still have no clue why the fyle isn't there i just used the normal bundle to do a clean install.
gerald hemmers
RE: error in administration portlet
September 23, 2012 5:13 AM
Answer

gerald hemmers

Rank: Junior Member

Posts: 92

Join Date: May 13, 2008

Recent Posts

Thanx Juan,

The problem was indeed the missing file... I copied over there and it is working fin again !

I still have no clue what went wrong and why the file was missing if i ever found out i will post it here.

Thanks to all of you!
Arcane Huang
RE: [resolved] error in administration portlet
November 2, 2012 12:55 AM
Answer

Arcane Huang

Rank: Junior Member

Posts: 32

Join Date: April 13, 2010

Recent Posts

We found there indeed is this issue.
You can replace these .jsp files for folder '\html\portlet\admin\' from the original package.
gerald hemmers
RE: [resolved] error in administration portlet
November 12, 2012 1:14 PM
Answer

gerald hemmers

Rank: Junior Member

Posts: 92

Join Date: May 13, 2008

Recent Posts

The thing is a week ago this happened again.

We are changing and upgrading prtolets a lot so i can;t pin-point where it is happening. Is it a liferay bug or a custom build portletbug ... i have no clue.

But if anyone knows why this is happening please let me know.

Just copying file works like a charm and now everything is running again without any problems for some time.