Forums

Home » Liferay Portal » English » 2. Using Liferay » General

Combination View Flat View Tree View
Threads [ Previous | Next ]
Pete Helgren
Weird behavior of pages and LifeRay in General
September 25, 2012 5:40 PM
Answer

Pete Helgren

Rank: Regular Member

Posts: 126

Join Date: April 7, 2011

Recent Posts

We are having VERY strange behavior in our LifeRay Installation. I have already posted about our users logging in and then being given the identity of another user. We are also seeing these other random behaviors:

1) HTML and Javascript being presented as text to the end user.
2) Screens of "garbage" where a page displays what looks to be binary data.
3) Clicking on a link or a button and having a resource begin to download (we have multiple portlets that allow users to download PDF's and MP3 files as well as upload them to the site). Sometimes the portlet begins to download a page instead of displaying it. Sometimes a user sees an MP3 begin to download, even though they clicked on a link to go to another page.

In short, things are acting very peculiar. We have introduced very few changes over the past 3 months and the frequency of these problems seems to be increasing as the number of users grow.

I suspect a caching issue but I can't tell for sure. It is almost as though sessions are being shared between portlets and the data from one session is leaking into another or a previous abandoned session's data is getting intermixed with the current session. I don't know exactly, but LifeRay seems to be serving random content and we have spent a couple of weeks trying to get to the bottom of it to no avail.

Can anybody help us sort this out quickly? We are running LR 6.0.6 CE with Glassfish

Thanks,

Pete
Mika Koivisto
RE: Weird behavior of pages and LifeRay in General
September 26, 2012 3:14 PM
Answer

Mika Koivisto

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1501

Join Date: August 7, 2006

Recent Posts

Sounds like you have edge caching component in your infrastructure that is caching things a bit too aggressively. Are you perhaps running apache with mod_cache enabled or squid or some other caching component in front of your Liferay server?
Pete Helgren
RE: Weird behavior of pages and LifeRay in General
October 22, 2012 7:19 AM
Answer

Pete Helgren

Rank: Regular Member

Posts: 126

Join Date: April 7, 2011

Recent Posts

Sorry for the late reply Mike (our whole Liferay site has become so unstable and unpredictable that it has been consuming all of our time....)

The mod_cache shared library was disabled in our Apache instance and it made no difference. We have no other proxy in front of Glassfish.

Thanks!
Pete Helgren
RE: Weird behavior of pages and LifeRay in General
October 23, 2012 2:08 PM
Answer

Pete Helgren

Rank: Regular Member

Posts: 126

Join Date: April 7, 2011

Recent Posts

Another clue perhaps.... We took a look at the download "snippets" we get when we click on on a link with a hex editor. Each snippet has exactly 16,384 unrecognizable bytes of data before the http response header. EXACTLY 16k. So I am wondering what delivers a 16k payload. A cache setting maybe ?

Still stumped and getting help from no one on this.....

Pete