Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
George Stafford
Test driving EE 6.1 with Oracle - Unable to connect
October 3, 2012 8:33 AM
Answer

George Stafford

Rank: Junior Member

Posts: 62

Join Date: October 1, 2012

Recent Posts

Hi Folks,

I'm trying to get the EE version working with Oracle. I've adjusted my portal-ext.properties to the following per several things I've read:

verClassName=oracle.jdbc.OracleDriver
jdbc.default.url=jdbc:oracle:thin:@//XXX:1521/XXXX
jdbc.default.username=XXXX
jdbc.default.password=XXXX
hibernate.dialect=org.hibernate.dialect.Oracle10gDialect

Now I'm using the slash at the end of the thin URL because it's a service context instead of an ID. I don't have access to the ID.

I've placed my ojdbc6.jar in the tomcat lib.

When I try to start up liferay, I get the following error:

14:36:14,706 WARN [com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread-#5][BasicResourcePool:1841] com.mchange.v2.resourcepool.BasicResourcePool$AcquireTask@61df092e -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (3). Last acquisition attempt exception:
java.sql.SQLException: No suitable driver.


I'm not sure what I have done incorrectly and would appreciate any help. I've tried both with the CE and EE versions. I confirmed through a small servlet that I can talk to and pull information from the Oracle server with Tomcat on this machine as well.

Additionally, even with these settings in the portal-ext.properties the Hypersonic database still begins it's start up so I'm not sure if that's related or not?

Thanks,
George
David H Nebinger
RE: Test driving EE 6.1 with Oracle - Unable to connect
October 3, 2012 9:25 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 6439

Join Date: September 1, 2006

Recent Posts

Put the driver jar into tomcat's lib/ext directory and try again.
George Stafford
RE: Test driving EE 6.1 with Oracle - Unable to connect
October 3, 2012 9:42 AM
Answer

George Stafford

Rank: Junior Member

Posts: 62

Join Date: October 1, 2012

Recent Posts

Placed it there and restarted tomcat. Still have the same problem.
David H Nebinger
RE: Test driving EE 6.1 with Oracle - Unable to connect
October 3, 2012 10:19 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 6439

Join Date: September 1, 2006

Recent Posts

I'm assuming this is a cut-n-paste error:

George Stafford:
verClassName=oracle.jdbc.OracleDriver
George Stafford
RE: Test driving EE 6.1 with Oracle - Unable to connect
October 3, 2012 11:40 AM
Answer

George Stafford

Rank: Junior Member

Posts: 62

Join Date: October 1, 2012

Recent Posts

Nope, somehow that was my actual text. After changing to

jdbc.default.driverClassName=oracle.jdbc.OracleDriver

things are now connecting. On to fix the other problems!

Thank you!
George