Combination View Flat View Tree View
Threads [ Previous | Next ]
Mudasar Kalwar
Upgrading Liferay from 6.0.6 to 6.1.0 lost the portlets from pages
November 6, 2012 11:13 PM
Answer

Mudasar Kalwar

Rank: New Member

Posts: 23

Join Date: September 13, 2012

Recent Posts

Hi All,

I upgrade from liferay 5.2.3 to 6.0.6 , it was successfully done without any error left; but when I upgrade from 6.0.6 to 6.1.0 GA1 portlets are removed from the pages as they were on pages in liferay 5.2.3 and in 6.0.6, I am asking for the liferay portlets lie web content display etc.

Anyone has any idea?

Thanks
Mudasar Kalwar
RE: Upgrading Liferay from 6.0.6 to 6.1.0 lost the portlets from pages
November 7, 2012 11:39 PM
Answer

Mudasar Kalwar

Rank: New Member

Posts: 23

Join Date: September 13, 2012

Recent Posts

I have checked the port-lets they are deployed for the page, i.e I get plid (page Layout id) for main page from the layout table and checked the port-lets against that plid in portletpreferences table there are entries after that verified by adding another port-let and comparing the old port-let entries and new one, there is no difference.
What's going wrong any one has any idea ?
Oliver Bayer
RE: Upgrading Liferay from 6.0.6 to 6.1.0 lost the portlets from pages
November 8, 2012 1:22 AM
Answer

Oliver Bayer

Rank: Liferay Master

Posts: 875

Join Date: February 18, 2009

Recent Posts

Hi Mudasar,

the setting which portlet is placed on which page and on which layout-column is stored in the "layout_" table in the "typesettings" column.

HTH Oli
Mudasar Kalwar
RE: Upgrading Liferay from 6.0.6 to 6.1.0 lost the portlets from pages
November 8, 2012 2:04 AM
Answer

Mudasar Kalwar

Rank: New Member

Posts: 23

Join Date: September 13, 2012

Recent Posts

Thanks Oliver,

I figured out the layouts were missingemoticon Thank you so much for the hint.

Thanks