Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Brian Scott Schupbach
IIS 7 session and internet explorer error - user login
December 10, 2012 10:14 AM
Answer

Brian Scott Schupbach

Rank: Expert

Posts: 331

Join Date: October 23, 2008

Recent Posts

I am using IIS 7 as the webserver in front of Liferay in tomcat. When a user logs into the portal and other users are also logged in, the portal shows that you are authenticated as another person at random. So, when I type in my credentials and login, it shows someone else's face in the top gray bar. It shows content/permissions of the person who is in the top gray bar (not myself). Also, when I start internet explorer it sometimes doesn't take me to the login page. It takes me to private pages that should be forcing me to authenticate before viewing. When I click on a link it then forces me to the login page. This only occurs in internet explorer.

This is a pretty big issue.. any ideas or suggestions or where to even start?
Brian Scott Schupbach
RE: IIS 7 session and internet explorer error - user login
December 10, 2012 10:27 AM
Answer

Brian Scott Schupbach

Rank: Expert

Posts: 331

Join Date: October 23, 2008

Recent Posts

The Liferay version is 6.1 GA2
Brian Scott Schupbach
RE: IIS 7 session and internet explorer error - user login
December 11, 2012 12:03 PM
Answer

Brian Scott Schupbach

Rank: Expert

Posts: 331

Join Date: October 23, 2008

Recent Posts

I think I might have corrected this. The problem was that IIS was caching requests. So, IIS displayed a cached version of the page from when she was logged in previously. I have disabled caching in IIS and I believe it corrected the issue.