Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Lucas A Blancher
Liferay Faces - RichFaces CSS Load Problem
January 15, 2013 7:24 PM
Answer

Lucas A Blancher

Rank: Junior Member

Posts: 32

Join Date: June 4, 2008

Recent Posts

Hi All,

I'm hoping someone can point me in the right direction to troubleshoot my issue. I have created a portlet that combines Liferay 6.0.6CE, Liferay Faces 3.0.1-ga2 and Richfaces 4.2.2Final. When I open the portlet, sometimes the CSS gets loaded and some time it does not. Most the the time, when I do a Shift + Reload the CSS will be loaded in the page, but sometimes it is not. Also, often when a normal reload is performed, the CSS is not loaded. Also, generally the first time visiting a page does not load the CSS. When using firebug, there are significantly more CSS files loaded when the styling is displayed, compared to when it is not(when styling is not applied, at least 1 CSS file is still loaded).

I'm not sure how to troubleshoot this issue as it is very erratic and does not seam to follow any pattern as to when the CSS is loaded. If anyone has any idea's as to what i can try to fix the problem, or try to continue troubleshooting it would be appreciated.

Regards,
Lucas
Lucas A Blancher
RE: Liferay Faces - RichFaces CSS Load Problem
January 17, 2013 12:44 PM
Answer

Lucas A Blancher

Rank: Junior Member

Posts: 32

Join Date: June 4, 2008

Recent Posts

I have attached two screen shots of the demo Richfaces application for download in from the Liferay Faces site. The Good.png file shows when everything is ok, in this case when the page is first loaded. Then if I press reload, After Realod.png is what I get. All browsers(IE, Firefox,Chrome) show the same results.

Regards,
Lucas
Attachment

Attachment

Attachments: After Reload.png (59.5k), Good.png (85.1k)
Neil Griffin
RE: Liferay Faces - RichFaces CSS Load Problem
January 18, 2013 7:45 AM
Answer

Neil Griffin

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2223

Join Date: July 26, 2005

Recent Posts

Are you running Tomcat or perhaps an app server like JBoss AS or GlassFish? One thing I would recommend is that you use "View->Developer->Developer Tools" in Chrome and then click on the "Network" tab to see if you are getting HTTP error codes for the missing resources.
Lucas A Blancher
RE: Liferay Faces - RichFaces CSS Load Problem
January 18, 2013 8:08 AM
Answer

Lucas A Blancher

Rank: Junior Member

Posts: 32

Join Date: June 4, 2008

Recent Posts

Hi Neil,
I'm running in Jboss 4.2.3, with upgraded jsf libraries(2.1.8). There are no error codes, but when the resources fail there are a lot of 304 status codes. This problem also appears in the IceFaces and PrimeFaces demo's as well.

Lucas
Neil Griffin
RE: Liferay Faces - RichFaces CSS Load Problem
January 18, 2013 8:41 AM
Answer

Neil Griffin

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2223

Join Date: July 26, 2005

Recent Posts

Could you try it with JBoss 5.1? I think that's the version that 6.0.6 CE is bundled with:
http://sourceforge.net/projects/lportal/files/Liferay%20Portal/6.0.6/
Lucas A Blancher
RE: Liferay Faces - RichFaces CSS Load Problem
January 18, 2013 8:43 AM
Answer

Lucas A Blancher

Rank: Junior Member

Posts: 32

Join Date: June 4, 2008

Recent Posts

Hi Neil,
Upgrading the Jboss stack would take a large amount of effort(not impossible, but...). Any idea's on what might be up? Could it be a difference in Tomcat versions, compatibility, etc... I'm just not sure where to continue my troubleshooting, any suggestions on things to check would be appreciated.

Regards,
Lucas
Neil Griffin
RE: Liferay Faces - RichFaces CSS Load Problem
January 18, 2013 8:49 AM
Answer

Neil Griffin

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2223

Join Date: July 26, 2005

Recent Posts

Hi Lucas,

I'm just suggesting that you try a test with the Liferay 6.0.6 CE + JBoss 5.1 bundle. Also I would recommend a test with the Liferay 6.0.6 + Tomcat 6 bundle.

If the problem happens in those newer versions that we can look more deeply into the issue. JBoss 4.2.x is not supported in any of our Liferay Faces test configurations here at Liferay.

Thanks,

Neil