Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Joshua Humphrey
Getting 504 Gateway Timeout
February 5, 2013 12:29 PM
Answer

Joshua Humphrey

Rank: New Member

Posts: 2

Join Date: November 5, 2012

Recent Posts

When users try to log into our liferay portal, they are given an error "504 Gateway Time-out The server didn't respond in time"
In the logs, I am seeing the following which keeps repeating for hundreds of lines.
Exception in thread "http-bio-80-exec-7" java.lang.StackOverflowError
at java.util.regex.Pattern$Branch.match(Pattern.java:4131)
at java.util.regex.Pattern$GroupHead.match(Pattern.java:4185)
at java.util.regex.Pattern$Loop.match(Pattern.java:4312)
at java.util.regex.Pattern$GroupTail.match(Pattern.java:4244)


I do have 2 other Liferay portals that are working fine. Could this be as simple as copying a known good config file over to problematic server or is this problem something larger?
Hitoshi Ozawa
RE: Getting 504 Gateway Timeout
February 5, 2013 7:54 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

There should be a "caused by" line further down the list.

I had this error in my jboss when version of jboss mismatched the liferay version default setup.

Check if your OS and application server's versions are the same as the working copy.
Joshua Humphrey
RE: Getting 504 Gateway Timeout
February 6, 2013 5:32 AM
Answer

Joshua Humphrey

Rank: New Member

Posts: 2

Join Date: November 5, 2012

Recent Posts

Thanks for the information but we are using Tomcat 7.
I forgot to mention this in my original message but our version is "Liferay Portal Community Edition 6.1.1 CE GA2 (Paton / Build 6101 / July 31, 2012)" using Tomcat 7.

The errors that I'm receiving never give a "caused by" line. It only repeats the above error until the end user gets the 504 error.
Alex Galkin
RE: Getting 504 Gateway Timeout
December 16, 2013 11:56 AM
Answer

Alex Galkin

Rank: New Member

Posts: 9

Join Date: November 29, 2012

Recent Posts

Joshua Humphrey:
Thanks for the information but we are using Tomcat 7.
I forgot to mention this in my original message but our version is "Liferay Portal Community Edition 6.1.1 CE GA2 (Paton / Build 6101 / July 31, 2012)" using Tomcat 7.

The errors that I'm receiving never give a "caused by" line. It only repeats the above error until the end user gets the 504 error.


Have exactly the same issue right now (using the same Liferay version). Are there any updates? workaround? thoughts?