Forums

Home » Liferay Portal » English » 2. Using Liferay » General

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Ram A
{Resolved] Disable sending a mail notification when web content is created
March 4, 2013 6:18 AM
Answer

Ram A

Rank: Junior Member

Posts: 76

Join Date: January 16, 2013

Recent Posts

Hi,

I am new to Liferay.
I am using Liferay 6.0.6.

I am getting the below error when i added/updated the web content.

[MailEngine:244] From: Liferay Portal Workflow Notifications <no-reply@liferay.com>
10:49:26,023 DEBUG [MailEngine:245] To: [test test <test@mail.sample.domain.com>, Soni <soni@mail.sample.domain.com>, Koen<koen@mail.sample.domain.com>, Vanden<Vanden@mail.sample.domain.com>, Ram<Ram@mail.sample.domain.com>]
10:49:26,023 DEBUG [MailEngine:246] CC: null
10:49:26,024 DEBUG [MailEngine:247] BCC: null
10:49:26,024 DEBUG [MailEngine:248] List Addresses: null
10:49:26,024 DEBUG [MailEngine:249] Subject:
10:49:26,024 DEBUG [MailEngine:250] Body: You have a new submission waiting for your review in the workflow.
10:49:26,024 DEBUG [MailEngine:251] HTML Format: true
10:49:26,024 DEBUG [MailEngine:252] Reply to: null
10:49:26,024 DEBUG [MailEngine:253] Message ID: null
10:49:26,024 DEBUG [MailEngine:254] In Reply To: null
10:49:27,117 WARN [MailEngine:482] Failed to connect to a valid mail server. Please make sure one is properly configured. Could not connect to SMTP host: localhost, port: 25
10:49:27,117 DEBUG [MailEngine:376] Sending mail takes 1094 ms


I think liferay is trying to send a mail notification when webcontent is created/updated.
As mail server is not configured it is giving the above error.

Am i correct?
But i want to disable this feature of sending a mail notification to the people who are having the Administratot role.

I added the following properties in portal-ext.properties.But nothing works.
pop.server.notifications.enabled=false
journal.email.article.added.enabled=false
journal.email.article.approval.granted.enabled=false
journal.email.article.approval.requested.enabled=false
journal.email.article.updated.enabled=false

journal.email.article.review.enabled=false
message.boards.email.message.added.enabled=false
message.boards.email.message.updated.enabled=false



Can anyone please help me to fix this issue.

Thanks in advance
Ram
Javier Sánchez
RE: Stop/Disable sending a mail notification when web content is created
February 21, 2013 6:42 AM
Answer
Ram A
RE: Stop/Disable sending a mail notification when web content is created
February 21, 2013 7:20 AM
Answer

Ram A

Rank: Junior Member

Posts: 76

Join Date: January 16, 2013

Recent Posts

Javier Sánchez:



Thanks Javier for the reply.

In the mentioned links they have given the steps for kaleo-web workflow settings.
That is already installed in my Liferay application server.

Now i want to stop sending the mail notifications to the members who are having Administrator role when web content is created.

Is it possible without unistalling the kaleo-web plugin?
Please help me to fix this issue.


Thanks ina advance
Ram A
Javier Sánchez
RE: Stop/Disable sending a mail notification when web content is created
February 21, 2013 8:17 AM
Answer

Javier Sánchez

Rank: New Member

Posts: 13

Join Date: January 8, 2013

Recent Posts

Hi Ram,

Can't you configure Kaleo to do not send notifications or disable Kaleo processes for Web Content? Take a look at these links:
http://www.liferay.com/documentation/liferay-portal/6.0/administration/-/ai/workflow-with-kal-2
http://www.liferay.com/web/juan.fernandez/blog/-/blogs/liferay-workflow-in-action

In the second link there is a comment where is specified how to add a notification to a workflow, you just has to do the opposite.

Regards
Ram A
RE: Stop/Disable sending a mail notification when web content is created
March 4, 2013 6:21 AM
Answer

Ram A

Rank: Junior Member

Posts: 76

Join Date: January 16, 2013

Recent Posts

Hi Javier,

Thanks for helping me to resolve tis issue.

This issue is fixed .

In control panel we can configure the workflow for webcontent portlet.

First deactivated the Single approver workflow by using default configurations in workflow in control panel.
Then selected the No workflow in the dropdown list for wen content portlet.

This fixed my issue.


Thanks and Regards
Ram A