Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Peter Dimitri
Can't install any plugins after upgrade to 6.1.1
February 27, 2013 2:45 AM
Answer

Peter Dimitri

Rank: Junior Member

Posts: 35

Join Date: January 9, 2013

Recent Posts

I just did a (test) upgrade of our current Liferay Portal from 6.0.1 CE to 6.1.1 CE GA2. I'm in the Administrator Role for the Portal, but when I now open the Control Panel, there is no Marketplace section, and in the "Plugins Installation" portlet, the button witch is usually labeled "Install more Portlets" is missing. This surely is a permission issue, but I can't find a way to grant the needed permission to install new portlets to myself (as said before: I'm in the Administrator role and should be allowed anything). In another forum post I saw a screenshot where there is a permission named "Plugins Installation" shown during Roles definition. I don't have this entry in the dropdown field while assigning permissions to roles.

Any Idea, how I could get the permission to install plugins?
David H Nebinger
RE: Can't install any plugins after upgrade to 6.1.1
February 27, 2013 5:46 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 6276

Join Date: September 1, 2006

Recent Posts

You have to download the private plugin installer through the marketplace.
Hitoshi Ozawa
RE: Can't install any plugins after upgrade to 6.1.1
February 27, 2013 6:00 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7990

Join Date: March 23, 2010

Recent Posts

As David replied, you're wrong about it being "surely a permission issue". Liferay.com "accidently" deleted plugin installer from Control Panel. So, you'll have to manually add it back in. Plugin installer is available as "Private Plugin Installer" from the Marketplace.

http://www.liferay.com/marketplace/-/mp/application/15474932?_7_WAR_osbportlet_backURL=%2Fmarketplace%3Fp_p_id%3D7_WAR_osbportlet%26p_p_lifecycle%3D0%26p_p_state%3Dnormal%26p_p_col_id%3Dcolumn-1%26p_p_col_pos%3D1%26p_p_col_count%3D2%26_7_WAR_osbportlet_mvcPath%3D%252Fmarketplace%252Fsearch.jsp%26p_r_p_564233524_assetCategoryId%3D0%26p_r_p_564233524_keywords%3Dprivate
Peter Dimitri
RE: Can't install any plugins after upgrade to 6.1.1
February 27, 2013 6:32 AM
Answer

Peter Dimitri

Rank: Junior Member

Posts: 35

Join Date: January 9, 2013

Recent Posts

OK, I'll try it.

But just one more comment: I've already read about the accidentally deletion of the plugin installer here at the forum. But I've used the exact same Liferay 6.1.1. CE GA 2 Tomcat Bundle twice in my test environment: Once as a fresh install for my development training, and once to upgrade our current live portal from 6.0.1 to 6.1.1. In the fresh install the Marketplace Portlet is available as well as the "Install more Plugins" Button. Only when I use this bundle to upgrade the portal from 6.01. to 6.1.1. the options for plugin installation are missing.
Peter Dimitri
RE: Can't install any plugins after upgrade to 6.1.1
February 27, 2013 7:10 AM
Answer

Peter Dimitri

Rank: Junior Member

Posts: 35

Join Date: January 9, 2013

Recent Posts

I installed the private plugin installer, and the server console says:

15:05:59,332 INFO [pool-2-thread-2][HookHotDeployListener:690] Hook for private-plugin-installer-hook is available for use


But still no Marketplace or "Install more plugins button" available in control panel.
Mindy Dixon
Automatic reply: [Liferay Forums][1. Installation / Deployment / Setup] RE:
February 28, 2013 10:12 PM
Answer

Mindy Dixon

Rank: New Member

Posts: 11

Join Date: January 13, 2011

Recent Posts

I will be out of the office with limited access to email today. I will get back to you as soon as possible. I will be returning on Thursday.
Mindy Dixon
Automatic reply: [Liferay Forums][1. Installation / Deployment / Setup] RE:
February 28, 2013 10:12 PM
Answer

Mindy Dixon

Rank: New Member

Posts: 11

Join Date: January 13, 2011

Recent Posts

I will be out of the office with limited access to email today. I will get back to you as soon as possible. I will be returning on Thursday.
Mindy Dixon
Automatic reply: [Liferay Forums][1. Installation / Deployment / Setup] RE:
February 28, 2013 10:12 PM
Answer

Mindy Dixon

Rank: New Member

Posts: 11

Join Date: January 13, 2011

Recent Posts

I will be out of the office with limited access to email today. I will get back to you as soon as possible. I will be returning on Thursday.
Mindy Dixon
Automatic reply: [Liferay Forums][1. Installation / Deployment / Setup] RE:
February 28, 2013 10:12 PM
Answer

Mindy Dixon

Rank: New Member

Posts: 11

Join Date: January 13, 2011

Recent Posts

I will be out of the office with limited access to email today. I will get back to you as soon as possible. I will be returning on Thursday.
Mindy Dixon
Automatic reply: [Liferay Forums][1. Installation / Deployment / Setup] RE:
February 28, 2013 10:12 PM
Answer

Mindy Dixon

Rank: New Member

Posts: 11

Join Date: January 13, 2011

Recent Posts

I will be out of the office with limited access to email today. I will get back to you as soon as possible. I will be returning on Thursday.
Dylan Kusters
RE: Can't install any plugins after upgrade to 6.1.1
October 25, 2013 6:03 AM
Answer

Dylan Kusters

Rank: Junior Member

Posts: 78

Join Date: February 7, 2013

Recent Posts

Dear Peter,

Have you already found a solution for the "Install more portlets" button issue?

Kind regards,
Dylan